-   Slackware (
-   -   Unable to build webkitgtk (

trademark91 03-15-2012 09:56 PM

Unable to build webkitgtk
Every time I try to build webkitgtk, the compilation fails with the following error:


JavaScriptCore/wtf/ByteArray.cpp: In static member function ‘static WTF::PassRefPtr<WTF::ByteArray> WTF::ByteArray::create(size_t)’:
JavaScriptCore/wtf/ByteArray.cpp:34:54: error: expected type-specifier before ‘ptrdiff_t’
JavaScriptCore/wtf/ByteArray.cpp:34:54: error: expected ‘>’ before ‘ptrdiff_t’
JavaScriptCore/wtf/ByteArray.cpp:34:54: error: expected ‘(’ before ‘ptrdiff_t’
JavaScriptCore/wtf/ByteArray.cpp:34:54: error: ‘ptrdiff_t’ was not declared in this scope
JavaScriptCore/wtf/ByteArray.cpp:34:54: note: suggested alternative:
/usr/lib64/gcc/x86_64-slackware-linux/4.6.2/../../../../include/c++/4.6.2/x86_64-slackware-linux/bits/c++config.h:156:28: note:  ‘std::ptrdiff_t’
JavaScriptCore/wtf/ByteArray.cpp:34:88: error: expected ‘)’ before ‘]’ token
JavaScriptCore/wtf/ByteArray.cpp:34:89: error: expected ‘]’ before ‘;’ token
make[1]: *** [JavaScriptCore/wtf/libJavaScriptCore_la-ByteArray.lo] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/tmp/SBo/webkit-1.3.4'
make: *** [all] Error 2
rm DerivedSources/WebCore/JSSVGFilterPrimitiveStandardAttributes.cpp DerivedSources/WebCore/JSSVGTests.cpp DerivedSources/WebCore/JSSVGURIReference.cpp DerivedSources/WebCore/JSSVGExternalResourcesRequired.cpp DerivedSources/WebCore/JSSVGTransformable.cpp DerivedSources/WebCore/JSSVGZoomAndPan.cpp DerivedSources/WebCore/JSSVGAnimatedPathData.cpp DerivedSources/WebCore/JSSVGFitToViewBox.cpp DerivedSources/WebCore/JSSVGViewSpec.cpp DerivedSources/WebCore/JSSVGLocatable.cpp DerivedSources/WebCore/JSSVGAnimatedPoints.cpp DerivedSources/WebCore/JSSVGStylable.cpp DerivedSources/WebCore/JSElementTimeControl.cpp DerivedSources/WebCore/JSSVGLangSpace.cpp

this is the third time I've tried to do this, and it takes about 2 hours before it reaches this error, so I'm not really able to try a bunch of little tweaks to try to fix it myself. Has anyone encountered compile errors similar to this, and if so, what have you done to fix it? Im running slackware -current x64 with multilib.

WhiteWolf1776 03-16-2012 10:03 AM

From here:

it looks like, since you are using GCC 4.6

You will need to patch these.
Include to <stddef.h> must be replace by <cstdef>.

The post is for a different app, but the same error makes me think it is likely the same issue.

trillobyte 03-16-2012 06:34 PM

I was able to build webkitgtk-1.3.4 in stable. I'm using GCC4.5 so it looks like this may be the problem.

Best regards

trademark91 03-17-2012 11:47 PM

Thanks. I installed alienbob's package, because I didnt want to deal with patching or downgrading gcc.

All times are GMT -5. The time now is 02:40 PM.