-   Slackware (
-   -   Unable to build from Slackbuild in slackware 13 (

troj3n 01-28-2010 08:26 AM

Unable to build from Slackbuild in slackware 13
Hi Guys

I installed slackware 13 i386 reacently

i was trying to build wvstreams and wvdial

when i give the ./wvdial.Slackbild it runs for quite some time and at the end while creating the package it gives me an error cannot find gzip compression utility in $PATH. and there is no tgz or txz package in /tmp folder

then i ran pkgtool and found that gzip isnt installed. the i installed it from the slackware dvd. but still i am getting the same error

Please help me at the earlies

Thank you all in advance

Best Regards

ponce 01-28-2010 08:49 AM

you can verify the PATH environment variable you are using in the shell from which you execute the slackbuild with this command

set | grep PATH | grep bin
blind guessing, maybe you have some ~/.bashrc ~/.bash_profile or /root/.bashrc /root/.bash_profile that set differently your PATH variable.
try also becoming root with the command

su -
so that the root user get his correct PATH env var.

MS3FGX 01-28-2010 08:59 AM

If you were missing gzip, then that tells me either something went wrong with the install or otherwie somebody tried to go in and remove packages they though they wouldn't need.

In either event, SlackBuilds are designed to be used on full Slackware installs. It is assumed that you are starting from a full, stock, Slackware system. Anything else, and you are pretty much on your own.

I think your first step should be to go through your installed packages and see just what is missing, of if you would rather, reinstall and make sure you choose a full installation. You can always go back and remove things you are sure you don't need on your desktop (like Apache and sendmail) later, but at least this way you are sure all the core components are installed before doing anything else.

troj3n 01-28-2010 09:37 AM

the path of the appliccation gzip is given there when i do the command u said

what else can be done

ponce 01-28-2010 09:42 AM

can you please issue the command

file /bin/gzip
and post the output?

knudfl 01-28-2010 10:38 AM

No problems with either, wvstreams, wvdial on my Slackware 13, "i486".
So it isn't a bug in the wvdial files.

'gzip' is not used at compile time, but for the final
gzipping the package, wvdial-1.60-i486-1_SBo.tgz .

You can get the Slackware packages from

wvdial - 1.60 > >
> >
> wvdial-1.60-i686-5bj.txz

All times are GMT -5. The time now is 03:20 PM.