Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 10-22-2011, 02:38 AM   #1
Registered: Aug 2010
Distribution: Debian Sid, openSUSE, Gentoo, Slackware64
Posts: 68

Rep: Reputation: 2
Unable to boot: LVM setup on external HDD with separate /boot

Hi all,
I have installed Slackware 13.37 on my external harddisk with LVM setup. I have followed README_LVM except that I've a separate /boot partition. The external harddrive is recognised as /dev/sdb and I have installed LILO on MBR of /dev/sdb.

I've LVM setup in my laptop's internal harddrive too.

My problem is when I boot, only my internal harddrive's VG is recognised but not external drive's. Hence, I'm not able to boot into Slackware.

I repartitioned my external drive and reinstalled Slackware thinking I might have done some mistake. But to no avail.

The following is the error message I get during booting.
/boot/initrd.gz: Loading kernel modules from initrd image: 4 logical volumes in volume group 'sv' now active.
mount: mounting /dev/S160/root on /mnt failed: No such file or directory.
ERROR: No /sbin/init found on rootdev (or not mounted). Trouble ahead. You can try to fix it. Type 'exit' when things are done.
Here is my lilo.conf:
# LILO configuration file
# generated by 'liloconfig'
# Start LILO global section
boot = /dev/sdb
  bitmap = /boot/slack.bmp
  bmp-colors = 255,0,255,0,255,0
  bmp-table = 60,6,1,16
  bmp-timer = 65,27,0,255
append=" vt.default_utf8=0"
timeout = 50
vga = normal
# End LILO global section

# Linux bootable partition config begins
image = /boot/vmlinuz-generic-
  initrd = /boot/initrd.gz
  root = /dev/S160/root
  label = Slackware
  read-only  # Partitions should be mounted read-only for checking
# Linux bootable partition config ends
Any ideas? Thanks in advance.
Old 10-22-2011, 05:56 AM   #2
Senior Member
Registered: May 2008
Posts: 4,437
Blog Entries: 7

Rep: Reputation: 1890Reputation: 1890Reputation: 1890Reputation: 1890Reputation: 1890Reputation: 1890Reputation: 1890Reputation: 1890Reputation: 1890Reputation: 1890Reputation: 1890
Are we talking external USB drive here? If so then it may be that you're not allowing enough time for the drivers to load. Setting the WAIT= option of the initrd will give the kernel time to do its thing. You may also need to load any modules necessary for use with USB harddisks (My external is an esata therefore I don't know what they;ll be off-hand, so you'll have to research that)
Old 10-22-2011, 12:21 PM   #3
Registered: Aug 2010
Distribution: Debian Sid, openSUSE, Gentoo, Slackware64
Posts: 68

Original Poster
Rep: Reputation: 2
It is my old laptop harddrive (scsi) which I have put in an external case with usb interface. So, I guess its USB drive? I tried the following (I'm quoting from memory now. Don't mind if it has error. I typed correctly on my system :-)
mkinitrd -c -k -m ext3:ehci_hcd:uhci_hcd:usbhid -f ext3 -r /dev/S160/root -L -w 120
It did not help. Then I added scsi_transport_fc (as seen on my centos /proc/modules) to module list. I don't know what it is but looks like some scsi related module. Not OK.

I put root = /dev/sdb1. Not OK. This time error for mount: no /etc/mtab...

Thinking the problem may be with separate /boot partition, I even copied contents of /boot (/dev/sdb1) to my root partition itself with
cp -rfL /tmp/slack-boot/* /tmp/slack/boot/
and ran the mkinitrd again. Still no luck. All these time I have been running /sbin/lilo eachtime I run mkinitrd or edit /etc/lilo.conf

The VG on my laptop's internal HD is recognized but not the VG on my external HD. :-(

Last edited by saivnoba; 10-22-2011 at 12:35 PM.
Old 10-25-2011, 08:55 AM   #4
Registered: Aug 2010
Distribution: Debian Sid, openSUSE, Gentoo, Slackware64
Posts: 68

Original Poster
Rep: Reputation: 2
Here is an update:
I reinstalled Slackware (LVM setup on external hdd), this time *without* a separate /boot. Same problem. But I re-read the README_LVM and decided to try mkinitrd-generator script. The correct module name was usb-storage and not usbhid :-) After executing this mkinitrd, I was able to login to Slackware.. :-D

However, my problem is for from over. I again re-installed *with* a separate /boot. I tried mkinitrd generator script but am not able to boot into Slackware. This time the error message is:
VFS: Cannot open root device "fd01" or unknown-block (253,1).
Please append a correct "root=" boot option. Here are the available partitions..
It only displays internal hard-drive (sda) partitions. Not my external harddrive's. I tried both "root = /dev/sdb1" and "root = /dev/S160/root". Both don't work.

Last edited by saivnoba; 10-25-2011 at 08:59 AM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
DUAL BOOT Backtrack Linux & Windows XP Pro from separate HDD's with GRUB nam5301 Linux - Newbie 1 02-10-2011 09:05 PM
[SOLVED] Boot from a separate external partition? lozontheweb Linux - General 3 11-15-2010 05:45 AM
I installed ubuntu 9.04 to my Maxtor external hdd. I have no internal hdd. I can boot dont33 Linux - Newbie 1 08-13-2009 04:13 PM
Dual boot XP(internal IDE HDD) Debian(external USB-IDE HDD) using boot.ini PolarDog Linux - Laptop and Netbook 2 07-01-2005 09:50 PM
Dual boot with separate HDD darrenjhopkins Linux - Newbie 4 10-19-2004 09:59 AM > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:35 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration