-   Slackware (
-   -   unable to aquire agp (

Kane2002 02-12-2005 12:18 PM

unable to aquire agp
hey guys
well since i got my dual screen setup working, i decided id have a go at "trying" to set up the ati drivers.

slackware 10
xorg 6.8.1
Primary Video Card: Ati radeon 9500
Secondary: nvidia geforce2 mx440

well i downloaded the package, installed them (did the make , make install or whatever)
and it came up and said it loaded fine but it might taint the kernel or something.

so i run fglrxconfig to see if they had worked ... ran through it and tried the new config ...but i got lots of errors.

so then i thought instead of creating a new config i would just use my config which worked but replace the Drivers part with "fglrx" (seen as these are the ati drivers i just installed? )

well here are the errors i get:
(EE) fglrx(0): [agp] unable to acquire AGP, error "xf86_ENOMEM"
(EE) fglrx(0): cannot init AGP

i uploaded my log file and xorg config: (i know this config worked ...and so the only thing i changed was the part where it now says Driver "fglrx" ... whereas in my original working config this was "ati")

and the log file:

any ideas?

thanks alot

edit:: i just read through the log file again and noticed this also

(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed! *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO) *
(WW) fglrx(0): * no 3D acceleration available *
(WW) fglrx(0): ********************************************* *

Kane2002 02-12-2005 05:48 PM

well ive jsut followed the howto on installing ATI's drivers (provided by the rage3d forums i think)

followed it TO THE LETTER.
(although there was one part - "enable chipset agp driver as (M)" - and im guessing this meant the nforce2 agp driver .... i couldnt find it in the make menuconfig)
and i ran through the fglrxconfig, selected to use the kernel AGPGART, copied it to xorg.conf

and bam ... nothing ...just a blank screen with no errors and then just a message at the bottom saying it got a fatal error or something.
i can seem to find it in the logs.

**sigh** ... where should i go from here?

oh btw - i tried then trying to use my working xorg.conf (on the newly compiled kernel with everything "supposedly" needed for the ati drivers) after i couldnt get the new config to work ...and it started but the mouse and icons were pretty much screwed up. so im back on the old kernel now.

any ideas?


Kane2002 02-13-2005 09:33 AM


almost there i think:

well i have managed to get a xorg config that works with the ati drivers ....

but when i try to enter the ati drivers into my current config ... i get an error:
X10: fatal IO error 104 (connection reset by peer) on X serve ":0.0" after 0 requests (0 known processes) with 0 events remaining.

so i disabled the load dri bit in the config (commented out) and it starts ...but i have no ati drivers ...when i do fglrxinfo it still says mesa.
here is my working config with dual screen (no ati drivers working)

and here is the one screen working with the ati drivers :

can anybody see why the first one wouldnt work without the dri part being commented out?

if not ....does this mean im gunna have to copy the parts i need from the working ati drivers into my working dual screen setup?

im getting excited :p

Thanks Alot

Kane2002 02-13-2005 09:50 AM

ah well i decided to just have a go at combining the two and....


i just dont understand though ... because nothing has changed since yesterday (besides a reboot) ... and yesterday i couldnt even get the ati drivers working on their own.

strange .....

thanks alot guys

capnpayne 02-13-2005 12:37 PM

I'm not completely sure of what you did either... Could you rephrase a bit?

You're not using external agpgart? I usually build ATi's module and use that.

Kane2002 02-13-2005 04:01 PM

im not using ati's agpgart because on the howto it says that it was "unknown" wether it worked or not, but it said that the kernel agpgart module worked fine (so i was being safe rather than sorry :p)

and its a bit hard to rephrase because ... i have no idea what i did lol.

but heres what i did:

recompiled the kernel making sure
/dev/agpgart was selected as a module
made sure MTRR (cant remember what this stand for) was enabled
and then made sure dri was disabled in the kernel .

rebooted - booted into the new kernel.
tried installing the ati drivers and then built the module like it says in the howto, worked fine (ie installed without any errors), then i did fglrxconfig (when using this config i got some errors)

so then i tried putting fglrx (ati drivers) into my working config file. still got errors.
commented out dri in the config file. and included "userinternalagpgart" "no";

it worked (ie monitors came on)... but still mesa when fglrxinfo was used.

re- went through the fglrxconfig

then i did /sbin/insmod agpgart (even though i had done lsmod and saw that agpgart was loaded)

and it worked :/

and i still have no idea why it did ... lol :p


capnpayne 02-13-2005 04:35 PM

Did you mv XFree86-whatever (generated by fglrxconfig) > xorg.conf ? I get the impression that you did, but if you didn't and just changed a field in the default xorg.conf, then you wouldn't actually be using ATi's stuff. (just checking)

Kane2002 02-13-2005 04:41 PM

yes i did :p

and i know its working because im getting 1500fps in glxgears as apposed to the measly 200 i got before :D

All times are GMT -5. The time now is 03:02 PM.