-   Slackware (
-   -   Unable to access internet through wifi. (

info.latawaz 06-12-2013 08:29 AM

Unable to access internet through wifi.
Hi Guys,

I have just installed slackware 14 64-bit and I am new to everything in linux. So I was trying to connect to my wifi but it wont work.

I have dell studio 1558 with "Dell Wireless 1520 Wireless-N WLAN mini card". Issuing

and it shows wlan0 as that adapter that I have

Now i am not able to understand as to what to do.

Looking forward to your answers.


schneidz 06-12-2013 08:38 AM

you dont show us the output of your iwconfig command; this information mite be helpful in diagnosing:

echo uname: && uname -a -m -p && echo lspci: && lspci && echo lsusb: && lsusb && echo lsmod: && lsmod && echo ifconfig: && ifconfig && echo ifconfig -a: && ifconfig -a && echo iwconfig: && iwconfig && echo resolv.conf: && cat /etc/resolv.conf && echo route: && route -n

mrclisdue 06-12-2013 08:49 AM

Are you using X at all? ie, KDE or XFCE, etc., or are you cli only?

The reason I ask is that it *may* be simpler (as in: more intuitive) vs the cli for a newbie. If you are running X, you may want to consider using either networkmanager or wicd to get your wireless up and running.

Either way, welcome to Slackware in particular, and Linux in general. The folks here are extremely helpful, knowledgeable, and most importantly, very patient. So come on aboard.


schneidz 06-12-2013 08:56 AM

true the gui is more intuitive but without knowing which distro version / desktop environment / window manager / network manager utility / ... its hard to give instruction (i am also, assuming they tried the obvious like selecting their wifi router from the dropdown menu but it didnt work).

if you would like to read ahead in the curriculum, you can try these commands to connect via the command line:

sudo iwlist <network-card> scan # this will use the <network-card> interface (that from the iwconfig command above) and scan for wireless routers that are accessible.
sudo iwconfig <network-card> essid <your-router-name> # assuming no security (the access point names will be provided by the previous iwlist command).
sudo dhclient # will attempt to get ip-address, subnet mask, dns server information automatically from your router assuming dhcp is turned on on your router.

hitest 06-12-2013 09:04 AM

As you are new to Slackware I would go with either networkmanager or wicd. The wicd utility is in the /extra directory on your Slackware DVD.

info.latawaz 06-12-2013 10:16 AM

2 Attachment(s)
Schneidz, the output of iwconfig and the long command that you wrote are in the attached files.

mrclisdue, I appreciate your welcome and yes I have installed KDE. Infact, I have done the default complete installation since I don't have the depth of slackware to mess around.

hitest, I tried wicd which is there when it boots up to the desktop and selected wlan0 but nothing was shown or maybe I am not aware of the next step.

Thanks for the response guys.

schneidz 06-12-2013 10:58 AM

try running

sudo ifconfig wlan0 up && ifconfig
and let us know if you get any errors.

this seems related:

is there a physical switch on the laptop case that needs to be turned on ?

mrclisdue 06-12-2013 11:35 AM


Originally Posted by schneidz (Post 4970374)
try running

sudo ifconfig wlan0 up && ifconfig
and let us know if you get any errors.

However, "sudo" has to be configured in Slackware in order to prevent the careless (as in "freely using what are often root privileges") use of root permissions.

As per your output, wlan0 appears to be up and running, however, issue the ifconfig wlan0 cmd provided by shneidz, then:

iwlist wlan0 scan

the output should show access points within range.

As pointed out earlier, it's at this point that the cli requires specific input in order to connect. Once the output of iwlist is considered, this additional input can be added to ifconfig, iwconfig, etc.

If you follow the link provided by shneizd, you'll find his posts with the proper cli method for connecting (just drop to root unless you've got sudo configured.)

The initial complexity of connecting via cli is why it's been suggested to connect using X, initially, then once it's confirmed to work, the cli can be explored more easily, and further.

In either case, more info is necessary, and the more info, the better. so please continue along either or both paths.

Using wicd/networkmanager, you've indicated that it shows wlan0, but nothing else. Normally the wicd window should show a list of available ap' the "scan" button alive? (as in not greyed-out)


info.latawaz 06-13-2013 10:38 AM

wlan0 no private ioctls
1 Attachment(s)
I have attached the screenshot of this error. I think its driver related.

And I do have wifi which is protected with


Security Mode: WPA2-Personal
Encryption: TKIP or AES
Broadcast disabled
I can associate with my router's ESSID but I am not able to figure out how and where to enter PSK.

Also, I am able to scan with my interface and I can see a few AP's.

As far a WICD is concerned, after selecting wlan0 and clicking on 'Apply', nothing new is shown and nothing changes.

Please let me know if you need more information on this.

I am focussing on command line because I like to use command line :D Once I am able to connect with the command line, I can surely search from there and see how to use WICD or vice-versa.

Right now, I have to restart into Slackware to find the desired output, and since I am unable to use internet there, I have to again restart into windows.

schneidz 06-13-2013 11:21 AM

i dont use wpa... but i think you need a program called wpa_supplicant in order to enter in the wpa hex-key.

info.latawaz 06-13-2013 08:06 PM


Originally Posted by schneidz (Post 4971090)
i dont use wpa... but i think you need a program called wpa_supplicant in order to enter in the wpa hex-key.

Thanks, I am looking into wpa_supplicant. I'll come back with my findings.

Appreciate your help on this!

rkelsen 06-13-2013 09:55 PM

Easy. See this post here:

info.latawaz 06-13-2013 11:42 PM

2 Attachment(s)
Worked with wpa_supplicant by following with no luck. Attaching screenshots of the problem that I am facing.

rkelsen, I'll give your solution a try. Thanks :D

info.latawaz 06-14-2013 12:52 AM

1 Attachment(s)

Originally Posted by rkelsen (Post 4971413)

Did that, received an error. I have attached the screenshot of error. What do you think is the problem?

allend 06-14-2013 01:24 AM

You are trying to use a device that needs a firmware that is not part of default Slackware.
Hence the ioctls errors in your commands.jpeg screenshot.
You will need to install the b43-firmware and b43-fwcutter packages from

All times are GMT -5. The time now is 08:03 AM.