LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-17-2008, 04:06 PM   #1
phodopus
Member
 
Registered: Aug 2006
Location: Belgium
Distribution: Slackware 13.0
Posts: 62

Rep: Reputation: 15
Unable to access folder


Hello,

I'm using Slackware 12 on a Dell Vostro 1000 laptop.

fstab:

Code:
/dev/sda5        swap             swap        defaults         0   0
/dev/sda2        /                ext3        defaults         1   1
/dev/sda2        /windowsxp       ntfs-3g     umask=077        1   0
#/dev/cdrom      /mnt/cdrom       auto        noauto,owner,ro  0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
tmpfs            /dev/shm         tmpfs       defaults         0   0
I'm always logged in as "Hendrik", not "root". Main reason: I can't run VLC as root.

All my music is stored on /dev/sda2 and mounted under /windowsxp.

My problem:

I can't access /windowsxp if I'm using "Hendrik".

This is what I tried:
Code:
su
password: **************
chmod 755 /windowsxp
but this doesn't give me rights to access (read is enough) to access the required partition.

What am I doing wrong?

Regards,

Hendrik.
 
Old 12-17-2008, 04:15 PM   #2
ErV
Senior Member
 
Registered: Mar 2007
Location: Russia
Distribution: Slackware 12.2
Posts: 1,202
Blog Entries: 3

Rep: Reputation: 62
Quote:
Originally Posted by phodopus View Post
What am I doing wrong?
You can't chmod files on ntfs partitions. Try to specify group in ntfs partition settings. For details see ntfs-3g manual.
 
Old 12-17-2008, 04:16 PM   #3
phodopus
Member
 
Registered: Aug 2006
Location: Belgium
Distribution: Slackware 13.0
Posts: 62

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by ErV View Post
You can't chmod files on ntfs partitions. Try to specify group in ntfs partition settings. For details see ntfs-3g manual.
That explains a lot, I'll respond soon!
 
Old 12-17-2008, 04:17 PM   #4
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,184

Rep: Reputation: 5167Reputation: 5167Reputation: 5167Reputation: 5167Reputation: 5167Reputation: 5167Reputation: 5167Reputation: 5167Reputation: 5167Reputation: 5167Reputation: 5167
Quote:
Originally Posted by phodopus View Post
Hello,

I'm using Slackware 12 on a Dell Vostro 1000 laptop.

fstab:

Code:
/dev/sda5        swap             swap        defaults         0   0
/dev/sda2        /                ext3        defaults         1   1
/dev/sda2        /windowsxp       ntfs-3g     umask=077        1   0
#/dev/cdrom      /mnt/cdrom       auto        noauto,owner,ro  0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
tmpfs            /dev/shm         tmpfs       defaults         0   0
For read-only user access, use a line of
Code:
/dev/sda2        /windowsxp       ntfs     umask=022        1   0
Quote:

I'm always logged in as "Hendrik", not "root". Main reason: I can't run VLC as root.
This was a choice made by the VLC team, but you can recompile VLC and add
Code:
--enable-run-as-root
to the "configure" command for VLC.


Eric
 
Old 12-17-2008, 04:48 PM   #5
svetlio0o
LQ Newbie
 
Registered: Oct 2007
Distribution: slackware 12.2
Posts: 16

Rep: Reputation: 0
Quote:
Originally Posted by phodopus View Post
fstab:

Code:
/dev/sda2        /                ext3        defaults         1   1
/dev/sda2        /windowsxp       ntfs-3g     umask=077        1   0
I think I see /dev/sda2 added two times. Once as an ext3 partition and the second - ntfs-3g.. May be this can help
 
Old 12-17-2008, 04:57 PM   #6
phodopus
Member
 
Registered: Aug 2006
Location: Belgium
Distribution: Slackware 13.0
Posts: 62

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by svetlio0o View Post
I think I see /dev/sda2 added two times. Once as an ext3 partition and the second - ntfs-3g.. May be this can help
Thanks for the little tip, while being to enthousiastic with copy pasting in my fstab, I made that mistake, making it impossible to even mount /windowsxp being logged in as root (a).

One problem less... I guess:

mount -a (again!) and voila, /windowsxp is back, for root...

Now I proceed for the "Hendrik" part

BTW:

Alien Bob, thanks for your response. btw, are you dutch?
 
Old 12-17-2008, 05:02 PM   #7
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,184

Rep: Reputation: 5167Reputation: 5167Reputation: 5167Reputation: 5167Reputation: 5167Reputation: 5167Reputation: 5167Reputation: 5167Reputation: 5167Reputation: 5167Reputation: 5167
Quote:
Originally Posted by phodopus View Post
Alien Bob, thanks for your response. btw, are you dutch?
The "Location: Eindhoven, The Netherlands" to the left of this post would be a small hint wouldn't it?

Eric
 
Old 12-17-2008, 05:14 PM   #8
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,383
Blog Entries: 55

Rep: Reputation: 3558Reputation: 3558Reputation: 3558Reputation: 3558Reputation: 3558Reputation: 3558Reputation: 3558Reputation: 3558Reputation: 3558Reputation: 3558Reputation: 3558
Quote:
Originally Posted by Alien Bob View Post
This was a choice made by the VLC team, but you can recompile VLC
If developers release something that should not run as root then they probably have a good reason for it...


Quote:
Originally Posted by phodopus
I'm always logged in as "Hendrik", not "root". Main reason: I can't run VLC as root.
...but in essence you shouldn't use root for tasks other than systems administration anyway.
 
Old 12-17-2008, 05:47 PM   #9
ErV
Senior Member
 
Registered: Mar 2007
Location: Russia
Distribution: Slackware 12.2
Posts: 1,202
Blog Entries: 3

Rep: Reputation: 62
Here is example fstab line for ntfs partition.
Code:
/dev/hdc1	/mnt/common	ntfs-3g		defaults,locale=ru_RU.UTF8,gid=users,fmask=113,dmask=003 1 0
Partition is writeable/readable for all users. Of course, you can remove locale option or replace it with your own.
 
Old 12-18-2008, 03:11 AM   #10
phodopus
Member
 
Registered: Aug 2006
Location: Belgium
Distribution: Slackware 13.0
Posts: 62

Original Poster
Rep: Reputation: 15
Thanks, ErV. I didn't think I had to modify fstab to fix the problem. It can access it now, problem solved.

Thanks to all!
 
Old 12-18-2008, 06:05 AM   #11
svetlio0o
LQ Newbie
 
Registered: Oct 2007
Distribution: slackware 12.2
Posts: 16

Rep: Reputation: 0
I want to ask if there's a way to mount removable devices as readable/writeable partitions as user(not root)
The HAL daemon does that but the partition is only readable. Every time you have to su to root in order to write a file (a bit annoying) ...
 
Old 12-18-2008, 07:27 AM   #12
appzer0
LQ Newbie
 
Registered: Nov 2008
Location: France
Distribution: 0Linux, Slackware
Posts: 13

Rep: Reputation: 0
We are out of topic but you may try to add your user account to the 'plugdev' group in /etc/group. Sorry for my English.
 
Old 12-18-2008, 08:49 AM   #13
ErV
Senior Member
 
Registered: Mar 2007
Location: Russia
Distribution: Slackware 12.2
Posts: 1,202
Blog Entries: 3

Rep: Reputation: 62
Quote:
Originally Posted by svetlio0o View Post
I want to ask if there's a way to mount removable devices as readable/writeable partitions as user(not root)
The HAL daemon does that but the partition is only readable. Every time you have to su to root in order to write a file (a bit annoying) ...
You should be included in "plugdev" group. Line in fstab also helps.

Last edited by ErV; 12-18-2008 at 08:50 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to See Folder on AIX-Very Urgent siesta_help AIX 3 09-05-2008 12:16 AM
folder access folder taze Linux - Security 7 03-19-2006 08:05 PM
Folder Max Size and Limiting SSH access to home folder. Mefistofeles Linux - General 4 11-26-2005 02:09 PM
unable to open Home folder umeshchandra Linux - Software 2 10-03-2005 05:30 PM
Unable to delete folder arctuniol Red Hat 2 10-11-2004 02:07 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 05:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration