-   Slackware (
-   -   UEFI installation problem (

pchristy 03-13-2019 10:18 AM

UEFI installation problem
My old laptop is well past its sell-by date, so I've purchased a new one, a Clevo N141ZU. I'm trying to install Slackware-current on it, but getting nowhere!

My main desktop machine is also UEFI, and I had no problems installing on that, using a pendrive created with AlienBob's program.

Using the same technique on the laptop, the pendrive boots, the initrd image loads, and then everything just hangs - stops dead!

I tried creating a pendrive from scratch using the information in the README_UEFI.txt file. The drive was recognised as a UEFI bootable drive, but just produced a "Boot failed" error message!

Finally, I tried creating a GPT formatted 8GB vfat partition on the pendrive, copied the contents of my working AlienBob pendrive across to it, and marking it EFI system. This produced exactly the same result as the original (AlienBob) pendrive! The kernel and initrd loaded, but immediately hung.

I also tried a Mageia6 install pendrive (uses grub instead of elilo). Again, grub loaded everything and then hung!

There must be some way round this! Secure boot is disabled, and I am out of ideas!

Anyone got any clues?



pchristy 03-13-2019 10:53 AM

A bit more info: There is a company in Germany supplying these with Linux pre-installed, so it IS possible! Also, I did the initial disk partitioning using systemrescuecd on a pendrive, BUT, version 5.X hung - exactly as per slackware, but the latest version (6.X) works fine. Between versions 5 and 6, they've switched to using Arch as the core system.


chrisVV 03-14-2019 06:13 PM

I don't know what the script to which you refer does, but I make my bootable USB sticks with an installable slackware binary distribution included on them this way:

1. Using gdisk delete all existing partitions on the stick (if any), then make a first partition (partition 1) on it of around 200Mb and have the remainder as a separate partition (partition 2) - partition 2 probably needs to be at least 3GB these days, possibly more.

2. Set the partition type of partition 1 to EFI System Partition (EF00).

3. Set the partition type of partition 2 to Linux data (8300), then save all this and exit gdisk.

4. Format partition 1 to VFAT, and partition 2 to ext4.

5. Mount the slackware USB image in usb-and-pxe-installers on loopback with 'mount -o loop usb-and-pxe-installers/usbboot.img /mnt/loop' and mount partitions 1 and 2 of the USB stick.

6. Copy everything under /mnt/loop to the mount point of partition 1.

7. Assuming you are using slackware64-current, copy slackware64-current/slackware64 to the mount point of partition 2 (or do the equivalent for slackware64-14.2/slackware64).

You should then be able to boot off partition 1, and then when booted mount partition 2 and use it to install slackware.

If you can't boot off partition 1 at all then it looks as if your UEFI firmware is not set to allow a boot off a USB stick: if so, there is probably a setting you can make to allow such a boot (there is on my laptop).

pchristy 03-15-2019 03:52 AM

Hi Chris, and thanks for your input. (BTW, I'm in the UK, so your response only arrived late last night, our time, hence the delay replying!)

Yes, I've tried most of what you've suggested. The laptop does boot from a USB stick, and is advertised in Germany as "Linux Friendly" (all Intel chipsets). However, there is something odd about it as some Linux systems run, and some don't! For example, systemrescuecd-6.0.2 (Arch linux based) loads and runs perfectly, whereas the earlier version (5.X, based on ?) hangs exactly the same way that Slackware does. The latest version of Clonezilla (Debian based) loads and runs. Mageia 6 (grub loader) hangs just like Slackware.

When I try and run the Slackware USB stick (created with the script on the usb-and-pxe-installers folder - which worked fine on my desktop UEFI machine), the stick boots and prompts me to choose the kernel. Picking either huge.s or kms.s then produces a message saying the kernel is loading, followed by the initrd loading. Once the initrd is loaded, the cursor moves down a line, then everything just freezes! The only way out of it is to turn the power off.

I've tried creating a boot stick using the method in the UEFI.readme file, and that simply produced a "boot failure" message (from the BIOS?). The BIOS is by Insyde, and doesn't seem to offer a legacy mode. Secure boot and fast boot are both disabled. I've also tried various methods found by googling, but so far nothing has worked.

I've always believed that a text based installer was easier to fault find in cases like this as you could see what was going on, but this has me stumped! Part of the problem is that I don't know (never needed to before!) precisely how the installer works. From what I've managed to read about older versions of Slackware, the initrd contains the scripts needed to start the install process. The system appears to hang at this point. If I could find out what was inside the initrd, I might be able to try a few things.

I did find a thread for older versions of Slackware that suggested adding a .gz to the initrd name, and unzipping it, but this doesn't work for -current (not a gzip file). Could be .xz, perhaps? Does anyone know?

I find it hard to believe that its something in the kernel configuration. I feel its more likely to be something in the initrd that is causing the system to hang. Either that, or it can't find the contents of the initrd once they are loaded.

This is something that needs addressing. This is a new generation machine, as far as I can gather, and it is likely that this issue will become more common in future. I have emailed Pat, but so far no response.

Any further suggestions most welcome!


Nille_kungen 03-15-2019 04:23 AM

I recently had problems booting liveslack created with on one new laptop with Insyde H20 bios but i was able to boot ubuntu.
My laptop hanged when changing from efifb.
My problem was that i had changed to "Secure Boot" "disabled" while it did make the usbstick show in F12 boot meny it always hanged during boot.
I had to enable secure boot and then choose "Select an UEFI file as trusted" and then browse and select the .efi file on the medium, then it booted as it should.
The reason for ubuntu to work but not slackware comes down to default UEFI keys and laptop not booting with secure boot disabled.
To make things harder i needed to set an bios password to be able to chance anything UEFI or add trusted files, since i didn't want an bios password at this stage i changed it to a blank password once i had selected trusted file or changed uefi settings.
On my older laptop everything works with secure boot disabled.
Every time i buy a new laptop it's harder to install linux on it, while the hardware support often is better these days the install process and all quirks makes the install much more complicated.
I also needed to add pci=noacpi to grub but thats because it's Raven Ridge Ryzen.

pchristy 03-15-2019 05:29 AM

Nille: Thanks very much for that information! Its very useful! I shall try it at once!

Perhaps this information needs to be added to the UEFI.readme file if it works for me too!

Watch this space - I shall report back shortly!



pchristy 03-15-2019 06:18 AM

Hmm! Not having much luck here!

I set a BIOS admin password (and a user one too, as a precaution), but the only way to activate secure boot was to select "Restore Secure Boot to Factory Settings". The other option was "Erase all secure Boot Settings", but I haven't tried that yet. Resetting to factory enables Secure Boot, but also indicates that the Secure Boot database is installed and locked. User Customized Security shows as enabled. I next navigated to the /EFI/BOOT/ folder on my pendrive and set BOOTX64.EFI as trusted for execution.

The result is exactly the same as before! The pendrive boots, the kernel is loaded, the initrd loads, then everything stops.


I was sure this sounded like a solution, too!

I am puzzled by the database reporting installed and locked, as this implies it isn't possible to add a new file for execution, but it nonetheless goes through all the motions, and User Customized Security says "Yes".

Yes, this is an Insyde H2O BIOS, but BIOS access if via F2, and boot select is F7, so maybe a slightly different version to yours?

Any further thoughts?


chrisVV 03-15-2019 10:20 AM

All I can say is that I have never encountered anything like what you report. The only thing that occurs to me is that my method involves constructing an EFI system partition by hand, formatting it and copying stuff over to it, rather than dd'ing the image directly onto the stick - it ends up with the same partition form and layout that you would have on a hard disk. Maybe doing it that way is more tolerant, I don't know - if you haven't tried my method it might be worth doing so. All in all though it looks as if it is something to do with your initrd, although I have no idea what. Also, I suggest trying slackware-current if you have so far been trying only slackware-14.2.

I suspect from your symptoms that secure boot is a red herring. As it happens I do have a boot/installation stick which can boot with secure boot enabled in two stages using Fedora's signed shim-15 EFI binary and its accompanying MokManager together with refind, but I have never come across a case where a boot stick or disk works with secure boot enabled but not when disabled. Usually it is the opposite way round.

pchristy 03-15-2019 11:11 AM

Hi Chris,

Thanks for your comments! Googling around, it appears that a lot of people have been having trouble with the Insyde BIOS and Linux, but the new versions are meant to be more tolerant. I'm not convinced its completely a UEFI problem, after all, the stick does boot - its just that something seems to be stopping the loaded kernel, or any associated scripts, from running. I've tried turning off all the security settings I can find, to no avail. The crazy thing is that some versions of Linux (systemrescuecd and clonezilla) do run as expected, whereas others do not. I've just downloaded Mageia-7-beta2 to see if that hangs like 6 does.

And yes, I am using -current (up to date) for this.

I would probably do better if I understood exactly how the install process works. I can see the kernel loading and the initrd.img. I'm guessing that the initrd contains some shell scripts to start the next stage and that this is where it is hanging. Or it could be that the kernel itself is not initialising properly for some reason. Since the system hangs before the anything actually runs, I cannot access any system logs or see any error messages, which makes locating the problem quite difficult!

My brain is starting to hurt!


pchristy 03-15-2019 11:33 AM

Just tried Mageia-7-beta2, and the installer loads and runs just fine. Mageia 6 doesn't - it hangs just like Slackware.

According to this website, they've tested it with a range of Linux distros without problems. (Ok, that's the 15" version, but same motherboard)

It looks as if other distros have found a workaround that hasn't made it into Slackware yet. No clues as to what that workaround is, though.....


mumahendras3 03-15-2019 02:30 PM

I have once encountered a problem similar to these but not exactly. I was using trying to boot to Ubuntu through USB stick but it hanged after the grub menu. The problem at that time was the Windows 10 fast startup being active (since I dual booted Windows 10). After disabling Windows 10 fast startup and restrating the system a couple times, I managed to boot into Ubuntu through USB in UEFI mode.

I don't know if this would help you as I presume that you don't have Windows 10 installed on that laptop right?

Nille_kungen 03-15-2019 02:52 PM


Originally Posted by chrisVV (Post 5974156)
Also, I suggest trying slackware-current if you have so far been trying only slackware-14.2.

I suspect from your symptoms that secure boot is a red herring. As it happens I do have a boot/installation stick which can boot with secure boot enabled in two stages using Fedora's signed shim-15 EFI binary and its accompanying MokManager together with refind, but I have never come across a case where a boot stick or disk works with secure boot enabled but not when disabled. Usually it is the opposite way round.

You should always try current first with new hardware, that's my 2 cents.

I choose liveslack current to test my hardware and make sure everything works.
But i just couldn't get it to boot and i tried every option to grub i could find with my google-fu but i had no luck whatever i tried it wouldn't boot.
I then made an ubuntu usb media and added pci=noapic to grub and it would boot but liveslack didn't.
The only thing that i could think of being different was down to UEFI keys.
When i added the file as trusted to uefi it worked with pci=noapic and it booted and didn't hang when changing from efifb as before.

I just tested to deactivate secure boot and with the added trusted file it now also able to boots with secure boot deactivated.
I tried to clear the trusted file "Erase all Secure Boot Setting:" and "Restore Secure Boot to Factory Default:" the first times it didn't work but then it seems like my trusted file was gone since i got the secure warning trying to boot with UEFI enabled.
After adding the trusted file the first time i could boot as expected with what ever options i enable in Insyde2HO setup utility.
I was also able to boot with UEFI enabled after adding the trusted file once again but i also got double boot entries indicating that the trusted file might not have been deleted but rather disabled and after cleaning settings the dual boot entries disappeared.
It seems like UEFI is quite buggy.
Adding the trusted file the first time made things work.
I think there are some tools for handling UEFI keys database, if i get to it i might dig a bit further to see if the trusted file actually gets deleted or disabled as i suspect, but this laptop is already taking to much time.
An completely other thing was that i had to change Touchpad setting in Insyde setup from advanced to basic to be able to use the touchpad with liveslack.
I never experienced anything like this one, this laptop and me haven't had the best start.

Originally Posted by pchristy (Post 5974170)
My brain is starting to hurt!

I feel the same way.
I started by updating my bios before i got started and do a have to tell anyone that it failed and the rollback procedure didn't work so a had to send it in.
You're not alone.

pchristy 03-15-2019 04:53 PM

The laptop came with a minimal windows install for testing purposes, but I've made sure fastboot is disabled both in the testing install and in the BIOS.

Tomorrow I'll try adding pci=noapic to the config file and see if that helps. The annoying thing is that the pendrive does boot - at least up to the point where it tries to start the installer. This seems to be telling me that its not UEFI per se, but perhaps some other security measure. But as far as I can see, I've disabled every security thing I can find!

Time to go to bed and sleep on it, I think!



pchristy 03-16-2019 03:51 AM

pci=noapic didn't work either!

Looks like I may have to install Mageia-7 as a stopgap until Slackware catches up.

To summarise: The pendrive boots, elilo runs and loads the kernel and initrd. But when elilo hands over to whatever it hands over to, everything stops dead.

More recent Linux distros or Linux based utilities *do* load and run whereas older ones don't. It doesn't appear to be a case of elilo vs grub, though it may be. (For example Mageia 6 (grub based) doesn't load, whereas Mageia 7 does.)

I've no real experience with grub. On the rare occasions I have used it, I've found it overly complex and difficult to eliminate once installed. Is there a guide to making a Slackware pendrive installer based on grub anywhere?

I'm going to be out most of today and won't get a chance to experiment further until tomorrow, or maybe even Monday....

One other thought - Is it possible to kick start the install process by chroot from something like systemrescuecd? The downside is that this may install, but still leave me with an unbootable system!


Nille_kungen 03-16-2019 05:26 AM

What versions of slackware have you tried to install?
Have you tried liveslack current and does it work or not? I used that currently is the latest release.
When i read that Mageia 7 works but Mageia 6 doesn't then i think it's down to hardware support since Mageia 7 comes with a later kernel and everything else is also more up to date.
If you don't want to install current you will need to add the missing support to 14.2 and that starts by updating the kernel.
I don't know anything about Mageia but wikipedia told me that Mageia 6 comes with kernel 4.9.35 and 6.1 comes with kernel 4.14.70 while Mageia 7 seems to use kernel 4.20.
Linux hardware support is mainly in the kernel that includes the drivers from the hardware now some hardware needs more then updated drivers to work but the rule of the thumb is that using a newer kernel adds support for newer hardware.
An updated Slackware 14.2 is now using kernel 4.4.172, kernels of 4.4 is rather old and doesn't support modern hardware, Slackware current or liveslack is currently using kernel 4.19 and supports more modern hardware.

Yes you can install slackware from an live linux media.
Eric, Alienbob has blogged about installing 14.2 from liveslack with an updated kernel.
Read it and understand the different steps and apply them on your install with a newer kernel, different partitioning or what you want.

All times are GMT -5. The time now is 04:07 PM.