-   Slackware (
-   -   Udev Rule Help Please (

Toods 11-23-2007 04:53 AM

Udev Rule Help Please
I am trying to write a rule to get udev to load the 'sd_mod' module as I do not have it built into the kernel.

I am using udev-116 in 'current'.

In the udev-111 version, this module was loaded in '50-udev.rules' file by the following rule:

# load modules to scsi disks, if they aren't in kernel
SUBSYSTEM=="scsi_device", ACTION=="add", ATTRS{type}=="0|7|14", RUN+="/sbin/modprobe sd_mod"
I have tried inserting this riule in the '80-drivers.rules' file and also in my '90-local.rules' file but it will not load the module.

Would someone be able to help me with this rule please as I am not experienced at all with udev rules?.

I want to have the module loaded ready for when I plug in my USB camera as this all worked well with udev-111.

Thank you.


shadowsnipes 11-23-2007 08:55 AM

I'm not exactly sure of the solution for this problem as I don't know the differences in the newest version of udev. However, you said you are not too familiar with writing rules...this may be helpful.

another link with much less info, but may be helpful still

It would probably be better to put your local rules in 10-local.rules since you probably want your rules to be parsed before the default rules.

All times are GMT -5. The time now is 03:18 PM.