-   Slackware (
-   -   Udev newbie wants to mount audio CDs & USB drives (

spes_hominis 11-25-2006 03:11 PM

Udev newbie wants to mount audio CDs & USB drives
I have a permissions problem and a udev problem.Right now,I can only mount as root. I read the advice given in this thread and added myself to the cdrom and disk groups,but it still comes up with "You must be superuser to do this". I tried adding mount with the NOPASSWD rule to sudo,but it gave the same result. Bizarrely,if I try to use sudo to mount,it asks for the password three times then refuses anyway:scratch:.
I'd like to write a udev rule or rules that will let me automatically access my card reader, USB hard drive & DVD-RW (especially ripping/playing audio & burning CDs)as a normal user. As I understand this,this will let me do so without needing to change /etc/fstab.
lsusb gives this:

Bus 2 Device 2: ID 0458:0037 KYE Systems Corp. (Mouse Systems)
Bus 2 Device 1: ID 0000:0000 
Bus 1 Device 4: ID 059f:0651 LaCie, Ltd
Bus 1 Device 3: ID 05e3:0703 Genesys Logic, Inc. Card Reader
Bus 1 Device 1: ID 0000:0000

Kernel version (untouched huge.i)
udev 107 (source version)
udev 097 (!) (listed in packages)
dbus 0.93 (

Andrew Benton 11-25-2006 04:42 PM

It's not possible to mount audio CD, they don't have a file system (or something). You don't need to mount CDs to rip, play or burn audio CDs.
To mount a USB drive or a card reader as a user, add the option `user' to the options in /etc/fstab like so

/dev/sda1 /mnt/usb auto user,noauto 0 0
read man mount for more

spes_hominis 11-25-2006 06:27 PM

Already have done:

/dev/hda4        swap            swap        defaults        0  0
/dev/hda2        /                ext3        defaults        1  1
/dev/hda1        /boot            ext2        defaults        1  2
/dev/hda3        /home            ext3        defaults        1  2
/dev/sda1        /usb/usb1        auto noauto,rw,user 0 0
/dev/cdrom      /mnt/cdrom      iso9660 noauto,ro,user 0 0
/dev/fd0        /mnt/floppy      auto        noauto,owner    0  0
devpts          /dev/pts        devpts      gid=5,mode=620  0  0
proc            /proc            proc        defaults        0  0

It was one of the first things I tried. Besides,I want to use udev to do this for me.

Andrew Benton 11-26-2006 05:33 AM

Udev creates the device nodes in /dev, it doesn't handle mounting. That is handled by HAL or whatever application you're trying to use to access /usb/usb1 or /mnt/cdrom.

All times are GMT -5. The time now is 04:59 AM.