-   Slackware (
-   -   Udev & devices trouble (

Macky 12-01-2005 07:59 AM

Udev & devices trouble
Hi, I have encountered a strange but somewhat interesting problem in Slackware 10.2, running my custom compiled kernel 2.6.14. It has to do with udev not creating devices when it should. It fails to create devices for alsa sound, my removeable dvd, and my webcam. Doesn't matter if it is at boottime or runtime.

For my removeable dvd, the initial problem was that there wasn't even a rule for it in udev.rules. I had to add a line manually there.

But with all rules set, hotplug and udev together with kernel and modules should create the required devices for my hardware automatically. But I am forced to do "udevstart" in a prompt to get the actual devices. I can check with "dmesg" that the actual hardware that I plug in into my computer is recognized and assigned a device. Yet I have to do "udevstart" afterwards to create the devices.

Is there some fundamental kernel option I have forgot to use, or what could be the problem? I have tried to compile in support for my hardware, for example, alsa sound directly into the kernel, instead of autoloading modules, but it seems to make no difference. I need to check this out more carefully again though. The udev and hotplug packages are both stock 10.2 packages.

I hope to get some input on this from other slackers here.


Macky 12-01-2005 02:11 PM

Well, not much input on this subject, but I have solved it. The guy in thread link given below suspected that udevd was not running, and thus not being able to create devices at plugin. He downgraded to the udev-50 slackware 10.1 package, and problems solved.

I did the same, it solved my problems too.... Obviously the 10.2 package is not behaving like it should, at all times...

All times are GMT -5. The time now is 02:07 PM.