LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Tv card + Sound Card = Audio Problem? (https://www.linuxquestions.org/questions/slackware-14/tv-card-sound-card-%3D-audio-problem-272735/)

kak 01-01-2005 08:04 PM

Tv card + Sound Card = Audio Problem?
 
Ok I got my TV card fully working but now I have issues with several programs (Realplayer, Juk, any Arts app.....??). It is just in programs that don't offer changing sound and/or mixer settings, that I can fiddle with. I think it is because of how the hardware is linked in /dev.
Quote:

Mixers:
0:Bt87x
1:SigmaTel STA9708/11
So I am also assuming : Bt878 = dsp0
ENS1371 = dsp1

Audio Devices didn't show up in the KDE Info Center.
So I think I need to switch their dev links and make it permanent but can't seem to find an answer? My googling skills are failing me.

Apps Known to work:
XMMS
Xine
Mplayer (with some fiddling)
Kdetv
TVtime

Apps that do not work
RealPlayer10
Juk
Kde Soundsystem
Flash from within Firefox

tw001_tw 01-02-2005 12:02 AM

I use to have that problem, but I can't remember what I did to fix it.
BUT, here is a thread here at LQ that has a fix.


http://www.linuxquestions.org/questi...lt+alsa+device

good luck.
-tw

kak 01-02-2005 01:18 AM

Got it. Thanks that pointed me into the right direction.:)

But I did it a little differently :
First Blacklist bttv in hotplug
Next add "/sbin/modprobe snd-ens1371" to rc.modules
then add "/sbin/modprobe bttv tuner=31" to rc.local

that way alsa is loaded FIRST and bttv LAST!

All good now:D


All times are GMT -5. The time now is 02:44 PM.