LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-08-2021, 04:43 PM   #1
Candelabrus
Member
 
Registered: Apr 2015
Location: Ponta Grossa - PR
Distribution: Slackware64
Posts: 162

Rep: Reputation: 22
Trying to run vkmark and gfxbench but...


Hello everyone, I apologize for creating another topic to ask for help, but i hope someday to contribute more than asking for help.

In my search for slackbuilds/private programs with a problem i found two more, which are the vkmark and gfxbench benchmarks. I would like to see with you if you had a similar problem or if you could help me in someway.

I'm using the most up-to-date version of Slackware64 Current, my laptop has an hd620 and a core i5 8a gen and i use nvidia primerun too. Just another detail, i tested both with the intel driver and the modesetting driver and the problem are the same, well i will try to explain the best possible, as there is not much output on the console showing the errors.

vkmark (using git) as soon as I run the benchmark it appears in the benchmark window but does not show any image, the image that is showing inside the square where the benchmark should be run shows a piece of the desktop screen.
I also tried to switch to kms or wayland but to no avail either. But with Nvidia the vkmark ran perfectly. (image attached intel error)

gfxbench (4.0.13) as soon as gfxbench is executed, the logo appears and immediately afterwards it closes automatically and this message appears:
Code:
eric@slackware ~ gfxbench 
[INFO ]: Dictionary loaded
[WARN ]: Empty dictionary
[INFO ]: Application started
[INFO ]: start
[INFO ]: Dispatching initialize
[INFO ]: Executing initialize
[INFO ]: App data path: /home/eric/.local/share/Kishonti Ltd/GFXBench GL
[INFO ]: Synchronization path: /home/eric/.cache/Kishonti Ltd/GFXBench GL/synchronized
[INFO ]: Config path: /opt/gfxbench/config
[INFO ]: Data path: /home/eric/.cache/Kishonti Ltd/GFXBench GL/synchronized/data
[INFO ]: Plugin path: /opt/gfxbench/plugins
[INFO ]: Test image path: /opt/gfxbench/images
[INFO ]: Asset image path: :
[INFO ]: Dispatching getTests
[INFO ]: Dispatching getConfigurations
[INFO ]: Dispatching getSessions
[INFO ]: Dispatching getBestResults
[INFO ]: Dispatching getBestResults
[INFO ]: Dispatching getSystemInfoItems
sh: linha 1: lspci: comando não encontrado
sh: linha 1: lspci: comando não encontrado
[clew] OpenCL loaded from: libOpenCL.so
[clew] Highest available: OpenCL 2.0
[clew] Highest available GL extensions: 1.2
Segmentation fault
Another detail was that i tried usingshared and with static libraries that come with the benchmark. But same error.
Attached Thumbnails
Click image for larger version

Name:	Captura de tela de 2021-05-08 18-36-32.jpg
Views:	39
Size:	245.5 KB
ID:	36340  

Last edited by Candelabrus; 05-09-2021 at 01:45 PM.
 
Old 05-12-2021, 05:17 PM   #2
Candelabrus
Member
 
Registered: Apr 2015
Location: Ponta Grossa - PR
Distribution: Slackware64
Posts: 162

Original Poster
Rep: Reputation: 22
Is everyone managing to run vkmark and gfxbench using an intel card?
 
Old 05-12-2021, 06:31 PM   #3
karlmag
Member
 
Registered: Apr 2014
Distribution: Slackware
Posts: 108

Rep: Reputation: Disabled
Quote:
Originally Posted by Candelabrus View Post

gfxbench (4.0.13) as soon as gfxbench is executed, the logo appears and immediately afterwards it closes automatically and this message appears:
Code:
eric@slackware ~ gfxbench 
<snip>
sh: linha 1: lspci: comando não encontrado
sh: linha 1: lspci: comando não encontrado
<snip>
Segmentation fault
Another detail was that i tried usingshared and with static libraries that come with the benchmark. But same error.
Tried to run it as root?

I believe that error there reads "command not found"? That would normally be true for a regular user, but lspci is in root's path.

You could try to set /sbin as a part of the path too, but not sure it's generally recommended for a regular user.


Thanks
--
KarlMag
 
Old 05-12-2021, 10:35 PM   #4
Candelabrus
Member
 
Registered: Apr 2015
Location: Ponta Grossa - PR
Distribution: Slackware64
Posts: 162

Original Poster
Rep: Reputation: 22
Quote:
Originally Posted by karlmag View Post
Tried to run it as root?

I believe that error there reads "command not found"? That would normally be true for a regular user, but lspci is in root's path.

You could try to set /sbin as a part of the path too, but not sure it's generally recommended for a regular user.


Thanks
--
KarlMag
Thank you for answering my friend.
But yes, i tried to run as root, but segmentation fault continues.
The question of the command not found in lspci really disappeared when i ran it as root, but as far as i understand it would only serve to gather information so to speak.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Need auto run in games without an auto run, used to use AutoHotKey in Windows, trying AutoKey, but having problems eric1234 Linux - Games 15 02-01-2019 11:58 AM
Deja-Dup doesn't run as scheduled, trying to run duplicity manually dcroxton Linux - Software 1 08-07-2017 09:11 PM
trying to fix xwindows or just run command line... changing run levels dave247 Debian 2 11-18-2008 06:11 PM
Trying to get a mini game system to run in linux but I don't know how to connect it redhed11 Ubuntu 4 06-27-2007 12:19 PM
Trying to run photoshop in wine. Install, but wont run. bruno buys Linux - Software 14 07-15-2004 04:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration