-   Slackware (
-   -   trying to get pxe boot working, but fail when setting up tftp server (

nass 08-02-2012 07:31 PM

trying to get pxe boot working, but fail when setting up tftp server
Hello everyone,
i am attempting to setup a boot server as per Alien's wiki but fail to set up the tftp server.

my /tftpboot folder contains:


root@stargaze:~# ls -l /tftpboot/
total 46717
-r-xr-xr-x 1 root root 831 Aug 3 01:34 f2.txt*
-r-xr-xr-x 1 root root 5866144 Aug 3 01:11 huge64.s*
-r-xr-xr-x 1 root root 5719840 Aug 3 01:10 hugesmp.s*
-r-xr-xr-x 1 root root 20034257 Aug 3 01:07 initrd.img*
-r-xr-xr-x 1 root root 16133793 Aug 3 01:07 initrd64.img*
dr-xr-sr-x 6 root root 288 Aug 3 01:41 kernels/
-r-xr-xr-x 1 root root 835 Aug 3 01:35 message.txt*
-rw-r--r-- 1 root root 16466 May 13 18:36 pxelinux.0
drwxr-sr-x 2 root root 104 Aug 3 01:38 pxelinux.cfg/
my /etc/inetd.conf has the tftp line uncommented. and i always get the
TFTP E32 open timeout error.

In a bold move , I tried to run the tftp outside of inetd. so I commented the line, restarted inetd, verified udp port 69 wasn't used and started the tftp server as:


in.tftpd -s /tftpboot -r blksize -l #th is small letter L
verified with netstat that port udp 69 was indeed occupied this time, and restarted my pxe client..
still the same error!

Finally, I did something more, i killed this tftp server, I renamed the /tftpboot folder and added a new empty /tftpboot folder in its place.Then i restarted the standalone server and I'd still get the E32 error!!!! how is this possible from an empty folder??

Thank you for your help!

OldHolborn 08-02-2012 08:17 PM


do you have a line in your hosts.allow for in.tftpd?

in.tftpd: 192.168.0.

for example?

astrogeek 08-02-2012 08:30 PM

Be sure your /etc/dhcpd.conf is set up correctly, that error is a PXE (client) error, not a TFTP server error.

Are the DHCP and TFTP on the same machine?

Other possibilities - are you sure the client is getting its DHCP data from the right machine?

Can you connect via tftp from another machine:
connect tftp-machine
get f2.txt

If so it would mean that the PXE boot machine is simply not finding the TFTP machine.

OldHolborn 08-02-2012 08:42 PM

It's not getting an answer from the tftp server, so either like you say, it's not looking in the right place, or it's got its fingers in its ears :)

jefro 08-02-2012 09:48 PM

Test tftp locally and remotely from command line. Does it work?

nass 08-03-2012 04:09 AM

Hello everyone thank you for the responses.

tftp works, I can log in from another slackware in the same intranet, and get a file (like pxelinux.0 or f2.txt) from command line tftp client.

the dhcp should also be correctly setup:


subnet netmask {
....more dhcp options....
allow bootp;
if substring (option vendor-class-identifier, 0, 9) = "PXEClient" {
filename "pxelinux.0";
I have also tried filename "/pxelinux.0" , but it didn't make any difference.

DHCP and boot server are on the same slackware64 machine, and there is no other dhcp server on my intranet.

OldHolborn, I don't have such a line in hosts.allow, but I don't have it in hosts.deny either, so I don't think I need to place it in hosts.allow. Or am I wrong?

What do you make of all this info, docs ?:)

OldHolborn 08-03-2012 05:08 AM


is that a typo or deliberate?

Your DHCP is listening on one class C, the tftp server you are directing it to is on another

nass 08-03-2012 05:38 AM

that's why I shouldn't be trying things on linux past midnight...
ok i'll go hide in a hobbit house and never come out again :)

I changed the value of next server - its a class C home network..

i'll verify this tonight, but i'll pretty confident that this was the problem.

Thank you

All times are GMT -5. The time now is 12:42 PM.