LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-07-2003, 05:33 PM   #1
Tyir
Member
 
Registered: Sep 2003
Distribution: Slackware 9.1 with fluxbox
Posts: 259

Rep: Reputation: 30
tryign to set up fstab with 2 cd drives


Hi, it sort of works, I'm just not sure if this is what it is supposed to be like, so I want to confirm I'm doing this right....

The importnat lines in fstab are
Code:
/dev/cdrom       /mnt/cdrom       iso9660     noauto,ro        0   0
/dev/cdrom1      /mnt/burner      iso9660     noauto,ro        0   0
And say i reboot, then put cds in
If i go to /mnt/cdrom or /mnt/burner, nothing is there
then, as root:
mount /mnt/cdrom
and
mount /mnt/burner
and then i can access my files

So would i need to put those two lines in a script (.xinitric or something) to run at startup?
Or is there a better way of setting them up.

Also, is this the correct way to set up the burner drive?
the cdrom is hdd and burner is hdc

Thanks
 
Old 12-07-2003, 06:01 PM   #2
jpbarto
Senior Member
 
Registered: Mar 2003
Location: Pittsburgh, PA
Distribution: Gentoo / NetBSD
Posts: 1,251

Rep: Reputation: 45
you got it pretty much right

however you can add an entry of user (user,noauto,ro)
that will allow users to mount the cd drive instead of just root.
 
Old 12-07-2003, 06:03 PM   #3
Nis
Member
 
Registered: Jul 2003
Location: Virginia
Distribution: Ubuntu Hoary (5.04)
Posts: 550

Rep: Reputation: 31
Try adding 'user' after 'noauto'. This way any user can mount those drives and you don't have to become root. If you want them to be automatically mounted when you insert a CD, check out supermount or magicdev.

As for setting up your burner, you'll need to the load scsi emulation module. Add 'append hdc=ide-scsi' to your lilo.conf, run 'lilo -v' as root, and reboot. Your burner will then be /dev/sr0. Now type, as root, 'ln -sf /dev/sr0 /dev/cdrom1'. Hope this works for you.
 
Old 12-07-2003, 06:20 PM   #4
Tyir
Member
 
Registered: Sep 2003
Distribution: Slackware 9.1 with fluxbox
Posts: 259

Original Poster
Rep: Reputation: 30
sr0 didnt seem to do anything, i tried scd0..
what does this mean?
Code:
root@MOFETTE:/mnt# ln -sf /dev/scd0 /dev/cdrom1
root@MOFETTE:/mnt# mount /mnt/burner
mount: /dev/cdrom1 is not a valid block device
 
Old 12-07-2003, 06:33 PM   #5
Nis
Member
 
Registered: Jul 2003
Location: Virginia
Distribution: Ubuntu Hoary (5.04)
Posts: 550

Rep: Reputation: 31
What distro are you using right now? Slack or Red Hat? Also, what is the output of 'ls -l /dev/sr0'?
 
Old 12-07-2003, 06:35 PM   #6
Tyir
Member
 
Registered: Sep 2003
Distribution: Slackware 9.1 with fluxbox
Posts: 259

Original Poster
Rep: Reputation: 30
Sorry, slackware

robert@MOFETTE:~$ ls -l /dev/sr0
brw-r----- 1 root disk 11, 0 Apr 13 1999 /dev/sr0
 
Old 12-07-2003, 06:41 PM   #7
Nis
Member
 
Registered: Jul 2003
Location: Virginia
Distribution: Ubuntu Hoary (5.04)
Posts: 550

Rep: Reputation: 31
Okay I just checked my system. /dev/scd0 works on my machine as well as /dev/sr0. I guess I got it wrong with /dev/sr0.
 
Old 12-07-2003, 06:47 PM   #8
minio
Member
 
Registered: Sep 2003
Location: Czech Republic - Prague
Distribution: Slackware 9.1
Posts: 61

Rep: Reputation: 15
Quote:
Originally posted by Tyir
mount: /dev/cdrom1 is not a valid block device
I get this message if i dont have ide-scsi support enabled. You must add

append="hdc=ide-scsi"

at he beginning of lilo.conf if it's not already here and run lilo (type lilo as root in console)
and reboot
(i don't know how about GRUB)
 
Old 12-07-2003, 07:00 PM   #9
Tyir
Member
 
Registered: Sep 2003
Distribution: Slackware 9.1 with fluxbox
Posts: 259

Original Poster
Rep: Reputation: 30
Im using GRUB, but im pretty sure the equivalent is enabled....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 10.1 fstab + 2 disc drives securitybreach Slackware 6 04-27-2005 03:17 PM
adding drives to fstab kurrupt Debian 1 08-09-2004 12:17 AM
add smbmount drives to fstab? woja Linux - Newbie 1 11-07-2003 03:14 PM
/etc/fstab drives gazza Linux - Newbie 5 10-29-2003 06:58 AM
Automatically mounting drives with FSTAB caesius_01 Linux - Newbie 6 10-21-2003 11:10 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration