LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-15-2011, 04:38 AM   #1
mocca
LQ Newbie
 
Registered: May 2011
Distribution: Slackware
Posts: 11

Rep: Reputation: 2
Truecrypt hidden volume


Hi, I mount truecrypt ntfs hidden volume in Slackware, i can read but i can't write to it. It shows "Operation not permitted".
Anyone know what I'm doing wrong?
I can read and write from other distro without any problem.
 
Old 05-15-2011, 08:04 AM   #2
hyperhead
Member
 
Registered: Mar 2011
Location: UK
Distribution: Slackware-14.2
Posts: 117

Rep: Reputation: 19
Who is the owner of the truecrypt file?

What is the output of:

ls -all <truecryptfile>
 
Old 05-15-2011, 08:21 AM   #3
mocca
LQ Newbie
 
Registered: May 2011
Distribution: Slackware
Posts: 11

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by hyperhead View Post
Who is the owner of the truecrypt file?

What is the output of:

ls -all <truecryptfile>
The truecrypt partition created from windows. Outer volume format in Fat and hidden volume format in ntfs.

Code:
ls:
 ls -all /dev/sdb3
brw-rw---- 1 root disk 8, 19 May 15 18:38 /dev/sdb3


bash-4.1$ ls -all /media/truecrypt1
total 8
drwx------  1 mocca users 4096 May 16  2011 .
drwxr-xr-x 19 root  root  4096 May 15 20:14 ..
drwx------  1 mocca users    0 May 16  2011 test
bash-4.1$
 
Old 05-15-2011, 08:49 AM   #4
hyperhead
Member
 
Registered: Mar 2011
Location: UK
Distribution: Slackware-14.2
Posts: 117

Rep: Reputation: 19
Do the volume properties state that it is read only?

truecrypt --volume-properties /mount/point

Alternatively have you got ntfs-3g package from /a/ installed?

Last edited by hyperhead; 05-15-2011 at 08:55 AM.
 
Old 05-15-2011, 09:23 AM   #5
mocca
LQ Newbie
 
Registered: May 2011
Distribution: Slackware
Posts: 11

Original Poster
Rep: Reputation: 2
Quote:
Do the volume properties state that it is read only?
truecrypt --volume-properties /mount/point
Volume properties state:
Read Only: No

Quote:
Alternatively have you got ntfs-3g package from /a/ installed?
Yes ntfs-3g was installed.
 
Old 05-15-2011, 10:15 AM   #6
hyperhead
Member
 
Registered: Mar 2011
Location: UK
Distribution: Slackware-14.2
Posts: 117

Rep: Reputation: 19
I have tried to re-create the conditions by creating a hidden container, but unfortunately did not have the option to format it as ntfs.

Perhaps this indicates that the truecrypt package on slackware cannot handle ntfs?

I found this:

If you wish to mount an NTFS formatted volume in read/write mode, you need to have the ntfs-3g driver installed, and when mounting specify it by saying --filesystem ntfs-3g because the autodetect mode will result in the usage of the read-only ntfs driver. Also the user mount option doesn't seem to work for me, so instead you can use the --mount-options gid=100,uid=1000,umask=000 parameter to make it accessible to all the user. You can find out the number you need to type for gid (GroupID) and uid (UserID) by doing a cat /etc/group|grep user and cat /etc/passwd|grep [your user name] respectively.

Last edited by hyperhead; 05-15-2011 at 10:25 AM.
 
1 members found this post helpful.
Old 05-15-2011, 06:29 PM   #7
mocca
LQ Newbie
 
Registered: May 2011
Distribution: Slackware
Posts: 11

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by hyperhead View Post
I have tried to re-create the conditions by creating a hidden container, but unfortunately did not have the option to format it as ntfs.

Perhaps this indicates that the truecrypt package on slackware cannot handle ntfs?

I found this:

If you wish to mount an NTFS formatted volume in read/write mode, you need to have the ntfs-3g driver installed, and when mounting specify it by saying --filesystem ntfs-3g because the autodetect mode will result in the usage of the read-only ntfs driver. Also the user mount option doesn't seem to work for me, so instead you can use the --mount-options gid=100,uid=1000,umask=000 parameter to make it accessible to all the user. You can find out the number you need to type for gid (GroupID) and uid (UserID) by doing a cat /etc/group|grep user and cat /etc/passwd|grep [your user name] respectively.
Hi hyperhead, I created and format the truecrypt hidden volume from windows.
I will try your suggestion when I back from work today.
 
Old 05-16-2011, 03:17 PM   #8
mocca
LQ Newbie
 
Registered: May 2011
Distribution: Slackware
Posts: 11

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by hyperhead View Post
I found this:

If you wish to mount an NTFS formatted volume in read/write mode, you need to have the ntfs-3g driver installed, and when mounting specify it by saying --filesystem ntfs-3g because the autodetect mode will result in the usage of the read-only ntfs driver. Also the user mount option doesn't seem to work for me, so instead you can use the --mount-options gid=100,uid=1000,umask=000 parameter to make it accessible to all the user. You can find out the number you need to type for gid (GroupID) and uid (UserID) by doing a cat /etc/group|grep user and cat /etc/passwd|grep [your user name] respectively.
I tried this method, It shows error:
mount: wrong fs type, bad option, bad superblock on /dev/mapper/truecrypt1
 
Old 05-17-2011, 01:22 PM   #9
hyperhead
Member
 
Registered: Mar 2011
Location: UK
Distribution: Slackware-14.2
Posts: 117

Rep: Reputation: 19
Ok, I have one last thing you could try

in sbin/ link mount.ntfs to mount.ntfs-3g

Code:
ln -s mount.ntfs-3g mount.ntfs
This worked for me when I couldn't write to a couple of external USB devices I had that were ntfs filesystems.

Hope this works, I am out of ideas!
 
Old 05-19-2011, 07:10 AM   #10
mocca
LQ Newbie
 
Registered: May 2011
Distribution: Slackware
Posts: 11

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by hyperhead View Post
Ok, I have one last thing you could try

in sbin/ link mount.ntfs to mount.ntfs-3g

Code:
ln -s mount.ntfs-3g mount.ntfs
This worked for me when I couldn't write to a couple of external USB devices I had that were ntfs filesystems.

Hope this works, I am out of ideas!
Hi hyperhead,
This method worked. Now i can read and write to the ntfs hidden volume.
Thank you very much.
 
Old 05-19-2011, 08:37 AM   #11
hyperhead
Member
 
Registered: Mar 2011
Location: UK
Distribution: Slackware-14.2
Posts: 117

Rep: Reputation: 19
Happy to hear it worked.
 
Old 05-26-2011, 11:44 AM   #12
firekage
Member
 
Registered: May 2011
Location: Poland
Distribution: Slackware, Ubuntu, Arch
Posts: 275

Rep: Reputation: 7
Quote:
Originally Posted by hyperhead View Post
Ok, I have one last thing you could try

in sbin/ link mount.ntfs to mount.ntfs-3g

Code:
ln -s mount.ntfs-3g mount.ntfs
This worked for me when I couldn't write to a couple of external USB devices I had that were ntfs filesystems.

Hope this works, I am out of ideas!

I also have problems with truecrypt containter that was created under windows in ntfs.

I used command in code above, i can enter the ntfs container, i can delete files, i can copy files to a container, i can create new folders (without the command in code i could only acces and read but i couldn't delete files or create folders in it) but i've problems with editing things that are in this windows ntfs container.

When i open, for an example, .txt document, or open office document i can read it but i can't change anything in it, i can't save changes that i made in it - i don't have file permission and i don't understand why - i don't have file save permission.

There is something also with file permission - when i start the terminal, i change filepermission on a specific file - for an example on slacware.txt, than i...can't read the file, i cannot open it. It looks like the file after changing file permission is damaged.

Last edited by firekage; 05-26-2011 at 11:46 AM.
 
Old 05-26-2011, 01:56 PM   #13
hyperhead
Member
 
Registered: Mar 2011
Location: UK
Distribution: Slackware-14.2
Posts: 117

Rep: Reputation: 19
Hi

What are the permissions on the directory that is mounted? Do they differ at all between files / directories?

That's all I can think of that would cause the problem, other than what is stated in the suggestions above.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How plausibly deniable are TrueCrypt hidden volumes? Mata Hari Linux - Security 7 12-02-2010 04:50 AM
Open truecrypt volume dellthinker Linux - Software 1 04-10-2009 03:55 PM
Mount a Truecrypt volume as /home/knoppix docinthebox Linux - Software 3 06-07-2007 03:16 PM
putting ext2 or ext3 on a truecrypt volume fakie_flip Linux - Software 2 03-21-2007 03:50 PM
can't mount truecrypt volume on FC4 obmuc Linux - Software 0 11-25-2006 05:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration