-   Slackware (
-   -   Trouble with wireless disconnecting (

popbot 10-03-2012 12:51 PM

Trouble with wireless disconnecting
So I've recently installed Slackware 14 (32) bit on a new Toshiba Satellite L855 (dual booting with Windows 7). I can connect to my router (or my works network) initially, but after 5 to 10 minutes, it will disconnect. It will then be unable to reconnect or find any networks until I reboot, at which time it does the same thing.

I did a lspci and it looks like this for the wireless:


02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
dmesg produces this last couple of lines:


[ 1218.852416] rtl8192c_common:rtl92c_firmware_selfreset(): 8051 reset fail.
[ 1219.640835] rtl8192ce:_rtl92ce_llt_write():<0-0> Failed to polling write LLT done at address 0!
[ 1219.640841] rtl8192ce:rtl92ce_hw_init():<0-0> Init MAC failed

lsmod looks like this:


Module                  Size  Used by
snd_seq_dummy          1119  0
snd_seq_oss            24956  0
snd_seq_midi_event      4568  1 snd_seq_oss
snd_seq                41599  5 snd_seq_midi_event,snd_seq_oss,snd_seq_dummy
snd_seq_device          4276  3 snd_seq,snd_seq_oss,snd_seq_dummy
snd_pcm_oss            33254  0
snd_mixer_oss          12984  1 snd_pcm_oss
ipv6                  238549  28
pcmcia                31533  0
pcmcia_rsrc            9312  0
pcmcia_core            10137  2 pcmcia_rsrc,pcmcia
cpufreq_ondemand        5272  4
speedstep_lib          2567  0
acpi_cpufreq            4977  1
mperf                    923  1 acpi_cpufreq
freq_table              2103  2 acpi_cpufreq,cpufreq_ondemand
lp                      7119  0
ppdev                  4710  0
parport_pc            16755  0
parport                26159  3 parport_pc,ppdev,lp
fuse                  58282  7
joydev                  7668  0
rts5139              270016  0
usbhid                31118  0
hid                    65824  1 usbhid
i915                  372988  3
drm_kms_helper        22825  1 i915
drm                  151850  4 drm_kms_helper,i915
intel_agp              8712  1 i915
video                  9938  1 i915
rtl8192ce              66483  0
intel_gtt              11571  3 intel_agp,i915
processor              23020  1 acpi_cpufreq
fan                    1894  0
thermal                6587  0
snd_hda_codec_hdmi    21721  1
rtlwifi                83299  1 rtl8192ce
rtl8192c_common        53284  1 rtl8192ce
mac80211              202703  3 rtl8192c_common,rtlwifi,rtl8192ce
thermal_sys            12122  4 thermal,fan,processor,video
psmouse                54408  0
snd_hda_codec_realtek  150654  1
agpgart                22087  3 intel_gtt,intel_agp,drm
mei                    27885  0
hwmon                  1033  1 thermal_sys
cfg80211              145277  2 mac80211,rtlwifi
rfkill                12432  3 cfg80211
i2c_i801                6952  0
i2c_algo_bit            4543  1 i915
i2c_core              16454  5 i2c_algo_bit,i2c_i801,drm,drm_kms_helper,i915
snd_hda_intel          19503  2
snd_hda_codec          70505  3 snd_hda_intel,snd_hda_codec_realtek,snd_hda_codec_hdmi
snd_hwdep              4802  1 snd_hda_codec
snd_pcm                59013  4 snd_hda_codec,snd_hda_intel,snd_hda_codec_hdmi,snd_pcm_oss
snd_page_alloc          5925  2 snd_pcm,snd_hda_intel
snd_timer              14798  2 snd_pcm,snd_seq
snd                    43657  16 snd_timer,snd_pcm,snd_hwdep,snd_hda_codec,snd_hda_intel,snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_mixer_oss,snd_pcm_oss,snd_seq_device,snd_seq,snd_seq_oss
soundcore              4570  1 snd
serio_raw              3349  0
evdev                  7314  8
battery                9119  0
button                  3665  1 i915
ac                      2563  0
loop                  14650  0

I've gone through AlienBob's wireless instructions, and have tried both wicd and network manager. I do get the same results using one or the other.

Is this a driver issue? I've looked through the LQ forums and haven't found similar issues. If I need to provide more info or post this somewhere else, please let me know. Just looking for a place to start.


dugan 10-03-2012 01:29 PM

Had this problem on one of my Windows boxes. The solution was to buy a new USB wifi dongle.

popbot 10-03-2012 08:03 PM


H_TeXMeX_H 10-04-2012 04:53 AM

Try a newer kernel, say 3.4.12, maybe they fixed the issue. I would also use wicd or Network Manager.

popbot 10-04-2012 07:02 AM

Thanks guys. I think I'm just going to try a newer kernel. This one just has me at a loss.

Old_Fogie 10-04-2012 08:01 PM

sounds like we have same computer. I recommend the 3.4.x series kernel as well. 3.5 is no good for our wifi. The 3.6 kernel breaks our our intel hd audio, but the wifi works

rc nai 10-04-2012 09:05 PM

I don't have the same computer, but I do have a toshiba L645 with the same network controller (RTL8188CE). I haven't had time to install sw14 yet, but when I do install it--my guess is I will run into the same problem. I'll let you guys know if I encounter any problems with the driver.

Did kernel 3.4.x fix your problem?

Old_Fogie 10-05-2012 01:11 AM

@ rc: yes the 3.4.x series kernel works properly for me. tho I. am hoping that 3.7 will restore functionality to the intel hd audio. I really would like to use that hybrid suspend.

ps. if my typing stinks blame swiftkey :)

popbot 10-06-2012 07:20 PM

I think I found something. I found this bug report in Launchpad:


There is a patch that was merged into kernel 3.7 and is being backported into all the stable kernels to detect a so-called B-Cut of the RTL8188CE cards. This patch helps a number of those cards. In addition, there is another patch that implements full support for all these cards, but it did not make the merge for 3.7. Furthermore, it will not be backported as it is too invasive. Users with this card should be able to get full support using kernel 3.8 or compat-wireless packages from November 1, 2012 or later. Of course, that date is just a guess.
I tried a patch from post #156 and it seems to be working. So I'm going to give it a few days and see how it goes.

rc nai 10-09-2012 11:56 PM

I'm curious, how's your connection like so far with the new driver, is it stable?

Just a thought, if the driver isn't stable, you can try using ndiswrapper.
It uses windows drivers which is the .sys and .info files. It may or may not work with ndiswrapper.

I found out that RTL8188CE isn't listed in the "working" section:

But you can still try if you want :)

rc nai 10-15-2012 07:27 PM

Sorry for the double post, I can't seem to find the option to edit my post. Anyway reporting back, I just installed sw14 today and so far I'm using the default drivers and its been going well, so far its stable and has no disconnections.

All times are GMT -5. The time now is 07:30 AM.