LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   trouble with wine 4.0 on current iso 3-6-19 (https://www.linuxquestions.org/questions/slackware-14/trouble-with-wine-4-0-on-current-iso-3-6-19-a-4175649833/)

mrapathy 03-08-2019 10:59 PM

trouble with wine 4.0 on current iso 3-6-19
 
2 Attachment(s)
was running 14.2 with wine 2.8 from alien bob.

wine ran NeverWinterNights Diamond GOG and Neverwinter nights 2 GOG with wine 2.8.

currently running current iso image from alien bob and did slackbuild wine4.0 and also tried alien bob package for wine 4.0.

went to current iso image to play BattleTech and it works well.

installed 32compat packages on both installs.

when I run install for NeverWinterNights Diamond GOG I get this with winedebug enabled.

I get a different error when trying to install nwn2 gog

gog/GOG=Good old Games or http://www.gog.com

appreciate any help

enorbet 03-09-2019 09:37 PM

I can't be certain this is the base issue but in each case you get the following error

Code:

preloader: Warning: failed to reserve range 00010000-00110000
There are other ways but I solve that issue by running as root before running wine....

Code:

  sysctl vm.mmap_min_addr=4096
Try this (you can always go back) and see if this helps any.

RadicalDreamer 03-10-2019 08:43 PM

You could try PlayOnLinux (you can download various versions of Wine with it) or Lutris (it has nice scripts created for games).
https://lutris.net/games/?q=neverwinter

mrapathy 03-10-2019 11:50 PM

1 Attachment(s)
Thanks for the help fella's.

Installing NWN Diamond got to same spot before error.

Will try play on linux I used it before and seemed to not need it. reinstalled 14.2 and getting errors oddly.
Dont know whats going with my system. My laptop still seems to be working fine which has 14.2 and wine 2.8.

got new debug info. the info enorbet suggested got rid of a annoying message.

bassmadrigal 03-11-2019 03:46 AM

Quote:

Originally Posted by enorbet (Post 5972239)
There are other ways but I solve that issue by running as root before running wine....

Code:

sysctl vm.mmap_min_addr=4096
Try this (you can always go back) and see if this helps any.

Quote:

Originally Posted by mrapathy (Post 5972558)
the info enorbet suggested got rid of a annoying message.

If you can't find any downsides of having this, you can create a file in /etc/sysctl.d/ and have it loaded automatically on boot.

Code:

echo "vm.mmap_min_addr=4096" > /etc/sysctl.d/99.wine-fix.conf

mrapathy 03-11-2019 11:08 PM

well I installed playonlinux sbo and its deps. now things are nwn and nwn2 are installing and working.
I didnt configure playonlinux so dont know what the issue was.


All times are GMT -5. The time now is 03:51 PM.