LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Trouble mounting a Windows share (https://www.linuxquestions.org/questions/slackware-14/trouble-mounting-a-windows-share-373789/)

lowpro2k3 10-16-2005 11:54 PM

Trouble mounting a Windows share
 
It seemed like I didn't have Samba or any of the SMB tools installed, so I went to linuxpackages.net and grabbed the package for 10.1.

I installed it with pkgtool, and the install seemed fine. I copied the example smb.conf to the right location, and it all seems to be working, including 'mount -t smbfs ...' (this didn't work before, and I realized I would need to download Samba).

I created a directory called /mnt/smb. I'm trying these 2 commands, to try and mount a directory called 'ebooks' on my Windows machine:

mount -t smbfs //192.168.1.97/ebooks /mnt/smb -o username=myuser,password=mypassword
smbmount //192.168.1.97/ebooks /mnt/smb -o username=myuser,password=mypassword

They both seem to work. When I do an ls of /mnt/smb, the shell just hangs and does nothing. I disabled my Sygate firewall on Windows, but it had no effect. ls just hangs and does nothing, I even tried giving it 5 minutes and went to make coffee, but it was still hanging.

vls 10-17-2005 01:28 AM

You need to run this command as root:
modprobe smbfs

Then run the mount commands.

Note that smbfs and the Samba package are two different things performing similar functions.
More or less.

I would suggest that you uninstall the linuxpackages.net pack and get the official Slackware package. (Not to denigrate whoever made the effort but I don't know what's in that build.)
The Slackware package has all the docs for samba that you'll ever possibly need.

http://slackware.at is an excellent mirror of the official Slackware distribution.

Hope this helps.

Have fun

fotoguy 10-17-2005 04:38 AM

Also check your /etc/hosts.allow and add your network to it, if your network is a 192.168.1.0 network, put something like this:

ALL: 192.168.1.0/255.255.255.0

Also can you post the contents of your /etc/samba/smb.conf file so we can see how it's setup


All times are GMT -5. The time now is 02:54 PM.