-   Slackware (
-   -   Trouble logging in (

spartn119 12-13-2004 04:31 PM

Trouble logging in
So i finally got Slackware installed on my laptop. I was soo happy! I got everything working that i knew how to use. I downloaded Putty for Windows, connected to my laptop, connected with success, exited out of that, everything. However, I wasn't as much of a fan of Gnome as i was of KDE seeing as how im new. So at the login screen, i click on one of the buttons at the bottom, choose KDE and tried to log in as root. Failure. It said that either i didn't have enough storage space or that it couldn't write when it needed to. So I set it back to load Gnome and tried logging in as root. Failure. Two windows are in the upper left hand corner with nothing else but a black screen. The window on top says:
"An error occured while loading or saving configuration information for gnome_segv. Some of your configuration settings may not work properly."
It gives me a "details" and a "ok" button. Neither of them are responsive. There is a window behind the front, but i can't bring it to focus, nor can I read whats written on it. The mouse will move, but other than that the computer is completely unresponsive. I have to take the battery out to restart. When linux boots it says "/dev/hda3 was uncleanly mounted" and runs some sort of check. It does the same with /dev/hda5. (These are my linux partitions hda3=/ and hda5=/usr) What did I do? What can I do to fix it?

Tinkster 12-13-2004 05:08 PM

Both hard to say ... what is the output of
df -k


shilo 12-13-2004 05:10 PM

Use putty to login and run the command:


df -h
What's it say?

Doh! You beat me! :)

spartn119 12-13-2004 05:18 PM

Im out for about an hour, i'll be sure to get right back to this when i get back though, thanks!

spartn119 12-13-2004 07:29 PM

OK, im back, and I tried what you suggested. I got the following message:
Filesystem Size Used Avail Use% Mounted on
/dev/hda3 950M 950M 0 100% /
/dev/hda5 3.5G 2.5G 851M 75% /usr

Guess that means I need more room for '/' doesn't it? What can I do about that?

capnpayne 12-13-2004 07:37 PM

Clean out /home stuff, for starters.

spartn119 12-13-2004 07:44 PM

How can I clean this out without logging onto my laptop? I've got Putty open, but what type of commands can I use to see whats in the /home directory and then to clean it out?

capnpayne 12-13-2004 07:53 PM

edit: oh, if you're to your display selector, in all likelihood the inetd has run successfully, so you can SSH to your laptop with putty, login like normal, and work.

cd ~
ls -a

rm [filename]
(no brackets)
removes a file

rm -rf [foldername]
(no brackets)
recursive (removes sub-directories) and force (forces remove, e.g. removes folders).

when you're done,
df -h

I... don't know if this is too newbie for you.

spartn119 12-13-2004 08:04 PM

Not at all, afterall, this is only my 3rd day with Slack...I can use Putty and everything and understand a little, im just not familiar with all the console commands yet. I'll edit this post when/if im successful!

Youri 12-14-2004 02:25 AM

u should not use such a small partition for your root directory ("/") maybe for just to start u should use one partition of 4 gig for the root ("/") and not a seperate mountpoint for "/usr" to start with u should just have one partition for slack and later when ur a little bit more familiar u could divide those partitions over diffrent mount points.

C0Y0TE 12-14-2004 04:42 AM

go to the bitbender forums and check out this walkthrough for installing slack, it really helped me when I started out..

I had a similar problem when I did a fresh install recently.. It seems that when you run out of space, it will continue to install (you just wont see error messages if you are using the install client) and then act like normal, until you reboot. Once you reboot, it won't have enough to work with, and will do things like ask for you to log in, then kick you out and ask for login, ad infinitum... I got to the point where I had to remove my battery from laptop to shut the dang thing off, too...

If you have extra drives, or you partition your hard drive differently, you can spllit up your files more carefully.. However if you arent willing to even give up 2 full gigs for slackware, you are going to have to give up trying to install every_single_package on the CDs.. Slack comes on 4 CDs, compressed, which is WAY more than the 1800M you have allocated for its use.. Hard drives of more than 40G are available for less than 100 bucks these days.

"/" is root directory (like C: ,) you will have ANY software installed inside here by default, during install, UNLESS you specify other partitions under specific directory names.. Most people recommend 1G for this, I double it just to be safe.

"/usr" is where most of your "system software" goes into, make sure you have a few gigs for this.

"/opt" is for optional software, if you get a couple-3 or 4 gig partition for /opt, I'd recommend avoiding installing multiple GUIs until you figure out how to get started with one.. I installed KDE and it ate up a lot of space.

"/home" is where users will store their files by default (like "my documents" in windows) and if you don't have space for this, you won't be able to do anything but surf the interface anyway..

Putty is neat and all, but using a telnet shell in windows, vs a full OS install have a few degrees of seperation there.. You might concentrate less on console commands and more on what is actually going on inside the system during (and after) install.

capnpayne 12-14-2004 03:31 PM

A) The third and fourth CD's are source CD's which you don't actually need. There are a handful of extras on each disc, but not enough to warrant downloading them for most people.

B) I don't know entirely what Coyote's trying to say, but using Putty for SSH is both safer and better than using Windows Telnet, which is unencrypted (like all telnet) and is a fairly broken client. Using SSH is almost exactly like sitting at your system - some people even use their Linux computers exclusively from another system. If you can get your installation to work just by trimming a bit, then you won't need it after that, and can use the system directly.

C) According to Coyote's post, your installation may be flat-out broken and missing critical packages due to the installer's nature. You may be better off installing it over again - it's not that much trouble.

All times are GMT -5. The time now is 08:24 AM.