-   Slackware (
-   -   Trouble installing Slackware 13.37 x64 to a USB drive (

spudgunner 07-03-2012 07:39 PM

Trouble installing Slackware 13.37 x64 to a USB drive
I'm attempting to install Slackware to a USB to use in a home server. I've encrypted the root partition (separate /boot, unencrypted), built my initrd.gz using the script provided by AlienBOB, and tried my best at configuring Lilo, but it failing. From what I can tell, all the modules start loading as normal, it panics:


mount: mounting ServerRoot on /mnt failed: no such file or directory
at which point it halts. (ServerRoot being my mapped encrypted partition)

After this 7 or 8 more kernel messages appear and appears as though it finishes initializing all the USB stuff and correctly stating that it has found sda1 and sda2 (/boot and / partition, respectively).

Because I don't know how to have Slackware copy all the boot messages and I'm too lazy to type, here's a picture of what I'm getting.

So it looks to be a timing issue to me since sda is being correctly read, just after the kernel tries to mount it. After searching a little bit, I tried using the rootdelay=[some number] in my lilo.conf, both in the global append section and appending to a particular entry, but it doesn't appear to affect the boot process at all (last number I tried was 500).

Any suggestions would be welcome.

Edit for a little clarity: regardless of what number I set for "rootdelay=", the system takes the same time to boot.

BCarey 07-03-2012 10:06 PM

Have you read Didier Spaier's how-to?


spudgunner 07-03-2012 10:25 PM

Interesting article, I never knew that you could "test" lilo, that would have definitely saved me some time. One thing I noticed from that is that "rootdelay=" is supposed to be in seconds (which is what I thought, so that is confirmed) but my system seems to not be waiting according to that. On my system, a delay of 500 takes the same amount of time as if it were set to 10.

spudgunner 07-04-2012 09:52 PM

So I reinstalled Slackware to the thumb drive without encryption (to remove some variables) and tried it out again, without luck. After some more internet searches, I found a solution that someone used for GRUB where they added in an extra script with a sleep command and it worked out for them, and it got me thinking. So I rebooted with the install media, mounted my USB drive and started poking around in /boot. Found a file called "wait-for-root' under /boot/initrd-tree/, the contents of this file are below:


I changed it to 100 because why not, re-ran mkinitrd without the -c (clean option) and bingo, got a (somewhat long) delay!

So I'm calling this problem 99% solved because I'm not sure how it will act with encryption. I'll have that tested by the end of the weekend.

spudgunner 07-05-2012 08:38 AM

Update: problem is basically solved now, although apparently I'm missing the module needed to use my USB keyboard to input the password for the encrypted drive (that should be a little easier to solve).

A note to anyone else that may have a problem similar to this in the future:

If rootdeley has no effect (or rootdelay doesn't work), use mkinitrd with the -w [time in seconds] option, works like a charm!

All times are GMT -5. The time now is 09:14 PM.