-   Slackware (
-   -   trouble formatting SATA hdd w/ slackware 10.2 (

surfbass 07-13-2006 11:18 PM

trouble formatting SATA hdd w/ slackware 10.2
Every time I try to boot up the Slackware 10.2 disks and run cfdisk I get an error saying the disk is read-only and I cannot change it. I tried the sata.i kernel and that didn't work (neither did test26.s). When I run 'fdisk -l' it shows my partition table fine. Any suggestions?

jimX86 07-13-2006 11:38 PM

Are you typing in just "cfdisk"? Try "cfdisk /dev/sda".

I'm not sure, but the read-only message sounds like it's looking at the cd-rom drive...

surfbass 07-14-2006 12:01 AM

Damn...That did it. Thanks a lot! I overlooked that little detail.:)

I'm currently kicking myself for not trying that, as I used that same command to install Slackware on my my iPod.

I feel like such a dumbass right now. <_<

jimX86 07-14-2006 08:18 AM

You're too hard on yourself. I think cfdisk defaults to /dev/hdc. It becomes habit to let it default, and after a while you don't even think about it.

All times are GMT -5. The time now is 01:32 AM.