-   Slackware (
-   -   Trouble compiling qemu (

pimy 05-31-2009 06:30 PM

Trouble compiling qemu
Slack 11.0
gcc 3.4.6
ld 20040927
ldd 2.3.6


I downloaded qemu 10.0 from here:

I extracted the contents, then ran ./configure. Here is the ouput:


Install prefix    /usr/local
BIOS directory    /usr/local/share/qemu
binary directory  /usr/local/bin
Manual directory  /usr/local/share/man
ELF interp prefix /usr/gnemul/qemu-%M
Source path      /home/ronin/downloads/qemu-0.10.0
C compiler        gcc
Host C compiler  gcc
ARCH_CFLAGS      -m32
make              make
install          install
host CPU          i386
host big endian  no
target list      i386-softmmu x86_64-softmmu arm-softmmu cris-softmmu m68k-softmmu mips-softmmu mipsel-softmmu mips64-softmmu mips64el-softmmu ppc-softmmu ppcemb-softmmu ppc64-softmmu sh4-softmmu sh4eb-softmmu sparc-softmmu i386-linux-user x86_64-linux-user alpha-linux-user arm-linux-user armeb-linux-user cris-linux-user m68k-linux-user mips-linux-user mipsel-linux-user ppc-linux-user ppc64-linux-user ppc64abi32-linux-user sh4-linux-user sh4eb-linux-user sparc-linux-user sparc64-linux-user sparc32plus-linux-user
gprof enabled    no
sparse enabled    no
profiler          no
static build      no
-Werror enabled  no
SDL support      yes
SDL static link  no
curses support    yes
mingw32 support  no
Audio drivers    oss
Extra audio cards ac97 es1370 sb16
Mixer emulation  no
VNC TLS support  no
kqemu support    yes
brlapi support    no
Documentation    no
NPTL support      no
vde support      no
AIO support      yes
Install blobs    yes
KVM support      no
fdt support      no

I then run make, and receive this error:


make[1]: Entering directory `/home/ronin/downloads/qemu-0.10.0/i386-softmmu'
  LINK  i386-softmmu/qemu
/usr/lib/gcc/i486-slackware-linux/3.4.6/../../../../i486-slackware-linux/bin/ld: cannot find -lX11
collect2: ld returned 1 exit status
make[1]: *** [qemu] Error 1
make[1]: Leaving directory `/home/ronin/downloads/qemu-0.10.0/i386-softmmu'
make: *** [subdir-i386-softmmu] Error 2

I have also tried qemu 10.5, and receive the same error.

Please help.


brianL 05-31-2009 06:43 PM

There's a SlackBuild for qemu on 11 here:

hitest 05-31-2009 06:56 PM

I agree with brianL. I've got qemu installed on my slackware 12.2 system, I used the slack build script from It works just fine.
That is the way to go, pimy.

joutlancpa 06-02-2009 01:05 AM

Used as a virtualizer, does Qemu have usb support ala VirtualBox PUEL version? tks

ponce 06-02-2009 02:16 AM


Originally Posted by pimy (Post 3558440)
/usr/lib/gcc/i486-slackware-linux/3.4.6/../../../../i486-slackware-linux/bin/ld: cannot find -lX11

it seems you need X11 package installed. ;)

All times are GMT -5. The time now is 12:14 PM.