-   Slackware (
-   -   Tried to be 'clever' with lilo and now cant boot (

mutexe 04-13-2013 12:48 PM

Tried to be 'clever' with lilo and now cant boot
installed slack on 5 or 6 machines over last few years with no problem but this time decided to install lilo to the superblock of my linux partition and not to the MBR.

Clearly on reboot nothing happened because it's still got grub there from a previous linux installation.
The thing that's fustrating me is that i've booted back off the installation drive, mounted my linux partition and have tried to edit the lilo.conf file but the system cant run lilo for some reason. Thread i've read say stuff like "from root partition run /sbin/lilo", but all i get back is "sh: lilo: command not found".
Does anyone have any ideas please?

manwichmakesameal 04-13-2013 12:58 PM

Have you tried to boot from the install disc, chroot into your install and reinstall lilo?

mutexe 04-13-2013 01:03 PM

thanks for the reply dude.
all i've done is try and add "lba32" into my lilo.conf and try and run lilo.

Wouldn't know how to chroot and re-install sorry.

solarfields 04-13-2013 01:10 PM

you can boot the install CD/DVD, set swap, set target partition WITHOUT formatting it, then skip installing any packages and go directly to the configuration part in the installer to configure and reinstall lilo from there. Remember not to format your partitions!

manwichmakesameal 04-13-2013 01:17 PM

You don't even need to do that. Just boot the install disc, mount your ROOT partition on /mnt. Mount your BOOT partition (if any) on /mnt/boot. After those are mounted, you can just chroot /mnt as root. Et, voila! Now you are in your install. Edit your lilo.conf to need and reinstall lilo where you want it

mutexe 04-13-2013 01:31 PM

cheers guys. All working now.

Thanks again.

All times are GMT -5. The time now is 05:52 AM.