Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 02-22-2005, 02:31 PM   #1
LQ Newbie
Registered: Apr 2004
Distribution: Slackware 10.1
Posts: 6

Rep: Reputation: 0
Transparencies doesnt work properly Slackware 10.1 + fluxbox


I just noticed that transparencies doesnt work at all on my slackware 10.1 2.4.29 and fluxbox 0.9.12..

Every time i tried to reduce the alpha value of the menu the windows went darker, not transparent. Then i realized that there was a line at .fluxbox/startup that established a black bg, i commented this line, and now anything happens if i try to reduce alpha.

Even if the widnows has 0 for alpha the window shows like if it has 255...

Neither with fbdesk transparencies work...

ANy ideas what could it be?


Last edited by Nah; 02-22-2005 at 02:47 PM.
Old 02-22-2005, 02:39 PM   #2
Senior Member
Registered: Oct 2003
Location: lost in the midwest...
Distribution: Slackware
Posts: 1,098

Rep: Reputation: 54
unless i'm reading your post're increasing alpha values which makes it darker...transparency works with decreased alpha values...
Old 02-22-2005, 09:28 PM   #3
gnu noob
Registered: Mar 2003
Location: CA
Distribution: Debian Buster
Posts: 140

Rep: Reputation: 15
set the background file with fbsetbg instead of bsetbg. You might also want to change your fluxbox styles that have backgrounds as well. I'm not sure why this works, but it solved the problem for me.

Last edited by gnu noob; 02-22-2005 at 09:30 PM.
Old 02-22-2005, 09:47 PM   #4
Registered: Jan 2005
Location: Santiago, Chile
Distribution: Looking towards LFS
Posts: 67

Rep: Reputation: 15
I have the same problem... and I'm using fbsetbg...

Any ideas?
Old 02-22-2005, 10:17 PM   #5
LQ Newbie
Registered: Apr 2004
Distribution: Slackware 10.1
Posts: 6

Original Poster
Rep: Reputation: 0
Thanks gnu noob.

The problem was that the style used xv to set the background, and xv doesnt support transparencies, and what fbsetbg does is try to find a suitable background-setting app and then tries to set the wallpaper using that appinstead .

So sharagat probably your problem is that fbsetbg uses a program that doesnt support transparencies, check the priority of apps of fbsetbg here:
Old 03-06-2005, 07:19 PM   #6
Registered: Mar 2005
Location: NJ - US
Distribution: Slackware
Posts: 93

Rep: Reputation: 15

i just donwload eterm, set it in the menu and the open Xterm and typed Eterm -x --borderless --scrollbar=false.... then save the user settings.... and every time i open a new eterm terminal is transparent.....

hope this help.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Updated Firmware of Wireless card, now doesnt work properly? kromatic Linux - Hardware 1 02-18-2005 01:36 PM
Fluxbox PANEL transparencies DraaX Linux - Software 4 11-28-2004 02:38 PM
transparencies & fluxbox N_A_J_M Linux - General 42 02-29-2004 09:10 PM
upgrading fluxbox to 0.9.6 doesnt work? slack_is_good Slackware 1 12-18-2003 03:10 PM
Slackware 8.1 installs OK but doesnt boot properly del Linux - Newbie 6 05-19-2003 05:46 AM > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:41 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration