-   Slackware (
-   -   Track filter in gtkpod doesn't work (

cyberpatrol 02-27-2013 04:16 AM

Track filter in gtkpod doesn't work
I've installed gtkpod 2.1.3 from SBo on Salix.

The problem is that the track filter doesn't work. Usually when I click onto an album, an artist or whatever in the track filter, the playlist tracks should only show the files which belong to what's selected in the track filter. And every action like deleting, editing or the like only applied to the displayed and selected files. This was the behaviour in gtkpod 2.1.2 on Arch Linux.

Now with gtkpod 2.1.3 on Salix selecting anything in the track filter doesn't do anything. Even if I click onto an album, the playlist tracks keep the same and show every file. The actions like deleting or editing is also applied to every file on the iPod.

Does anyone know if this is a packaging bug in SBo, an upstream bug, a missing dependency or another distro related issue?

I've already installed every dependency that I could find in the PKGBUILD for Arch Linux and the ebuild for Gentoo. Unfortunately currently I can't test it on another distribution.

willysr 02-27-2013 06:05 AM

gtkpod has a lot of optional dependencies
which packages do you have on your system?

Here's what i wrote on the README
Optional Requirements: faac, faad2, webkit, libmusicbrainz3 libmp4v2

on my system, the track filter does it job as in you expected

cyberpatrol 02-27-2013 07:25 AM

Besides the Salix OS full install, I have installed every package you've mentioned in the README except for brasero.

And according to the dependencies of the Arch Linux PKGBUILD and the Gentoo ebuild I have installed:


Of course, I recompiled gtkpod after installing all those packages.

cyberpatrol 02-27-2013 08:44 AM

I just see that you're using Slackware-Current. Is it possible that there's one dependency too old for gtkpod in Slackware 14 or Salix 14?

willysr 02-27-2013 10:44 AM

No, all the deps were installed from SlackBuilds repository
i tested the script on -Stable before pushing to SBo as well

cyberpatrol 03-05-2013 01:36 PM

But I guess you haven't tested it on Slackware64. I now tried it again with a full install of Slackware 14.0 and Slackware64 14.0. The issue appears only on Slackware64. On Slackware the track filter works as expected.

Btw., I'm using Salix in 64 bit, too.

willysr 03-05-2013 01:44 PM

I don't have a native x86_64 machines, only in Virtual Machines, so i can't really test on that environment
what happened if you tried to run the application in console? Does it produce any error or message?

cyberpatrol 03-05-2013 02:10 PM

If I start it from the console it just starts as usual. There are no error messages.

Meanwhile I reported it to upstream on the mailing list gtkpod-questions. As upstream just told me, it's already fixed in the git repo. Maybe a new release will be done in the next couple of weeks.

cyberpatrol 03-05-2013 03:42 PM

Installed gtkpod from the git repo. The bug is indeed fixed there.

willysr 03-05-2013 09:33 PM

I guess this is what you mean?

I think i will apply this patch for gtkpod in SBo

cyberpatrol 03-05-2013 10:10 PM

Actually, I don't know if that's the right patch. I just referred to this thread on upstream's mailing list, and installed gtkpod from the git repo. I guess they will soon release version 2.1.4 anyway from what Paul has written. But, if you like, let's try it, I can still reinstall the git version if the patch doesn't work.

willysr 03-05-2013 10:17 PM

Can you please try the updated SlackBuild on my SlackHacks? (commit)
if it's OK, i will submit to SBo because it takes time to be approved in SBo, so it's quicker to push it on my SlackHacks first

cyberpatrol 03-05-2013 11:02 PM

You can submit it to SBo. Seems to be the right patch. The filter works again as expected.

willysr 03-05-2013 11:16 PM

Thanks for confirming this patch
i will submit this to SBo soon

cyberpatrol 03-05-2013 11:25 PM

Thanks for helping me solving the issue.

All times are GMT -5. The time now is 04:30 AM.