LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   thunderbird won't run at all (https://www.linuxquestions.org/questions/slackware-14/thunderbird-wont-run-at-all-198821/)

MDesigner 06-28-2004 05:17 PM

thunderbird won't run at all
 
I installed Thunderbird via swaret. I try to run it (mozilla-thunderbird) and it cranks for a few seconds, then quits.

Does this happen for anyone else?

Peacedog 06-28-2004 05:31 PM

do you get any errors? have you tried starting it from the cli to see if there are any errors?

MDesigner 06-28-2004 05:37 PM

Yeah, tried that... no errors.

keefaz 06-28-2004 05:41 PM

No dependencies missing when ldd /path/to/thunderbird ? Is it the same when trying to run as root ?

Kovacs 06-28-2004 05:41 PM

I wouldn't use swaret for non-official packages. Just download the static Thunderbird binary from mozilla.org, untar it and you're ready to go.

MDesigner 06-28-2004 06:00 PM

OK, it mysteriously works now. I ran it as root..now it runs ok as all users. Maybe there were some config files that it couldn't create as a normal user? Hmm.

sethgeekx86 06-28-2004 07:58 PM

I had the same probem.

justin_p 06-28-2004 09:36 PM

I ran the program in the terminal as root. Here is what I got:

root@lola:/tmp/stuff# mozilla-thunderbird
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified


(thunderbird-bin:1414): Gtk-WARNING **: cannot open display:


Any ideas?

init 06-28-2004 10:25 PM

the last error you got is because your desktop user has ownership of the xserver.

you can try xhost +localhost then try to run it again

or export DISPLAY=root@localhost:0.0 (cant really remember how this is done)

anywhoooo that error has nothing to do with thunderbird. I down loaded the latest from thunderbird site at it runs fine just untar it and go... I liked evolution much more now novell got em so who knows.....

I had the same issue as you with evolution using slap-get never did figure it out.


All times are GMT -5. The time now is 12:08 AM.