LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 10-21-2018, 10:32 PM   #1
hedron
Member
 
Registered: Jul 2009
Location: NYC
Distribution: Slackware64-multilib 14.2, SARPI
Posts: 294

Rep: Reputation: 27
Thunderbird keeps locking up


I had a similar problem in windows (https://www.linuxquestions.org/quest...ly-4175638430/) but it seems to be happening in Linux as well. Basically, Thunderbird locks up, the window goes blank and even sudo kill -9 xxxx doesn't kill the process, nor does restarting fluxbox. The only way that works is by rebooting the entire computer.

I use Multilib Slackware64 14.2. I followed the guide as well as I could and 32bit wine applications work fine, but 64bit wine (windows) programs don't. But that's a story for another thread, I just thought it might be useful information.

My profile is located on a SARPI samba server. It's mounted via fstab as below.

Code:
//<servername>/<foldername> /home/<foldername> cifs      rw,user,uid=1000,gid=100,credentials=/home/<username>/.smbfile     0       0
testparm:
Code:
[global]
        dns proxy = No
        name resolve order = lmhosts host wins bcast
        server string = blah
        workgroup = <workgoup>
        idmap config * : backend = tdb
        hosts allow = 192.168.0. 127.


[<foldername>]
        comment = sarpi
        path = /home/<foldername>
        read only = No
        valid users = <username>
Also, I use NVIDIA drivers 410.66 for a 710 video card. When moving windows, there's a slight lag, and sometimes they (I don't know how to explain exactly) but they slide much slower than my cursor does. I don't know if this problem is related or not. If not, then it's a completely different thread.

Sometimes Palemoon locks up in a similar fashion, but again, I'm not convinced the issue is related.

Last edited by hedron; 10-21-2018 at 11:20 PM.
 
Old 10-22-2018, 12:22 AM   #2
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,519

Rep: Reputation: Disabled
if you move the profile locally do you still have the same hangs?
 
Old 10-22-2018, 08:50 PM   #3
hedron
Member
 
Registered: Jul 2009
Location: NYC
Distribution: Slackware64-multilib 14.2, SARPI
Posts: 294

Original Poster
Rep: Reputation: 27
Probably.

There's got to be some low level way of tracing this. I just don't know what it is.

It also tends to hang when copying long files. Even with the command line.

Last edited by hedron; 10-22-2018 at 08:56 PM.
 
Old 10-22-2018, 09:53 PM   #4
orbea
Senior Member
 
Registered: Feb 2015
Distribution: Slackware64-current
Posts: 1,466

Rep: Reputation: Disabled
What DE or WM are you using? Does using a different one help?

Some other things that might help narrow this down is to check dmesg, start the programs in a terminal and check for output before or during the hangs, check the cpu and memory usage by the programs with a tool like htop or if all else fails build one of the programs with debugging symbols and run it in gdb until you can reproduce the issue where you then can hopefully press ctrl+c in gdb to get a backtrace.
 
1 members found this post helpful.
Old 10-23-2018, 04:15 PM   #5
hedron
Member
 
Registered: Jul 2009
Location: NYC
Distribution: Slackware64-multilib 14.2, SARPI
Posts: 294

Original Poster
Rep: Reputation: 27
dmesg:
Code:
[25445.867794] CIFS VFS: Server <SARPI Server> has not responded in 120 seconds. Reconnecting...
I don't know why I didn't think of dmesg. But audacious locked up and the above is the dmesg from the event. I will see if the audacious lock up times with the thunderbird lock up, as it seems more consistent. (And right on queue, thunderbird locked up in perfect syncronicity when audacious locked up. Although, this time it "unlocked" when audacious started playing again.)

It seems to me that my error message from mysqldump (got errno 22 on write) is about the same timing too. ie: the time it takes from issuance of mysqldump -u user -p database > backup.sql to error is the same time as pressing play on audacious and it locking up.
 
Old 10-23-2018, 04:24 PM   #6
hedron
Member
 
Registered: Jul 2009
Location: NYC
Distribution: Slackware64-multilib 14.2, SARPI
Posts: 294

Original Poster
Rep: Reputation: 27
A google search for the error message, says that you shouldn't mount smb shares via fstab. Has anyone heard this? All the guides never mentioned anything like this.
 
Old 10-23-2018, 08:00 PM   #7
glorsplitz
Member
 
Registered: Dec 2002
Distribution: slackware!
Posts: 655

Rep: Reputation: 130Reputation: 130
When I was using samba, using nfs now, I did mounts via rc.local.

I probably found something somewhere from someone that said that was how they did it, it worked well.
 
Old 10-24-2018, 03:56 AM   #8
hedron
Member
 
Registered: Jul 2009
Location: NYC
Distribution: Slackware64-multilib 14.2, SARPI
Posts: 294

Original Poster
Rep: Reputation: 27
Mounting while observing tail -f /var/log/syslog:
Code:
No dialect specified on mount. Default has changed to a more secure dialect, SMB2.1 or later (e.g. SMB3), from CIFS (SMB1). To use the less secure SMB1 dialect to access old servers which do not support SMB3 (or SMB2.1) specify vers=1.0 on mount.
Code:
CIFS VFS: error -95 on ioctl to get interface list
Adding the options "vers=1.0", removes the error, but since the issue is random it's hard to say.

Code:
cat /boot/config | grep -i smb
# CONFIG_CIFS_SMB311 is not set
But on my SARPI server it is set. I guess I'll have to recompile at some point to set it.

Although, it doesn't explain why it happens in windows. But a sort of similar issue is here: https://bugzilla.redhat.com/show_bug.cgi?id=1502606 Maybe Microsoft is being passive aggressive again with this incompatibility crap? They did a similar thing with XP.

Update: It seems to be happening even with the vers=1.0

I just this from syslog was relevant: (the file is what I was using to test it in xine.) It appeared long after I had closed xine.

Code:
smbd[3157]:   send_file_readX: fake_sendfile failed for file Audio/Music/sleep/Long Train Sounds for Sleep _ Night Train 8 Hour Sound.webm (ipv4:192.168.0.99:36338) for client Connection timed out. Terminating

Last edited by hedron; 10-24-2018 at 04:45 AM.
 
Old 10-24-2018, 03:50 PM   #9
trite
LQ Newbie
 
Registered: Feb 2016
Location: Sweden
Distribution: Slackware
Posts: 16

Rep: Reputation: Disabled
I had the same problem.

What worked for me was to go into thunderbird config and set the db session timeout thingy to longer time, hold on.

Edit -> Preference -> Advanced -> Config Editor -> Accept risks...

and then hmm..

was it this one? mail.db.idle_limit

like add two or three more zeroes to that one I think


*edit* meh sorry for not reading you post properly. Mine didnt hang totally, more like froze up and then resumed but was really annoying. You can still try and see if it helps though.

Last edited by trite; 10-24-2018 at 03:52 PM.
 
Old 10-25-2018, 01:41 AM   #10
hedron
Member
 
Registered: Jul 2009
Location: NYC
Distribution: Slackware64-multilib 14.2, SARPI
Posts: 294

Original Poster
Rep: Reputation: 27
According to this: https://unix.stackexchange.com/quest...minutes-on-end It's a feature, not a bug.
 
Old 10-26-2018, 02:46 AM   #11
hedron
Member
 
Registered: Jul 2009
Location: NYC
Distribution: Slackware64-multilib 14.2, SARPI
Posts: 294

Original Poster
Rep: Reputation: 27
Well, I gave up and now am using NFS and it doesn't seem to be locking up. Knock on wood...
 
Old 11-11-2018, 03:23 AM   #12
hedron
Member
 
Registered: Jul 2009
Location: NYC
Distribution: Slackware64-multilib 14.2, SARPI
Posts: 294

Original Poster
Rep: Reputation: 27
Well, it's still locking up. The symptoms are slightly different. It's likely that it's a combination of things and not one specific thing, but I could be wrong.

It seems to lock up more when more than one instances are accessing the NFS folder. Only the application accessing the folder will lock up, except xterm. For some reason xterm doesn't lock up. Firefox style browsers will lock up, but not Chromium. XMMS and Audacious don't seem to want to load anything in their playlists, but they were somewhat ok yesterday. I can play audio files just fine in xterm with mpg123 and mplayer. File managers like XFM and QTFM have issues only when accessing the folder, but midnight commander is just fine. Thunderbird is typically fine, but occasionally locks up when XMMS is being used.

I'm still convinced it has something to do with a network driver setting on the low level and that's why it's eerily similar to the "feature" posted above.

Last edited by hedron; 11-11-2018 at 03:34 AM.
 
Old 11-11-2018, 03:31 AM   #13
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,519

Rep: Reputation: Disabled
Quote:
Originally Posted by ponce View Post
if you move the profile locally do you still have the same hangs?
Quote:
Originally Posted by hedron View Post
Probably.

There's got to be some low level way of tracing this. I just don't know what it is.

It also tends to hang when copying long files. Even with the command line.
you still haven't tried this, right? it could help you understand if the problem is tied to have a network profile.
 
Old 11-11-2018, 03:37 AM   #14
hedron
Member
 
Registered: Jul 2009
Location: NYC
Distribution: Slackware64-multilib 14.2, SARPI
Posts: 294

Original Poster
Rep: Reputation: 27
I don't think I have a network profile? I certainly didn't set one up. Maybe I'm misunderstanding what you're saying, but I just log in with a username locally, then add the folder via fstab: phlan:/home/moonsea /home/moonsea nfs sec=sys,tcp,nosuid 0 0

I take it back, xterm is locking up. Although, I'm pretty sure it's because I started testing it doing odd things. Mainly using midnight commander to play mp3 files. I try cd /folder and it locks or lsof /folder and it locks up as well.

Everything is fine locally though.

Last edited by hedron; 11-11-2018 at 06:21 AM.
 
Old 11-11-2018, 04:49 AM   #15
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,519

Rep: Reputation: Disabled
Quote:
Originally Posted by hedron View Post
I don't think I have a network profile? I certainly didn't set one up. Maybe I'm misunderstanding what you're saying, but I just log in with a username locally, then add the folder via fstab: phlan:/home/moonsea /home/moonsea nfs sec=sys,tcp,nosuid 0 0

I take it back, xterm is locking up. Although, I'm pretty sure it's because I started testing it doing odd things. Mainly using midnight commander to play mp3 files. I try cd /folder and it locks or lsof /folder and it locks up as well.

Everything is file locally though.
I meant that you have your home (containing your thunderbird profile, in ~/.thunderbird) on a nfs (samba before) share, that is used via the network.
what I asked you to try is to avoid mounting your home as a network drive but use a /home/moonsea on the local drive and see if it helps: if it does your issues are most probably tied to using an home on a network share.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Got this email from Google after trying to log into Thunderbird. Is Thunderbird in-secure? Ajwad Linux - Newbie 2 02-19-2016 12:59 PM
Ubuntu 12.04/Thunderbird - Migrate Thunderbird Email & Settings Ineed2know Linux - Newbie 3 05-04-2012 11:59 PM
Importing Thunderbird settings from Portable Apps Thunderbird zensunni Linux - Software 2 09-14-2010 03:56 AM
retrieving (Windows) Thunderbird e-mail from an old Thunderbird folder newbiesforever General 1 07-13-2009 08:56 AM
Using thunderbird inbox folders with kmail - thunderbird on linux too slow mtess Linux - Software 1 03-12-2008 11:34 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration