-   Slackware (
-   -   Thunderbird compiling building (

lq2009 05-21-2013 07:20 AM

Thunderbird compiling building
I am on Slackware v14

I tried to compile Thunderbird with build script from slackbuilds:

I encountered errors 2 errors for missing libraries.
But actually , I hv those libraries already available on the system.


../../../../dist/system_wrappers/glibconfig.h:3:29: fatal error: glibconfig.h: No such file or directory
compilation terminated.
make[6]: *** [nsIconChannel.o] Error 1

../../dist/system_wrappers/libgnome/libgnome.h:3:36: fatal error: libgnome/libgnome.h: No such file or directory
compilation terminated.

pkg-config shows that I hv those libs: glib libgnome
How can I include those missing libraries in the above build script?

Nikosis 05-23-2013 05:22 PM

Whats wrong with *.txz package? Is there any particular reason why you rebuild it?

lq2009 05-23-2013 09:49 PM

I work on a low resource machine.
Thunderbird works little bit slowish with Xul engine.

I want to test the self compiled version.
The Thunderbird package is large, and hard to configure

Any suggestions for modifying
script to find all the libraries?

zrdc28 05-27-2013 07:10 PM

I ran into this same problem on another package a while back and it seems like a symlink was the way I solved it.

All times are GMT -5. The time now is 07:17 PM.