LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-05-2018, 07:34 AM   #1
myoung
LQ Newbie
 
Registered: Nov 2010
Posts: 27

Rep: Reputation: 0
Thunderbird 60 black windows running as user


Hi,
I have been running Mozilla Thunderbird 52.8 as a user with no problems.
I am running Slackware64-current and fully up to date.
I installed Mozilla Thunderbird 60.0 using the latest slackware package and get black windows with the error message:
"[GFX1-]: Failed to lock new back buffer."

If I run it as root it works fine and if I run it as a user on another computer, also Slackware64-current, fully up to date, it also works fine.
I have tried removing the .thunderbird directory, but no change.
Googling for "[GFX1-]: Failed to lock new back buffer." gives little joy.

So I think that there is something wrong/different/missing on the first computer.
Suggestions on how to find the problem please?
 
Old 09-05-2018, 11:37 AM   #2
Gordie
Member
 
Registered: Aug 2007
Location: Nolalu, Ontario, Canada
Distribution: Slackware Linux
Posts: 588

Rep: Reputation: 216Reputation: 216Reputation: 216
Quote:
Originally Posted by myoung View Post
Hi,
I have been running Mozilla Thunderbird 52.8 as a user with no problems.
I am running Slackware64-current and fully up to date.
I installed Mozilla Thunderbird 60.0 using the latest slackware package and get black windows with the error message:
"[GFX1-]: Failed to lock new back buffer."

If I run it as root it works fine and if I run it as a user on another computer, also Slackware64-current, fully up to date, it also works fine.
I have tried removing the .thunderbird directory, but no change.
Googling for "[GFX1-]: Failed to lock new back buffer." gives little joy.

So I think that there is something wrong/different/missing on the first computer.
Suggestions on how to find the problem please?
Maybe try removing
Code:
~/.cache/thunderbird/
EDIT - You didn't make a full install?

Last edited by Gordie; 09-05-2018 at 11:41 AM.
 
Old 09-05-2018, 12:16 PM   #3
abga
Senior Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 1,420

Rep: Reputation: 809Reputation: 809Reputation: 809Reputation: 809Reputation: 809Reputation: 809Reputation: 809
Quote:
Originally Posted by myoung View Post
Hi,
Googling for "[GFX1-]: Failed to lock new back buffer." gives little joy.
The first 2-3 results point to issues (both Thunderbird & Firefox 60) related to /dev/shm/, have you read those/tried the fix?
https://www.mail-archive.com/debian-...sg1579071.html
https://bugzilla.mozilla.org/show_bu...ult&id=1450169
 
Old 09-05-2018, 09:51 PM   #4
myoung
LQ Newbie
 
Registered: Nov 2010
Posts: 27

Original Poster
Rep: Reputation: 0
Smile running Thunderbird 60 as user Solved :-)

Thank you for the suggestions :-) :-)
I tried all of the suggestions! but I think it was the mount command which I tried last that did the trick :-)

As the user I did:
cd ~
rm -fr .cache
rm -fr .thunderbird

As root I did:
chmod o+w /dev/shm
chgrp users /dev/shm
mount -t tmpfs tmpfs /dev/shm

Running thunderbird as a user now works

Cheers
 
Old 09-06-2018, 04:22 AM   #5
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 9,249

Rep: Reputation: Disabled
Quote:
Originally Posted by myoung View Post
As the user I did:
cd ~
rm -fr .cache
rm -fr .thunderbird

As root I did:
chmod o+w /dev/shm
chgrp users /dev/shm
mount -t tmpfs tmpfs /dev/shm

/me think a better solution is to set /dev/shm for each regular user, as I have here in ~/.profile:
Code:
export XDG_CACHE_HOME=/dev/shm/$(whoami)
mkdir -p /dev/shm/$(whoami)
chmod 700 /dev/shm/$(whoami)
export XDG_RUNTIME_DIR=$XDG_CACHE_HOME
This setting is fully compliant with the XDG Base Directory Specification. The last line is optional, but can help two apps communicate together, as some software rely on XDG_RUNTIME_DIR and others on XDG_CACHE_HOME for the same purpose.

This also provides the advantage that you will never again have to clean ~/.cache, and results in less writes on disk.
 
1 members found this post helpful.
Old 11-28-2018, 11:56 AM   #6
buchner.johannes
LQ Newbie
 
Registered: Nov 2018
Posts: 1

Rep: Reputation: Disabled
Thunderbird 60 black windows, on systemd

Hi all, I would like to attach additional information in case someone else has the same problem on a systemd-based system, in my case Gentoo. Apologies to the Slack users for hijacking your thread.

I had the same problem (black windows in thunderbird), which comes from thunderbird not being able to create /dev/shm files. However, /dev/shm has already generous permissions:

Code:
$ ls -ld /dev/shm/
drwxrwxrwt 2 root root 40 Nov 28 14:41 /dev/shm/
The problem was the number of allowed open files (ulimit -n was giving 1024).
Classically this limit can be increased through /etc/security/limits.conf, but systemd loads limit settings differently. This was confusing for me because you get different ulimit results in the VTs. Redhat bug #1364332 has information how to set the limits per-user in systemd. I am copying from there:

Code:
mkdir /etc/systemd/system/user@1000.service.d
(If your user uid is something other than 1000 change to that )

Create the file /etc/systemd/system/user@1000.service.d/limit.conf and have it contain

Code:
[Service]
LimitNOFILE=10240
Reload the systemd daemon to pick up the changes
Code:
systemctl daemon-reload
Logout or reboot.

Check that the new limit works:
Code:
$ ulimit -n
10240
I hope this saves someone a few hours of debugging when only having "[GFX1-]: Failed to lock new back buffer." to work with.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Using Windows Thunderbird's database in Centos Thunderbird cent_uries@yahoo.co.id Linux - Newbie 1 02-08-2012 10:46 AM
Moving from Thunderbird in Windows to Thunderbird in Linux pnh73 Linux - Software 14 11-05-2011 09:24 AM
retrieving (Windows) Thunderbird e-mail from an old Thunderbird folder newbiesforever General 1 07-13-2009 07:56 AM
Importing Windows Thunderbird to Linux Thunderbird NaughtyMonkey Linux - Desktop 1 07-11-2007 04:54 PM
Importing Thunderbird(Windows) to Thunderbird(Linux) NomadABC Linux - Software 9 07-19-2006 01:30 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 03:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration