LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-15-2018, 10:06 AM   #1
alanware
Member
 
Registered: Aug 2011
Location: Midwest-USA
Distribution: Slackware
Posts: 84

Rep: Reputation: Disabled
Thunar USB Auto Browse/Mount not working


I have fresh Slackware64 14.2 install with SLiM. When I log into an account using XFCE and start Thunar I am unable to get the USB drivers to show. I have tried changing to XDM, but still doesn't work. The system sees connection of the USB drive. ConsoleKit lists a session running, which was one of the things I found to check searching around for solutions. Any insights would be appreciated.
 
Old 04-15-2018, 10:39 AM   #2
RandomTroll
Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 735

Rep: Reputation: 97
What does
Code:
df
return?
Code:
ls -l /dev/sd*
?
 
Old 04-15-2018, 11:45 AM   #3
coralfang
Member
 
Registered: Nov 2010
Location: Bristol, UK
Distribution: Slackware, FreeBSD
Posts: 560
Blog Entries: 3

Rep: Reputation: 176Reputation: 176
Is thunar running in daemon mode?
Try running
Code:
$ thunar --daemon &
, then inserting a usb drive. If that works, then add this command to your autostart session scripts.
 
Old 04-15-2018, 12:04 PM   #4
alanware
Member
 
Registered: Aug 2011
Location: Midwest-USA
Distribution: Slackware
Posts: 84

Original Poster
Rep: Reputation: Disabled
Code:
df
Filesystem             1K-blocks     Used Available Use% Mounted on
tmpfs                    4082668      852   4081816   1% /run
devtmpfs                 4077036        0   4077036   0% /dev
/dev/dm-1                5029504  1021408   3729568  22% /
tmpfs                    4082668        0   4082668   0% /dev/shm
cgroup_root              4082668        0   4082668   0% /sys/fs/cgroup
/dev/mapper/slack-tmp   10190136   956736   8692728  10% /tmp
/dev/mapper/slack-usr   30832636 11079640  18163748  38% /usr
/dev/mapper/slack-var   10190136    77428   9572036   1% /var
/dev/mapper/slack-home  29796412  7387920  20871880  27% /home
cgmfs                        100        0       100   0% /run/cgmanager/fs
Code:
ls -l /dev/sd*
brw-rw---- 1 root disk    8,  0 Apr 15 11:29 /dev/sda
brw-rw---- 1 root disk    8,  1 Apr 15 11:29 /dev/sda1
brw-rw---- 1 root disk    8,  2 Apr 15 11:29 /dev/sda2
brw-rw---- 1 root plugdev 8, 16 Apr 15 11:29 /dev/sdb
brw-rw---- 1 root plugdev 8, 17 Apr 15 11:29 /dev/sdb1
RandomTroll
Code:
thunar --daemon &
Does nothing.
 
Old 04-15-2018, 05:01 PM   #5
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 6,068

Rep: Reputation: 673Reputation: 673Reputation: 673Reputation: 673Reputation: 673Reputation: 673
Does it show up in /run/media/<username> ?
 
Old 04-15-2018, 05:09 PM   #6
RandomTroll
Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 735

Rep: Reputation: 97
You have 2 physical drives. If you have only 1 built in, /dev/sdb may be your USB drive (the case on my computer).

If so, df tells us it isn't mounted. Does /etc/fstab have an entry for /dev/sdb1 ? If so, you can just run
Code:
mount /[MountPointOfUSBDrive]
. I assign /usb to /dev/sdb1 (pretty sneaky, eh?) so I can run
Code:
 mount /usb
. If not, you can choose a mount point and run
Code:
mount /dev/sdb1 /usb
(the mount point must exist; depending on permissions, only root may have write access; one can specify permissions with mount or assign them in /etc/fstab.

If you have 2 physical drives built in, the system hasn't detected your USB drive. In that case run
Code:
lsusb
.
 
Old 04-15-2018, 07:43 PM   #7
alanware
Member
 
Registered: Aug 2011
Location: Midwest-USA
Distribution: Slackware
Posts: 84

Original Poster
Rep: Reputation: Disabled
There is no /run/media directory.

I know how to mount the drive, I am after Thunar being able to auto browse/mount it without the need to run the mount command. I did a clean Slackware 14.2 install in a vm and everything worked fine. I also did a fresh install the the problem system and have the same issue.
 
Old 04-15-2018, 09:12 PM   #8
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 4,890

Rep: Reputation: 1674Reputation: 1674Reputation: 1674Reputation: 1674Reputation: 1674Reputation: 1674Reputation: 1674Reputation: 1674Reputation: 1674Reputation: 1674Reputation: 1674
Code:
/dev/mapper/slack-var   10190136    77428   9572036   1% /var
Have you tried with /var on the root partition rather than on a separate partition?
 
Old 04-15-2018, 09:47 PM   #9
alanware
Member
 
Registered: Aug 2011
Location: Midwest-USA
Distribution: Slackware
Posts: 84

Original Poster
Rep: Reputation: Disabled
allend
I am not sure what you mean.

I have instaslled from the same media with identical configurations. One on bare metal and the other into a virtual machine. The virtual machine works correctly and the bare metal does not.

The system detects the usb drive being inserted into the port. For some reason thunar cannot see it. I am setting this system up for another person to use and do not want to manually mount the drive. This works really well on my laptop and the virtual machine.

lsusb
Code:
Bus 001 Device 003: ID 0781:5571 SanDisk Corp. Cruzer Fit
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 
Old 04-15-2018, 10:28 PM   #10
RandomTroll
Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 735

Rep: Reputation: 97
Quote:
Originally Posted by alanware View Post
I am after Thunar being able to auto browse/mount it without the need to run the mount command.
Then my advice is beside the point. I don't know what Thunar is. I suspect Thunar is looking for instructions on which drives to mount, perhaps in a configuration file?
 
Old 04-15-2018, 11:27 PM   #11
alanware
Member
 
Registered: Aug 2011
Location: Midwest-USA
Distribution: Slackware
Posts: 84

Original Poster
Rep: Reputation: Disabled
Thunar is XFCEs file manager.
 
Old 04-16-2018, 09:04 AM   #12
keefaz
LQ Guru
 
Registered: Mar 2004
Distribution: Slackware
Posts: 6,068

Rep: Reputation: 673Reputation: 673Reputation: 673Reputation: 673Reputation: 673Reputation: 673
There was a thread some times ago with the same topic
https://www.linuxquestions.org/quest...nt-4175623755/

Unfortunatelly, no solution was found it seems. Which is weird because it should work out of the box
 
Old 04-16-2018, 09:28 AM   #13
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 4,890

Rep: Reputation: 1674Reputation: 1674Reputation: 1674Reputation: 1674Reputation: 1674Reputation: 1674Reputation: 1674Reputation: 1674Reputation: 1674Reputation: 1674Reputation: 1674
Does it work if you log in to run level 3, run 'xwmconfig' and then run 'startx'?
For the mounting to work, the DBUS_SESSION_BUS_ADDRESS environment variable must be set and dbus must be running.
 
Old 04-16-2018, 04:41 PM   #14
RandomTroll
Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 735

Rep: Reputation: 97
I speculate that Thunar looks for mounted drives but not mountable devices (this would be common). Thus you need to configure automount and/or autofs to mount newly-attached devices. I've never used either.
 
Old 04-16-2018, 05:49 PM   #15
alanware
Member
 
Registered: Aug 2011
Location: Midwest-USA
Distribution: Slackware
Posts: 84

Original Poster
Rep: Reputation: Disabled
DBUS_SESSION_BUS_ADDRESS
Code:
unix:abstract=/tmp/dbus-6N36WK81EL,guid=8ceb0a308cfb2bf7549785d45ad5064c
ps aux | grep dbus
Code:
message+  1213  0.0  0.0  19868  2352 ?        Ss   15:23   0:00 /usr/bin/dbus-daemon --system
localad+  1369  0.0  0.0  33000  3608 ?        S    15:23   0:00 ck-launch-session dbus-launch --exit-with-session awesome
localad+  1376  0.0  0.0  35484  2176 ?        S    15:23   0:00 dbus-launch --exit-with-session awesome
localad+  1377  0.0  0.0  19736  1972 ?        Ss   15:23   0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
localad+  1407  0.0  0.0  11636  2080 pts/0    S+   15:27   0:00 grep dbus
Thunar does not need any mounted drives. It auto populates when you plug removable media. My other Linux installs it just works. I am trying to figure out why it isn't working on this install.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Thunar: turning off auto-open for auto-mount newbiesforever Linux - Software 2 04-11-2016 11:42 AM
Auto Mount not working for USB? Hald not running? SonoranFun Linux - Newbie 6 05-15-2011 02:31 PM
Thunar, FluxBox & auto mount CopyrightPhilly Linux - Software 1 05-14-2009 01:06 PM
usb auto mount stopped working nkd Linux - Hardware 4 12-21-2008 12:08 PM
how is the usb auto mount working ? nkd Linux - Hardware 2 10-31-2007 01:48 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration