-   Slackware (
-   -   thunar does not seem to use gamin to show file changes? (

titopoquito 07-15-2007 05:26 AM

thunar does not seem to use gamin to show file changes?
Hi all,

I found nothing similar here, but some few threads outside -- and I got to the conclusion that it probably is a Slackware configuration issue.

I just started using xfce4 that comes with Slackware 12.0 along with its file manager, thunar. While both look great, thunar doesn't reflect file changes unless I manually refresh the content. Any ideas what might cause this? The info I have checked so far, I'm not absolute sure which one of this is really necessary:
  • kernel is compiled with inotify enabled
  • rc.messagebus and rc.hald get started when the machine is powered up
  • HAL, DBUS and gamin are installed and running, at least that's what "ps aux" shows to me
  • "ldd /usr/bin/thunar" shows no unmet dependencies

Any ideas what I am missing? :scratch:

MS3FGX 07-15-2007 08:59 AM

I don't think HAL or DBUS have anything to do with this particular issue, as those are used for handling physical devices and system events, not keeping track of files.

Personally I just thought that Thunar simply didn't update in real time, since other file managers (like ROX) do on my system. Looking it up it turns out it is supposed to, but it isn't working on my system either.

titopoquito 07-15-2007 09:13 AM

Thanks for answering, MS3FGX -- so at least I'm not the only one who can produce this problem :) Maybe I should try to just recompile gamin and xfce, but I'm confused because the ldd output looks right.

I was not sure about hal and dbus and if they might be involved some way. Thanks for that info.

Any others? I wonder if this the common thunar behaviour in Slackware 12.0. Anyone who don't have this problem at all with Slackware 12.0?

MS3FGX 07-15-2007 11:12 AM

Strange, now that I tried works. I know for a fact it did not during the -current phase, since I noticed a number of times that it was not updating.

I did notice that Slackware does not appear to include any configuration with the gamin package, so you could try creating a per-user configuration to jump start it. The configuration is pretty simple.

You should be able to do a real simple .gaminrc that just contains:


notify /home/username

tobyl 07-15-2007 11:22 AM

Its working ok here. Slack 12.

As a test I touched a file in the console, and it appeared immediately in thunar. Then I wrote something to a file, and saved - the no. of bytes increased immediately in thunar.

I see /usr/libexec/gam_server in my ps -ef if that helps

not sure what I have done differently to you, but I will run any test for you if you would like


titopoquito 07-15-2007 12:19 PM

Thanks to both of you. I created the .gaminrc file now and will reboot in a minute. gam_server is running here, too, that's what deeply confuses me. I did a full install again in VMWare Server to see if it makes any difference. Voilą - it works there, so I guess this functionality depends on any other stock Slackware package. I guess I will remove them one by one in my virtual machine :-/

titopoquito 07-15-2007 12:34 PM

After reboot it works for my home folder ok, but not for any subfolder of it. I'll have to dig a little bit in the configuration info you send me. Let there be wildcards :)

In the virtual machine it works "out of the box", like it works for tobyl. I'll get back if I have removed some packages from the full install to see if any of them makes the difference.

MS3FGX 07-15-2007 11:43 PM

Ah right, the line should be:


notify /home/username/*
Sorry about that.

titopoquito 07-16-2007 04:46 AM


Originally Posted by MS3FGX
Ah right, the line should be:


notify /home/username/*
Sorry about that.

No need to excuse, you could have written "RTFM" as well as I'm able of reading, well, most of the time :)

I will try to find what's wrong here that it didn't work out of the box and post it again. Tonight a flu caught me, so that will take some time...

hopbyhop 09-18-2008 01:45 AM

who runs gam_server in your machine?
I had a similar issue in slack 12.1, but had no gam_server process running. I solved starting gam_server with --notimeout switch in rc.local.
Strangely, no default initialization script ran gam on my machine.
What script does in yours?

tobyl 09-19-2008 04:49 PM

Hi hopbyhop

On my system I have the package gamin-0.1.9-i486-1 installed

it installs usr/libexec/gam_server

I think this is where it is called from.


hopbyhop 09-22-2008 01:49 AM

Thanks. I have the same package too. I would know which script in rc.d calls /usr/libexec/gam_server, if in your system it is running.

keefaz 09-22-2008 10:21 AM

The gam_server is automatically started once an application require it:
From the gamin author:

Originally Posted by Daniel Veillard
It was really designed so that each user gets a different
server, and when different programs runs for the same user they share
the access. The fact that gam_server got started because application A
or application B on the desktop needed the monitoring feature should
not matter, they really should share the instance.
We really do not want to see a gam_server for nautilus, one for
firefox, etc... The server is dynamically started by the first app
needing FAM, the others connect based on the user ID being shared.
the whole security design of gamin is based on the assumption that all
process running for a given UID share their filesystem permissions
and hence can share the gam_server instances. As a result the server
runs under the ID of the given user.

All times are GMT -5. The time now is 01:19 PM.