LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-06-2019, 02:37 PM   #3526
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 5,632

Rep: Reputation: 3389Reputation: 3389Reputation: 3389Reputation: 3389Reputation: 3389Reputation: 3389Reputation: 3389Reputation: 3389Reputation: 3389Reputation: 3389Reputation: 3389

Quote:
Originally Posted by SCerovec View Post
I think you're covered in slack docs for this but here a TL;DR:
0. as root
1. first stop and disable network manager or/and wicd in /etc/rc.d
2. configure /etc/wpa_supplicant.conf by running wpa_passphrase for your intended hotspot or connection
3. make sure /etc/rc.d/rc.inet1.conf references wpa_supplicant properly:
Code:
WLAN_WPA[1]="wpa_supplicant"
for wireless interface with index [1]
4. restart /etc/rc.d/rc.inet1
In reference to #3, I simply made sure the following existing lines in /etc/rc.d/rc.inet1.conf were uncommented.

Code:
IFNAME[4]="wlan0"
USE_DHCP[4]="yes"
WLAN_WPA[4]="wpa_supplicant"
Once that was done and wpa_supplicant.conf was set up correctly, I have no problems connecting to wifi. If you want a static address, you'd just uncomment those items as well and ensure they're set properly. On my setup, I simplified it by adding my MAC address to my router for static leases to always assign it the same address (effectively a static IP, but the computer still uses DHCP and the router always provides the same IP).
 
Old 01-06-2019, 04:11 PM   #3527
JWJones
Senior Member
 
Registered: Jun 2009
Location: Cascadia
Distribution: None - OpenBSD
Posts: 1,154

Rep: Reputation: 452Reputation: 452Reputation: 452Reputation: 452Reputation: 452
Quote:
Originally Posted by SCerovec View Post
I think you're covered in slack docs for this but here a TL;DR:
0. as root
1. first stop and disable network manager or/and wicd in /etc/rc.d
2. configure /etc/wpa_supplicant.conf by running wpa_passphrase for your intended hotspot or connection
3. make sure /etc/rc.d/rc.inet1.conf references wpa_supplicant properly:
Code:
WLAN_WPA[1]="wpa_supplicant"
for wireless interface with index [1]
4. restart /etc/rc.d/rc.inet1
Yup, that did it, works like a charm. Thanks!
 
1 members found this post helpful.
Old 01-07-2019, 09:13 AM   #3528
SCerovec
Senior Member
 
Registered: Oct 2006
Location: Cp6uja
Distribution: Slackware on x86 and arm
Posts: 1,376
Blog Entries: 2

Rep: Reputation: 296Reputation: 296Reputation: 296
Quote:
Originally Posted by bassmadrigal View Post
In reference to #3, I simply made sure the following existing lines in /etc/rc.d/rc.inet1.conf were uncommented.

Code:
IFNAME[4]="wlan0"
USE_DHCP[4]="yes"
WLAN_WPA[4]="wpa_supplicant"
Once that was done and wpa_supplicant.conf was set up correctly, I have no problems connecting to wifi. If you want a static address, you'd just uncomment those items as well and ensure they're set properly. On my setup, I simplified it by adding my MAC address to my router for static leases to always assign it the same address (effectively a static IP, but the computer still uses DHCP and the router always provides the same IP).
yes, indeed, DHCP with MAC->IP fixed pairing is the only proper way - once you change the receiving computer or it's network interface - you simply update the MAC on the router

The rest of time it's automagic on work

but what i didn't konw - that one could have interfaces out of order and they will still work?
 
Old 01-07-2019, 11:20 AM   #3529
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 5,632

Rep: Reputation: 3389Reputation: 3389Reputation: 3389Reputation: 3389Reputation: 3389Reputation: 3389Reputation: 3389Reputation: 3389Reputation: 3389Reputation: 3389Reputation: 3389
Quote:
Originally Posted by SCerovec View Post
but what i didn't konw - that one could have interfaces out of order and they will still work?
Out of order? If you're referring to my rc.inet1.conf snippet, that is pulled out of an almost unmodified version from 14.2. The only thing I did was change USE_DHCP[0] from yes to nothing and then uncomment the above lines. I didn't even need to modify the lines themselves...
 
Old 01-07-2019, 03:42 PM   #3530
SCerovec
Senior Member
 
Registered: Oct 2006
Location: Cp6uja
Distribution: Slackware on x86 and arm
Posts: 1,376
Blog Entries: 2

Rep: Reputation: 296Reputation: 296Reputation: 296
Talking

Quote:
Originally Posted by bassmadrigal View Post
Out of order? If you're referring to my rc.inet1.conf snippet, that is pulled out of an almost unmodified version from 14.2. The only thing I did was change USE_DHCP[0] from yes to nothing and then uncomment the above lines. I didn't even need to modify the lines themselves...
Then maybe you have 5 network interfaces the 5th being a Wireless?
 
Old 01-07-2019, 04:48 PM   #3531
bassmadrigal
LQ Guru
 
Registered: Nov 2003
Location: West Jordan, UT, USA
Distribution: Slackware
Posts: 5,632

Rep: Reputation: 3389Reputation: 3389Reputation: 3389Reputation: 3389Reputation: 3389Reputation: 3389Reputation: 3389Reputation: 3389Reputation: 3389Reputation: 3389Reputation: 3389
Quote:
Originally Posted by SCerovec View Post
Then maybe you have 5 network interfaces the 5th being a Wireless?
This is just the default rc.inet1.conf and that's the designation Pat uses for his wireless entries. Have a look: rc.inet1.conf on a Slackware mirror. I don't currently use any other network on my machine (but I eventually plan to switch back to ethernet once I run it at the new house).

Here's the relevant wireless section out of it. You just uncomment and adjust what you need. I just uncomment IFNAME, USE_DHCP, and WLAN_WPA, and none of them need adjustment (in my case).

Code:
## Example config information for wlan0.  Uncomment the lines you need and fill
## in your data.  (You may not need all of these for your wireless network)
#IFNAME[4]="wlan0"
#IPADDR[4]=""
#NETMASK[4]=""
#USE_DHCP[4]="yes"
#DHCP_HOSTNAME[4]="icculus-wireless"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
#WLAN_ESSID[4]=DARKSTAR
#WLAN_MODE[4]=Managed
#WLAN_RATE[4]="54M auto"
#WLAN_CHANNEL[4]="auto"
#WLAN_KEY[4]="D5A31F54ACF0487C2D0B1C10D2"
#WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=96389dc66eaf7e6efd5b5523ae43c7925ff4df2f8b7099495192d44a774fda16"
#WLAN_WPA[4]="wpa_supplicant"
#WLAN_WPADRIVER[4]="wext"
#WLAN_WPAWAIT[4]=30
I should mention that there is nothing wrong with the method you use. This is just what I do. Both methods work equally well. In my case, I just delete 3 characters (to uncomment those three options) and remove the "yes" from the first dhcp entry for eth0 so I don't have to wait for it to time out.

Last edited by bassmadrigal; 01-07-2019 at 04:52 PM.
 
2 members found this post helpful.
Old 01-08-2019, 06:48 AM   #3532
SCerovec
Senior Member
 
Registered: Oct 2006
Location: Cp6uja
Distribution: Slackware on x86 and arm
Posts: 1,376
Blog Entries: 2

Rep: Reputation: 296Reputation: 296Reputation: 296
Yes!
the script patiently iterates over each and every index from 0 to $MAXNICS, regardless of the edits in the *.conf file, so even the later and out of order ones are picked up!

Very clever and flexible Mr. Volkerding
 
Old 01-08-2019, 04:01 PM   #3533
Lysander666
Senior Member
 
Registered: Apr 2017
Location: The Underearth
Distribution: Slackware
Posts: 1,114
Blog Entries: 3

Rep: Reputation: 1038Reputation: 1038Reputation: 1038Reputation: 1038Reputation: 1038Reputation: 1038Reputation: 1038Reputation: 1038
Dark minimalist Middle Eastern landscapes/culture... such an untapped area.

EDIT: OK, MENA maybe.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2019-01-08_20-59-24.jpg
Views:	116
Size:	200.4 KB
ID:	29431  

Last edited by Lysander666; 01-08-2019 at 04:04 PM.
 
3 members found this post helpful.
Old 01-09-2019, 06:12 AM   #3534
l0f4r0
Member
 
Registered: Jul 2018
Location: Paris
Distribution: MacOS, Slackware
Posts: 626

Rep: Reputation: 196Reputation: 196
^ It looks like Mojave desert: https://fr.wikipedia.org/wiki/MacOS_...ve-desktop.jpg
Tell us Lysander666, you are actually running MacOS Mojave with its *revolutionary* dark mode instead! ;p
 
1 members found this post helpful.
Old 01-09-2019, 04:58 PM   #3535
Lysander666
Senior Member
 
Registered: Apr 2017
Location: The Underearth
Distribution: Slackware
Posts: 1,114
Blog Entries: 3

Rep: Reputation: 1038Reputation: 1038Reputation: 1038Reputation: 1038Reputation: 1038Reputation: 1038Reputation: 1038Reputation: 1038
Quote:
Originally Posted by l0f4r0 View Post
^ It looks like Mojave desert: https://fr.wikipedia.org/wiki/MacOS_...ve-desktop.jpg
Tell us Lysander666, you are actually running MacOS Mojave with its *revolutionary* dark mode instead! ;p
However hard I try, I just can't get behind the idea of docks. I've tried them so many times and they just feel superfluous to me. One panel to rule them all.
 
Old 01-10-2019, 03:52 PM   #3536
Lysander666
Senior Member
 
Registered: Apr 2017
Location: The Underearth
Distribution: Slackware
Posts: 1,114
Blog Entries: 3

Rep: Reputation: 1038Reputation: 1038Reputation: 1038Reputation: 1038Reputation: 1038Reputation: 1038Reputation: 1038Reputation: 1038
I'm cheating a bit with this post but I'm experimenting with Slackware Live Xfce for the first time. What a fantastic innovation, and only 692MB. So this is not a permanent desktop, obviously, but it's great to see that this thing exists. Great, great work, Eric.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2019-01-10_20-53-00.jpg
Views:	86
Size:	132.3 KB
ID:	29441  

Last edited by Lysander666; 01-10-2019 at 03:53 PM.
 
2 members found this post helpful.
Old 01-10-2019, 08:37 PM   #3537
andrew.46
Member
 
Registered: Oct 2007
Distribution: Slackware
Posts: 934

Rep: Reputation: 214Reputation: 214Reputation: 214
Quote:
Originally Posted by Lysander666 View Post
I'm cheating a bit with this post but I'm experimenting with Slackware Live Xfce for the first time. What a fantastic innovation, and only 692MB
I blew up an HDD and spent several days running just the Live DVD before the new HDD arrived and I agree it is an amazing bit of work
 
2 members found this post helpful.
Old 01-11-2019, 11:51 AM   #3538
SCerovec
Senior Member
 
Registered: Oct 2006
Location: Cp6uja
Distribution: Slackware on x86 and arm
Posts: 1,376
Blog Entries: 2

Rep: Reputation: 296Reputation: 296Reputation: 296
It makes no justice to say it's just amazing

Eric lifted live on a new level IMHO
 
1 members found this post helpful.
Old 01-11-2019, 01:53 PM   #3539
hazel
Senior Member
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: Debian, Crux, LFS, AntiX, Slackware
Posts: 2,597
Blog Entries: 6

Rep: Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288
Here is one of them. I have four, as on all my distros (except Debian), each one with a different buttonbar. This one is the "Default" desktop. The other ones are for Internet, System and Manuals.

The window manager is my favorite, Fluxbox.
Attached Thumbnails
Click image for larger version

Name:	screenshot.png
Views:	91
Size:	67.1 KB
ID:	29449  
 
4 members found this post helpful.
Old 01-12-2019, 12:12 PM   #3540
jr_bob_dobbs
Member
 
Registered: Mar 2009
Distribution: Linux From Scratch, Bedrock
Posts: 325
Blog Entries: 46

Rep: Reputation: 15
Quote:
Originally Posted by andrew.46 View Post
I blew up an HDD
Story please?
 
  


Reply

Tags
background, cwm, dwm, framebuffer, gui, i3, ion3, kde, monitor, musca, screenshot, tmux, wallpaper, xfce4, xterm


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
3D Desktop on Slackware? darkhatter Slackware 3 10-10-2006 01:26 PM
Slackware 10.0 with NO Desktop NiPP Linux - Newbie 2 01-02-2006 11:43 AM
3d desktop on Slackware k1ll3r_x Linux - Software 1 09-20-2005 11:47 PM
Desktop Slackware s0no Slackware 5 12-04-2004 12:20 PM
I can't get my desktop in Slackware 10 DraGoNsLaYeR Linux - Newbie 1 06-27-2004 03:00 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 05:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration