LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-31-2004, 12:04 PM   #301
Reap3R
LQ Newbie
 
Registered: May 2004
Location: Norway
Distribution: Debian, Gentoo, FreeBSD
Posts: 11

Rep: Reputation: 0

This tread really helped me alot.. thanks!!!
 
Old 09-01-2004, 11:57 AM   #302
denizen
LQ Newbie
 
Registered: Jul 2004
Distribution: slackware
Posts: 19

Rep: Reputation: 0
Thank you, I just got slackware yesterday and I haven't had time to try all that stuff.But I've learned a lot just by reading it.

thanks alot shilo that post was very informative and easy to read
 
Old 09-02-2004, 10:47 AM   #303
paulinimus
Member
 
Registered: Aug 2004
Distribution: SLACKWARE10.0
Posts: 65

Rep: Reputation: 15
You truly are the finest geek Shilo
I salute your 1337|\|355
.

 
Old 09-03-2004, 12:27 PM   #304
UltimateZer0
LQ Newbie
 
Registered: Sep 2003
Posts: 10

Rep: Reputation: 0
Quote:
Originally posted by mangeli
Ok, so I have an install of slackware 9.1

However I cannot find the map.bmp or the boot.bmp.b (or whatever file it is...)

Is this installed in the default install?
IIRC, they are located in /usr/doc/lilo-x.x/sample/ and there are two different maps. One called ins64a.bmp, and one called logo64a.bmp.
Also, each bitmap has a .dat file of the same name associated with it. I used the lilo.conf.sample to learn what to do with /etc/lilo.conf and then after everything is done, just /sbin/lilo and you're all set.
 
Old 09-08-2004, 12:48 PM   #305
chud67
Member
 
Registered: Jul 2004
Location: San Antonio, TX, USA
Posts: 34

Rep: Reputation: 15
Re: This is how I do it all

Quote:
Originally posted by shilo

Anyhow, crank up your favorite text editor and open /etc/inittab . Now see that line that says:

# Default runlevel. (Do not set to 0 or 6)
id:3:initdefault:

Change it to:

# Default runlevel. (Do not set to 0 or 6)
id:4:initdefault:

Now you'll be greeted by your shiny new graphical login manger when you boot up. If you're like me, you'll have your share of troubles and wish you were logging into console. When something like that comes up, it's nice to remember that ctrl-alt-f6 opens up a text console. Ctrl-alt-f7 takes you back to X.

Ok, this works great but I have a dumb question. When you log out of your session and are taken back to the graphical login screen, how do you shutdown at this point? There's a button at the bottom to choose what kind of session you want (KDE, WindowMaker, etc), but no 'shut down' button. I've been just Ctrl-Alt-F6'ing to a text prompt and shutting down from there. Is that what everyone else does?
Also, how can you change the background wallpaper at this graphical login screen? Right now it is a plain background with a flower on the side, I'd like to change it to something cooler. Thanks.
 
Old 09-08-2004, 03:12 PM   #306
shilo
Senior Member
 
Registered: Nov 2002
Location: Stockton, CA
Distribution: Slackware 11 - kernel 2.6.19.1 - Dropline Gnome 2.16.2
Posts: 1,132

Original Poster
Rep: Reputation: 50
chud67-

There is a system button with a shutdown option from the gdm screen. At least there is on mine. For configuring the gdm screen "Accessories => System TOols => Login Manager" should do the trick for all the other things you want. I think that's where it's at. Im away from my Linux boxes right now.
 
Old 09-09-2004, 10:00 AM   #307
chud67
Member
 
Registered: Jul 2004
Location: San Antonio, TX, USA
Posts: 34

Rep: Reputation: 15
Quote:
Originally posted by shilo
chud67-

There is a system button with a shutdown option from the gdm screen. At least there is on mine. For configuring the gdm screen "Accessories => System TOols => Login Manager" should do the trick for all the other things you want. I think that's where it's at. Im away from my Linux boxes right now.
Ok, I found it. If you log in to Gnome (rather than KDE as I had been doing), you go to Applications - System Tools - Login Screen Setup, then click the "Security" tab, then check "Show actions menu".
Then when you log out and are back at the graphical login screen, you'll have an "Actions" button at the bottom which will give you the option to log out. Like many things in Slack I can't imagine why this isn't enabled by default, but oh well.
 
Old 09-09-2004, 10:21 AM   #308
shilo
Senior Member
 
Registered: Nov 2002
Location: Stockton, CA
Distribution: Slackware 11 - kernel 2.6.19.1 - Dropline Gnome 2.16.2
Posts: 1,132

Original Poster
Rep: Reputation: 50
chud67-

Sorry, I didn't think to ask if you were using KDE or Gnome. I am guessing that you are using GDM to login graphically. Thus, the settings are in Gnome. Why doesn't Slackware enable this by default? Two things I can think of. The first it that Gnome does not ditribute it with it enabled by default. Slackware doesn't mess with the software too much. That's one of the nice things about Slackware. Gnome looks like Gnome, not some Distro desktop environment. You make it look and work how you want it to look and work. A second thing is that many people don't think it's such a hot idea letting anyone who wants to shut down their system. This becomes more of an issue if you are running servers on your system.
 
Old 09-09-2004, 08:35 PM   #309
hkxx9
Member
 
Registered: Sep 2004
Location: Smoky Mtns
Distribution: Slackware 10
Posts: 64

Rep: Reputation: 15
Thumbs up

Great info, shilo!

Got my wheel mouse poppin' wheelies AND my nVidia drivers installed!

Thx, Dude (?)

cheers
 
Old 09-10-2004, 10:12 PM   #310
chud67
Member
 
Registered: Jul 2004
Location: San Antonio, TX, USA
Posts: 34

Rep: Reputation: 15
Re: Re: This is how I do it all

Quote:
Originally posted by chud67

Also, how can you change the background wallpaper at this graphical login screen? Right now it is a plain background with a flower on the side, I'd like to change it to something cooler. Thanks.
Ok, I'm answering my own question here in case anyone might be interested in how I did this. To change the wallpaper (theme) at the graphical login screen, just log in as root running a Gnome session. Then I went to http://www.customize.org/details/33166 and got the nice Slackware theme, which I saved to /usr/share/gdm/themes (it was a bz2 file). Then in Gnome I clicked on Applications - System Tools - Login Screen Setup. Click the 'Graphical Greeter' tab, and then the 'Install New Theme' button. Select the file and bam, it should appear in your list of themes there. Check the circle next to your theme (this one was called SlackCurve), and then close. Log out of your session and there you go, a nice Slack theme at your graphical login!
 
Old 09-11-2004, 09:20 AM   #311
celticX
Member
 
Registered: May 2004
Location: Northwest Ohio
Distribution: Slackware 10
Posts: 41

Rep: Reputation: 15
Shilo you are a hell of a man. Thankyou with the kernel compile, the only other thing besides nvidia i had to update was ndiswrapper. All in all hell of a post.
 
Old 09-19-2004, 04:20 PM   #312
bluenirve
Member
 
Registered: May 2003
Distribution: Slackware 10
Posts: 56

Rep: Reputation: 15
Quote:
Originally posted by taltman
Does anyone have the correct lilo.conf entry for blood_omen's boot screen?
http://www.geocities.com/mctarnet/images/lilo2.bmp
I am having some trouble lining things up.
I'd like it too. Thanks.
 
Old 10-03-2004, 07:47 PM   #313
stigfjel
LQ Newbie
 
Registered: Sep 2004
Distribution: Slackware, FreeBSD
Posts: 7

Rep: Reputation: 0
Could you please add instructions that tells what to do if I shall upgrade the kernel when the system disk is a SCSI disk?
 
Old 10-07-2004, 04:33 PM   #314
noobtesting
Member
 
Registered: Mar 2004
Location: Illinois
Distribution: Mint 15
Posts: 163

Rep: Reputation: 30
hello,

I was trying to wade through all the posts here and am having a hard time doing it. I was wondering if anyone has taken the time to put all the great info here into a pdf, txt or web site? I know shilo has one but I went to it and it doesn't look like it has been updated recently.

Also I was wondering if Shilo ever made a guide on setting up squirrelmail at all?

Thanks for your time
 
Old 10-07-2004, 07:12 PM   #315
Slackabuser
LQ Newbie
 
Registered: May 2004
Location: Indianapolis
Distribution: Slackware 9.1
Posts: 6

Rep: Reputation: 0
Hard Drive FTP issues

Shilo,
or anyone else that can help please....some background....I was previously dual booting Windows 2000 Pro and Slackware 9.1. Windows = /dev/hda1 and Slackware = /dev/hdb2 . I followed Shilo's advice about FTP, Web setup and everything was working fine. I was able to boot up linux and leave the house with the ability to login to my home computer and access files via FTP. Happiness was everywhere.
Today I removed the slave drive (Slackware = /dev/hdb) and installed it as a master in it's own tower. My new setup as follows:

Linux, Tower 1: Asus A7V 233, GeForce2 64MB video card, Linksys LNE100TX, Maxtor 40GB HDD, Slackware 9.1. I changed Lilo to boot to /dev/hda2 (rather than previous hdb) I changed my virtual server to route to the new tower ip address but did not change any port settings.

Windows Tower 2: Asus A7V 333, GeForce4 64MB video card, Linksys LNE100TXv5, Seagate 120GB HDD, Windows 2000 Professional.

Both towers are connected to 1 Monitor, 1 Keyboard, 1 Mouse through a Belkin 2 port KVM switch.

Problem = I can access linux through FTP within my home network, however, I can no longer access it from outside of my house. When I try to log in from outside my home network now I recieve loading error asking me to make sure I have permission or correct address. When I select "Login as..." I still can not login. Any ideas about what settings may need to be updated or changed? Perhaps a point in a certain direction that might help?

Thanks to anyone who can help or provide direction. If further info needs to be given just ask me. =)
 
  


Reply

Tags
kernel


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration