LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-02-2004, 12:06 PM   #181
fcaraballo
Member
 
Registered: Feb 2004
Location: WA
Distribution: Slackware
Posts: 230

Rep: Reputation: 31

^ bumb ^

MagicMan


P.S. This thread really should be pinned MODS.
 
Old 06-02-2004, 02:14 PM   #182
g452
Member
 
Registered: May 2003
Location: tswane
Distribution: Slackware 9.1
Posts: 113

Rep: Reputation: 15
cxxxxxx{====B=U=M=P====>

i second the motion that this thread should be bloody PINNED !!!

A hail the slack penguin !!

;D
 
Old 06-03-2004, 09:28 AM   #183
machinecraig
LQ Newbie
 
Registered: Jul 2003
Distribution: Slackware-current
Posts: 8

Rep: Reputation: 0
bump...

Just a reminder to the mods... consider pinning this post!!!
 
Old 06-03-2004, 07:58 PM   #184
plan9
Member
 
Registered: May 2004
Location: USA
Distribution: Slackware-Current
Posts: 74

Rep: Reputation: 15
Thanks alot, this post has been very helpful getting me up and going quickly. Now to dig in and do some learning!

9
 
Old 06-04-2004, 02:36 AM   #185
mickey1980
LQ Newbie
 
Registered: May 2004
Location: Singapore
Distribution: slackware/fedora
Posts: 8

Rep: Reputation: 0
hi all,
i did a fresh install of slackware 9.1 and i'm getting the following error messages in
#dmesg output:

/sbin/modprobe -k -s scsi_hostadaptor failed...

does anyone know why?
 
Old 06-04-2004, 10:37 AM   #186
shilo
Senior Member
 
Registered: Nov 2002
Location: Stockton, CA
Distribution: Slackware 11 - kernel 2.6.19.1 - Dropline Gnome 2.16.2
Posts: 1,132

Original Poster
Rep: Reputation: 50
mickey1980-

You are trying to load a module named scsi_hostadaptor, and it's not working. Odds are, you don't use SCSI, so this error really doesn't matter.
 
Old 06-04-2004, 01:13 PM   #187
Systematic
Member
 
Registered: May 2004
Location: Mechanicsburg, PA
Distribution: Mainly Slackware, but test run various different distros.
Posts: 77

Rep: Reputation: 15
did you enable hotplug by chance? if so, you can add this to your hotplug blacklist so that it does not try to load the module on startup.

just add the module scsi_hostadaptor to /etc/hotplug/blacklist

i had to do this for the b44 module for my nic. Im using the bcm4400 module but slack was trying to load both and i was getting swamped with errors on the b44 module.. added it to the blacklist file and poof errors gone!
 
Old 06-04-2004, 10:12 PM   #188
Drakeuser
LQ Newbie
 
Registered: May 2004
Location: United States
Distribution: Slackware 9.1
Posts: 11

Rep: Reputation: 0
*cough* bump *cough* ...oh did I do that? hehehe
 
Old 06-05-2004, 12:32 AM   #189
Justin_Time
Member
 
Registered: Feb 2004
Posts: 53

Rep: Reputation: 15
Quote:
Originally posted by Systematic
did you enable hotplug by chance? if so, you can add this to your hotplug blacklist so that it does not try to load the module on startup.

just add the module scsi_hostadaptor to /etc/hotplug/blacklist
I still think that not using the hotplug script at all is better, the only advantage it has is to detect your modules by default. When you know what those are (lsmod) then you just put them in your /etc/rc.d/rc.modules and disable hotplug. This will be also a little bit faster for startup.
 
Old 06-05-2004, 11:34 AM   #190
Drakeuser
LQ Newbie
 
Registered: May 2004
Location: United States
Distribution: Slackware 9.1
Posts: 11

Rep: Reputation: 0
Shilo

You said if there was anything to add that might be helpful to let you know so.....

I am not sure what I did but I started getting this error

Failed to start SSH server : Starting sshd:@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ @ WARNING: UNPROTECTED PRIVATE KEY FILE! @ @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ Permissions 0775 for '/etc/ssh/ssh_host_key' are too open. It is recommended that your private key files are NOT accessible by others. This private key will be ignored. bad permissions: ignore key: /etc/ssh/ssh_host_key Could not load host key: /etc/ssh/ssh_host_key @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ @ WARNING: UNPROTECTED PRIVATE KEY FILE! @ @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ Permissions 0775 for '/etc/ssh/ssh_host_rsa_key' are too open. It is recommended that your private key files are NOT accessible by others. This private key will be ignored. bad permissions: ignore key: /etc/ssh/ssh_host_rsa_key Could not load host key: /etc/ssh/ssh_host_rsa_key @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ @ WARNING: UNPROTECTED PRIVATE KEY FILE! @ @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ Permissions 0775 for '/etc/ssh/ssh_host_dsa_key' are too open. It is recommended that your private key files are NOT accessible by others. This private key will be ignored. bad permissions: ignore key: /etc/ssh/ssh_host_dsa_key Could not load host key: /etc/ssh/ssh_host_dsa_key Disabling protocol version 1. Could not load host key Disabling protocol version 2. Could not load host key sshd: no hostkeys available -- exiting. [FAILED]


After doing a search I found out to fix this you just have to type

chmod 600 /etc/ssh/ssh_host_rsa_key
chmod 600 /etc/ssh/ssh_host_dsa_key

this will set your key files to the proper setting once again and then you can...

/etc/rc.d/rc.sshd stop
/etc/rc.d/rc.sshd start


Anyway, if this helps anyone out then great. I was probably messing with something I shouldn't have but hey I learned something and hopefully someone else will benefit from this.
 
Old 06-05-2004, 01:54 PM   #191
shilo
Senior Member
 
Registered: Nov 2002
Location: Stockton, CA
Distribution: Slackware 11 - kernel 2.6.19.1 - Dropline Gnome 2.16.2
Posts: 1,132

Original Poster
Rep: Reputation: 50
Drakeuser-

Sweet. Glad you got it worked out. I haven't messed around with the permissions too much, so here is a listing from mine to show what (I believe) is the default.
Code:
shilo@shilo:~$ ls -l /etc/ssh
total 144
-rw-r--r--  1 root root 111892 2004-02-28 06:59 moduli
-rw-r--r--  1 root root   1159 2003-09-23 11:14 ssh_config
-rw-------  1 root root    668 2004-04-06 22:28 ssh_host_dsa_key
-rw-r--r--  1 root root    602 2004-04-06 22:28 ssh_host_dsa_key.pub
-rw-------  1 root root    527 2004-04-06 22:28 ssh_host_key
-rw-r--r--  1 root root    331 2004-04-06 22:28 ssh_host_key.pub
-rw-------  1 root root    887 2004-04-06 22:28 ssh_host_rsa_key
-rw-r--r--  1 root root    222 2004-04-06 22:28 ssh_host_rsa_key.pub
-rw-r--r--  1 root root   2552 2004-05-15 19:11 sshd_config
Thanks for all the bumps, too.
 
Old 06-06-2004, 08:30 PM   #192
mickey1980
LQ Newbie
 
Registered: May 2004
Location: Singapore
Distribution: slackware/fedora
Posts: 8

Rep: Reputation: 0
Hi All, thanks for the reply to my message regarding the scsi_hostadapter error...

Justin, you mention that it's better not to use hotplug at all, however i was not ablt to detect
my Alcatel USB modem attached to the usb port if i do not use hotplug...

Is there another way to get around it? Thks again for the advice

mickey
 
Old 06-07-2004, 10:04 PM   #193
mickey1980
LQ Newbie
 
Registered: May 2004
Location: Singapore
Distribution: slackware/fedora
Posts: 8

Rep: Reputation: 0
Hi All,

So i did a #lsmod, get a list of modules that i need, edited my rc.modules and then #chmod -x /etc/rc.d/rc.hotplug
and finally i did a reboot.

however #dmesg still shows the same error:
"kmod: /sbin/modprobe -k -s scsi_hostadaptor failed...."

the only scsi related module that is loaded is ide-scsi. this is required for my cd-rw to work... anyway i tried not to load this module, so i commented that line in my rc.module file and did a reboot

as expected, the cd-rw didn't work anymore but wat's worst is that the same error messages are still there.

could this be due to the modules that are precomplied into the kernel itself? i have tried both the bare.i and bareapci.i
modules but still gets the same error...hmm...

can anyone pls advice me on this?

mickey
 
Old 06-08-2004, 08:59 AM   #194
Systematic
Member
 
Registered: May 2004
Location: Mechanicsburg, PA
Distribution: Mainly Slackware, but test run various different distros.
Posts: 77

Rep: Reputation: 15
hmmm... you may need to use the scsi.s kernel image for scsi emulation support for your cdrw. bare.i and bareapci.i won't work..
 
Old 06-08-2004, 03:56 PM   #195
shilo
Senior Member
 
Registered: Nov 2002
Location: Stockton, CA
Distribution: Slackware 11 - kernel 2.6.19.1 - Dropline Gnome 2.16.2
Posts: 1,132

Original Poster
Rep: Reputation: 50
Could be that the SCSI module is trying to load from somewhere else in the startup scripts. Look through all of the files in /etc/rc.d/ to see if something else is attempting to load the module. I'd just take my time looking, though, as I don't believe that you have any problem besides the error message. One solution to your cd-rw issue is to upgrade to kernel 2.6.xx. SCSI emulation is no longer required.
 
  


Reply

Tags
kernel


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration