LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-09-2013, 12:16 PM   #1
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,472

Rep: Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523
Thinkpad T400 Hardware


Two hardware questions:

1. What is the equivalent of a reset/reboot button that most desktop models have?

I can press the On/Off button for about 5 seconds to power off the laptop. I want to reboot the laptop without powering off. (Sometimes the laptop freezes and Ctrl-Alt-Del fails to reboot.)

2. How do I toggle on/off the trackpad?

The sledge hammer approach is disabling in the BIOS. I want to toggle on-the-fly, through a script or a desktop applet. I have read a little about xinput but haven't wrapped my mind around how that works.

Mostly I'm interested in disabling the trackpad while I'm typing. I've seen references to syndaemon and synclient, both of which are in Slackware, but some examples would help. When I test either command I get messages of "Couldn't find synaptics properties. No synaptics driver loaded?" and "Unable to find a synaptics device."

I have seen references that Fn-F8 can toggle the trackpad, but I have only found references to this for Windows. Probably a rather clunky solution anyway as there should be a simple way to disable the trackpad while typing.

Thanks.

Edit: Related to No. 2, I found this information:

Disable touchpad upon external mouse detection

Unfortunately, the udev rule does not work. Any ideas how to remedy that? Thanks.

Last edited by Woodsman; 07-09-2013 at 12:53 PM.
 
Old 07-09-2013, 01:34 PM   #2
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,199

Rep: Reputation: 290Reputation: 290Reputation: 290
synclient TouchpadOff=1

Will disable the trackpad.

I don't know of any way of doing a reset similar to a desktop. I've had a T21, T42, T43 and now a T420 and I don't recall there ever being a reset button and always had to resort to holding power button on a hard lockup.
 
Old 07-09-2013, 02:27 PM   #3
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,452

Rep: Reputation: Disabled
"syndaemon -i 2 -d" will disable the touchpad after the amount of idle time you set (the -i argument). You can have it start up automatically with X.

If you have an xorg.conf it should have "Option "SHMConfig" "on"" set in the synaptics device section.

Brian
 
Old 07-09-2013, 03:39 PM   #4
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,472

Original Poster
Rep: Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523
I will experiment. Does this toggling require root privileges?

I now realize that before when I wrote I received error messages when running the synclient and syndaemon commands I was in run level 3 and not in X.

That said, I think I discovered the true problem. As this is my first laptop, took me a while to understand the terminology. The real problem is something called tapping. Any slight momentary touch triggers this tapping mode. How do I stop ALL tapping such that the trackpad is only a device to move the mouse pointer? The trackpad has two "mouse" buttons. I don't need this tapping thing.

Thanks.

Quote:
I don't know of any way of doing a reset similar to a desktop. I've had a T21, T42, T43 and now a T420 and I don't recall there ever being a reset button and always had to resort to holding power button on a hard lockup.
Huh. Well, okay then. The sledge hammer will have to suffice. Thanks.

Last edited by Woodsman; 07-09-2013 at 03:40 PM.
 
Old 07-09-2013, 03:54 PM   #5
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,452

Rep: Reputation: Disabled
from the synaptics man page:

Quote:
Option "TapButton1" "integer"
Which mouse button is reported on a non-corner one-finger tap. Set to 0 to disable. Property: "Synaptics Tap Action"
Brian
 
Old 07-09-2013, 06:31 PM   #6
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,472

Original Poster
Rep: Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523
Quote:
from the synaptics man page:
I don't know whether I did this correctly, but here goes. I copied /usr/share/X11/xorg.conf.d/50-synaptics.conf to /etc/X11/xorg.conf.d/.

Then I set all three TapButton options to zero:

Code:
Section "InputClass"
	Identifier "touchpad"
	Driver "synaptics"
	MatchDevicePath "/dev/input/event*"
	MatchIsTouchpad "on"
	Option "TapButton1" "0"
	Option "TapButton2" "0"
	Option "TapButton3" "0"
EndSection
I don't know whether I resolved the main trackpad irritants, but for the past many minutes I seem unable to create popup menus and the like through any type of intentional or inadvertent tapping.

Quote:
synclient TouchpadOff=1
Seems to work when typed in a terminal window. Toggling with zero seems to restore the function.

Quote:
"syndaemon -i 2 -d" will disable the touchpad
Seems to work when typed from a terminal window. I executed the command, started moving the mouse pointer with the trackpad and then started typing random characters. When I typed the mouse pointer stopped moving. Yes, I also can rub my belly and concurrently tap my head.

To answer my own question, root privileges are not needed.

Regarding the synclient command, now that tapping is disabled and I can run the syndaemon command in an autostart script, I don't know whether I'll need that command. Perhaps later as I grow accustomed to the laptop I might decide I need a desktop icon to a one-liner script.

I'll tag this thread as resolved.

Thanks much!
 
Old 07-09-2013, 06:39 PM   #7
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,366
Blog Entries: 2

Rep: Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981Reputation: 3981
Just to add this, I use this, bound to a keyboard combination, to toggle the touchpad on and off:
Code:
#!/bin/bash

synclient TouchpadOff=$(synclient -l|grep -c 'TouchpadOff.*=.*0')
 
Old 07-09-2013, 06:58 PM   #8
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,472

Original Poster
Rep: Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523
Quote:
Just to add this, I use this, bound to a keyboard combination, to toggle the touchpad on and off:
Could this be assigned to a Fn special keys combination? Looks like Fn-F6 is not used on the T400.
 
Old 07-09-2013, 08:33 PM   #9
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,472

Original Poster
Rep: Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523
Quote:
Could this be assigned to a Fn special keys combination? Looks like Fn-F6 is not used on the T400.
Here is what I did:

I saved TobiSGD's script as /usr/local/bin/toggle-trackpad.

I created a desktop shortcut for the script.

I created /etc/acpi/events/toggle-trackpad:

Code:
event=ibm/hotkey HKEY 00000080 00001006
action=/usr/local/bin/toggle-trackpad
I restarted the acpid rc.d script.

Now Fn-F6 toggles the trackpad.

I wanted a udev rule to be automatic when an external mouse is connected, but I haven't found one that works. So for now the desktop and keyboard shortcuts suffice admirably.
 
Old 07-09-2013, 08:38 PM   #10
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,472

Original Poster
Rep: Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523
BTW, the other day I did the same thing to get the designated Fn-F4 special keys to toggle sleep/resume.

I created /etc/acpi/sleep.sh:

Code:
#!/bin/sh

echo mem > /sys/power/state
I created /etc/acpi/events/sleep-button:
Code:
event=ibm/hotkey HKEY 00000080 00001004
action=/etc/acpi/sleep.sh
I also copied /etc/acpi/events/sleep-button to /etc/acpi/events/lid.

Now the laptop suspends to ram with closing the lid and pressing Fn-F4.
 
Old 07-09-2013, 10:33 PM   #11
Z038
Member
 
Registered: Jan 2006
Distribution: Slackware
Posts: 789

Rep: Reputation: 157Reputation: 157
To those of you who have had a need or desire to turn off the touchpad, would you kindly explain why?

I'm just mildly curious about it. I've been using a T43 for going on 8 years now, and the touchpad has never gotten in my way or caused me any trouble that would make me want to disable it. In fact, even though I usually have a mouse attached, I frequently prefer to use the touchpad since it is often quicker than moving my hand away from the keyboard to handle the mouse.

Last edited by Z038; 07-09-2013 at 10:38 PM.
 
Old 07-09-2013, 10:37 PM   #12
Timothy Miller
Member
 
Registered: Feb 2003
Location: Arizona, USA
Distribution: Debian Jessie, OpenSuse 13.1, Chakra.
Posts: 665

Rep: Reputation: 95
For me, I hate the tapping because when I go from keyboard to touchpad, it always things I tapped. My laptops generally were FAR too sensitive with tapping, and quite frankly, the feature does nothing but irritate me since I have no desire to use it. Like the OP, my touchpads all have real buttons, and I vastly prefer to use them.
 
Old 07-09-2013, 10:41 PM   #13
TracyTiger
Member
 
Registered: Apr 2011
Location: California, USA
Distribution: Slackware
Posts: 247

Rep: Reputation: 55
Quote:
Originally Posted by Z038 View Post
To those of you who have had a need or desire to turn off the touchpad, would you kindly explain why?
You're typing along in a GUI based word processor or text editor when your thumb hits the touch pad and suddenly you're typing on a different part of the page than intended. Of course you don't notice it until three sentences later ... which are spread throughout your document.

Especially a problem when commuting by public transportation.
 
Old 07-09-2013, 10:54 PM   #14
Z038
Member
 
Registered: Jan 2006
Distribution: Slackware
Posts: 789

Rep: Reputation: 157Reputation: 157
Ah, ok. That makes sense, although I haven't experienced it myself. My thumbs don't stray below the space bar when I type, but I rarely use my laptop anywhere but on a desk where I can position myself properly for typing.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Thinkpad T400 Wireless Woodsman Slackware 18 10-28-2013 09:42 PM
Help with Thinkpad T400 Woodsman Slackware 24 07-05-2013 09:22 PM
Linux on Lenovo Thinkpad T400 wirawan0 Linux - Laptop and Netbook 9 04-17-2012 11:32 AM
Dual Monitor on Thinkpad T400? hewsonism Linux - Laptop and Netbook 3 05-12-2010 05:53 PM
fedora 10 64-bit on thinkpad t400 chickenlinux Linux - Software 1 06-29-2009 12:33 PM


All times are GMT -5. The time now is 08:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration