LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-23-2015, 09:09 AM   #1
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib" & Xfce.
Posts: 4,299
Blog Entries: 1

Rep: Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625
Things That Won't Run in -Current (21 April 2015).


Running the latest updates in a fresh install, along with a fresh install of the Multilib files.
So far, the following won't work and I have yet to find a fix,

Seamonkey and Firefox issue the same error, e.g.,

Quote:
bash-4.3$ seamonkey
XPCOMGlueLoad error for file /usr/lib64/seamonkey-2.33.1/libxul.so:
/usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /usr/lib64/seamonkey-2.33.1/libxul.so)
Couldn't load XPCOM.
bash-4.3$ firefox
XPCOMGlueLoad error for file /usr/lib64/firefox-37.0.2/libxul.so:
/usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /usr/lib64/firefox-37.0.2/libxul.so)
Couldn't load XPCOM.

VLC wont' run,

Quote:
bash-4.3$ vlc
VLC media player 2.2.1 Terry Pratchett (Weatherwax) (revision 2.2.1-0-ga425c42)
ALSA lib conf.c:3325snd_config_hooks_call) Cannot open shared library (null)
ALSA lib conf.c:3788snd_config_update_r) hooks failed, removing configuration
[00000000012d69a8] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Segmentation fault
Now to see what else is, or is not, running.

Last edited by cwizardone; 04-23-2015 at 09:17 AM.
 
Old 04-23-2015, 09:19 AM   #2
sbolokanov
Member
 
Registered: Feb 2013
Location: Бдинъ, Бѫлгариѧ
Distribution: GNU/Linux
Posts: 100

Rep: Reputation: 23
Recompile.
 
Old 04-23-2015, 09:38 AM   #3
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,313

Rep: Reputation: 5491Reputation: 5491Reputation: 5491Reputation: 5491Reputation: 5491Reputation: 5491Reputation: 5491Reputation: 5491Reputation: 5491Reputation: 5491Reputation: 5491
VLC 2.2.1 runs fine here on my slackware64-current (updated to the latest batch). I watched a movie with it, yesterday evening.
Are you certain that you have installed all the packages that have been added to Slackware-current in this batch?

Have not tested seamonkey or firefox on that desktop (don't use those).
 
Old 04-23-2015, 10:06 AM   #4
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib" & Xfce.
Posts: 4,299

Original Poster
Blog Entries: 1

Rep: Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625
Quote:
Originally Posted by Alien Bob View Post
...Are you certain that you have installed all the packages that have been added to Slackware-current in this batch?...
Yes. Reformatted the partition and did a complete install from the 2.5 gig iso you posted yesterday.
Then I downloaded all the fresh multilib files and installed those.


Now Libreoffice won't work,

Quote:
bash-4.3$ loffice
/usr/lib64/libreoffice/program/soffice.bin: error while loading shared libraries: libicuuc.so.51: cannot open shared object file: No such file or directory
Can't get KDE to read a CD (it has been reading for years), and WINE doesn't work.
 
Old 04-23-2015, 10:13 AM   #5
sbolokanov
Member
 
Registered: Feb 2013
Location: Бдинъ, Бѫлгариѧ
Distribution: GNU/Linux
Posts: 100

Rep: Reputation: 23
Quote:
Originally Posted by Alien Bob View Post
VLC 2.2.1 runs fine here on my slackware64-current (updated to the latest batch). I watched a movie with it, yesterday evening.
Are you certain that you have installed all the packages that have been added to Slackware-current in this batch?
Doesn't work on my end either.
Clean install of -current, last batch (iso made by myself with your mirror script).

Both "restricted" and normal VLC:
Code:
$vlc
VLC media player 2.2.1 Terry Pratchett (Weatherwax) (revision 2.2.1-0-ga425c42)
Segmentation fault
edit: By the way 64- no multilib

Last edited by sbolokanov; 04-23-2015 at 02:28 PM.
 
Old 04-23-2015, 10:13 AM   #6
phenixia2003
Member
 
Registered: May 2006
Location: France
Distribution: Slackware
Posts: 840

Rep: Reputation: 709Reputation: 709Reputation: 709Reputation: 709Reputation: 709Reputation: 709Reputation: 709
Hello,

Quote:
Originally Posted by cwizardone View Post
Running the latest updates in a fresh install, along with a fresh install of the Multilib files.
So far, the following won't work and I have yet to find a fix,

Seamonkey and Firefox issue the same error, e.g.,
Code:
bash-4.3$ seamonkey
XPCOMGlueLoad error for file /usr/lib64/seamonkey-2.33.1/libxul.so:
/usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /usr/lib64/seamonkey-2.33.1/libxul.so)
Couldn't load XPCOM.
bash-4.3$ firefox
XPCOMGlueLoad error for file /usr/lib64/firefox-37.0.2/libxul.so:
/usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /usr/lib64/firefox-37.0.2/libxul.so)
Couldn't load XPCOM.
What's the output of :

Code:
$ ls -l /usr/lib64/libstdc++*
and :

Code:
$ ls -l /var/log/packages/gcc*
--
SeB
 
Old 04-23-2015, 10:38 AM   #7
ryanpcmcquen
Member
 
Registered: Apr 2013
Distribution: DistroWanderer
Posts: 381

Rep: Reputation: Disabled
Quote:
Originally Posted by cwizardone View Post
Running the latest updates in a fresh install, along with a fresh install of the Multilib files.
So far, the following won't work and I have yet to find a fix,

Seamonkey and Firefox issue the same error, e.g.,

VLC wont' run,

Now to see what else is, or is not, running.

I am on a fresh install also, from Eric Hameleers ISO, and all three of these run for me (64-multilib).
 
Old 04-23-2015, 11:42 AM   #8
sbolokanov
Member
 
Registered: Feb 2013
Location: Бдинъ, Бѫлгариѧ
Distribution: GNU/Linux
Posts: 100

Rep: Reputation: 23
Did a recompile of vlc and it works (from alien).
So as expected recompile fixes the segfault.

edit: By the way 64- no multilib

Last edited by sbolokanov; 04-23-2015 at 11:45 AM.
 
Old 04-23-2015, 12:17 PM   #9
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib" & Xfce.
Posts: 4,299

Original Poster
Blog Entries: 1

Rep: Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625
Quote:
Originally Posted by phenixia2003 View Post
What's the output of :

Code:
$ ls -l /usr/lib64/libstdc++*
and :

Code:
$ ls -l /var/log/packages/gcc*
--
SeB

Thanks for asking. Here are the results:

Quote:
bash-4.3$ ls -l /usr/lib64/libstdc++*
lrwxrwxrwx 1 root root 18 Apr 21 12:50 /usr/lib64/libstdc++.so.5 -> libstdc++.so.5.0.7
-rwxr-xr-x 1 root root 4515618 Jun 5 2013 /usr/lib64/libstdc++.so.5.0.7
lrwxrwxrwx 1 root root 19 Apr 22 21:44 /usr/lib64/libstdc++.so.6 -> libstdc++.so.6.0.18
-rwxr-xr-x 1 root root 970768 Jun 9 2013 /usr/lib64/libstdc++.so.6.0.18
and

Quote:
bash-4.3$ ls -l /var/log/packages/gcc*
-rw-r--r-- 1 root root 32436 Apr 22 21:33 /var/log/packages/gcc-4.9.2_multilib-x86_64-1alien
-rw-r--r-- 1 root root 427 Apr 22 21:44 /var/log/packages/gcc-g++-4.8.3_multilib-x86_64-1alien
-rw-r--r-- 1 root root 2284 Apr 22 21:33 /var/log/packages/gcc-gfortran-4.9.2_multilib-x86_64-1alien
-rw-r--r-- 1 root root 251312 Apr 22 21:34 /var/log/packages/gcc-gnat-4.9.2_multilib-x86_64-1alien
-rw-r--r-- 1 root root 20025 Apr 22 21:34 /var/log/packages/gcc-go-4.9.2_multilib-x86_64-1alien
-rw-r--r-- 1 root root 236525 Apr 22 21:34 /var/log/packages/gcc-java-4.9.2_multilib-x86_64-1alien
-rw-r--r-- 1 root root 2232 Apr 22 21:34 /var/log/packages/gcc-objc-4.9.2_multilib-x86_64-1alien
-rw-r--r-- 1 root root 798 Apr 21 12:58 /var/log/packages/gccmakedep-1.0.3-noarch-1
Just saw the gcc-g++.
I'll re-install the correct version and try again.

Last edited by cwizardone; 04-23-2015 at 12:19 PM.
 
Old 04-23-2015, 12:36 PM   #10
number22
Member
 
Registered: Sep 2006
Location: Earth
Distribution: Slackware 14.1 Slackware64-current multilib
Posts: 278
Blog Entries: 7

Rep: Reputation: Disabled
I have had similar problem with firefox and seamonkey, but after upgrading all mutilibs(gcc glibc), it solved the problem, also I had to rebuild my nvidia legacy340 driver.

while the loffice still not working with missing libicuuc.so.51 file.

most vimeo html5 videos have no audio(very few exception) in firefox/seamonkey; but when I tried test html5 at http://www.quirksmode.org/html5/tests/video.html, all audio works; strange.

Last edited by number22; 04-23-2015 at 12:38 PM.
 
Old 04-23-2015, 12:57 PM   #11
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib" & Xfce.
Posts: 4,299

Original Poster
Blog Entries: 1

Rep: Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625Reputation: 1625
Quote:
Originally Posted by cwizardone View Post
...Just saw the gcc-g++.
I'll re-install the correct version and try again.
OK. Still scratching my head on that one. Checked my multilib repository and none of the old versions are there, but somehow I managed to install all the new ones except gcc-g++.

Now that it is installed Seamonkey does work, but nothing has changed with VLC, WINE or Libreoffice, that is, they still won't run.

Last edited by cwizardone; 04-23-2015 at 12:58 PM.
 
Old 04-23-2015, 01:17 PM   #12
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 7,313

Rep: Reputation: 5491Reputation: 5491Reputation: 5491Reputation: 5491Reputation: 5491Reputation: 5491Reputation: 5491Reputation: 5491Reputation: 5491Reputation: 5491Reputation: 5491
Libreoffice will get a new package specifically targeting slackware-current because it nbeeds a recompilation thanks to the icu4c upgrade. There are unannounced version 4.4.3 sources at libreoffice.org that I an using.
I am compiling 64-bit, then the 32-bit needs to be done and then it will be uploaded.
Virtual machine based package building... not as fast as an octacore with 16 GB of RAM of course.
 
Old 04-23-2015, 01:22 PM   #13
1337_powerslacker
Member
 
Registered: Nov 2009
Distribution: Slackware64-current
Posts: 665
Blog Entries: 1

Rep: Reputation: 382Reputation: 382Reputation: 382Reputation: 382
Quote:
Originally Posted by cwizardone View Post
OK. Still scratching my head on that one. Checked my multilib repository and none of the old versions are there, but somehow I managed to install all the new ones except gcc-g++.

Now that it is installed Seamonkey does work, but nothing has changed with VLC, WINE or Libreoffice, that is, they still won't run.
Have you tried deleting the user settings for these programs?
Code:
Libreoffice - ~/.config/libreoffice
VLC - ~/.config/vlc
Seamonkey - ~/.mozilla/seamonkey
Firefox - ~/.mozilla/firefox
That's the only thing I can think of if you've done a fresh install and these programs are giving you fits all of a sudden, because none of these programs are giving any of the rest of us fits.

Hope this helps.
 
Old 04-23-2015, 02:24 PM   #14
dr.s
Member
 
Registered: Feb 2010
Distribution: Slackware64-14.2
Posts: 214

Rep: Reputation: 57
Quote:
Originally Posted by sbolokanov View Post
Doesn't work on my end either.
Clean install of -current, last batch (iso made by myself with your mirror script).

Both "restricted" and normal VLC:
Code:
$vlc
VLC media player 2.2.1 Terry Pratchett (Weatherwax) (revision 2.2.1-0-ga425c42)
Segmentation fault
Same here, clean install of current, VLC Seg fault.
 
Old 04-23-2015, 04:01 PM   #15
Mark Pettit
Member
 
Registered: Dec 2008
Location: Cape Town, South Africa
Distribution: Slackware 14.2 64 Multi-Lib
Posts: 522

Rep: Reputation: 210Reputation: 210Reputation: 210
Quote:
Originally Posted by Alien Bob View Post
Virtual machine based package building... not as fast as an octacore with 16 GB of RAM of course.
Dutch humour :-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Three Things That Won't Get You An IT Job And Two Things That Will sundialsvcs General 20 08-13-2014 03:55 PM
Recent Changes in Current (or things that go bump in the night). cwizardone Slackware 13 03-02-2013 09:30 AM
VirtualBox won't run after upgrade to slackware64 current Ook Slackware 9 06-18-2011 08:13 AM
[SOLVED] kernel upgrade -current messed up things portia Slackware 28 01-26-2010 06:48 PM
Things that run in framebuffer!!! Optyx Linux - General 1 08-01-2007 09:26 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration