LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-28-2005, 11:24 AM   #1
IamI
Member
 
Registered: Mar 2004
Location: Dreary, Pennsylvania USA
Distribution: Slackware 10.2
Posts: 77

Rep: Reputation: 15
The Dialup Saga Continues


I've been having absurd amounts of difficulty trying to get dialup internet in Slackware 10. For some background, please refer to this thread:

http://www.linuxquestions.org/questi...hreadid=317013

The sysnopis is: I attempted to get Slackware to establish a sucessful dialup connection with my Worldnet account. First I tried a PCI winmodem with drivers supplied the mfg. It worked once, and after I rebooted, I could never get it to work again. I reinstalled Slack, reinstalled the drivers, and it worked once, and never again.

So I purchased a serial hardware modem (external), the Best Data. It worked once, then after a reboot never worked again. I reinstalled Slack (blanked the partitions and everything), and it still didn't work with a completely fresh install.

So I returned that modem, and bought a Creative Modem Blaster, plugged it in, and away it went. The next day, it began to behave in pretty much the same manner as all the other modems, which is basically where I am at this point, hardware wise.

During this process (on a good tip suggested by somebody who responded to my earlier thread), I called Worldnet tech support to see if they could pull up details concerning my login attempts. They could not, so I signed up with a local ISP who could.

The crux of that feedback is that, as far as my new ISP can tell, my dialup attempts are successful. The problem appears to be some sort of routing issue at my end.

The trouble is: I'm not using a firewall and I have not played with iptables in any manner.

root@darkstar:/home/saruman# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
root@darkstar:/home/saruman#


So I guess my question is: Are there any other mechanisms in Slackware other than iptables that deal with routing? Or perhaps that's not even what I should be focusing on: This business has been a trifle bewildering. I did not expect it to go on so long; I should have been taking notes.

Anyway, I still need help.



P.S: I have had no problems whatsoever with any of the various modems and ISPs in XP.


P.P.S: For what it's worth, there is some strange garbage in addition to the normal stuff that comes back in the kppp log window after I connect:


ATZ
OK
ATM1L1
OK
ATDT4125930110 `&b+IBC:1
CONNECT 57600
c


In addition, after about 20 seconds when the link invariably fails, the following error is returned:

Apr 28 11:32:32 darkstar pppd[1814]: Cannot determine ethernet address for proxy ARP
 
Old 04-28-2005, 11:39 AM   #2
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Just a simple question, when you said you install Slack, the connection works. The next day is gone, do you make any changes? I can't believe one day works and the other don't without changing anything...
 
Old 04-28-2005, 12:15 PM   #3
tobyl
Member
 
Registered: Apr 2003
Location: uk
Distribution: slackware current
Posts: 767

Rep: Reputation: 62
I have not used dial-up for a while, but I read my old /etc/ppp/options file in case I could see anything that helped me.
Only thing I could see was that I had commented out the line proxyarp

# Add an entry to this system's ARP [Address Resolution Protocol]
# table with the IP address of the peer and the Ethernet address of this
# system.
#proxyarp

I don't know if this is an option in your case?

Secondly, could it be a DNS problem. Most isp's now have dynamic DNS server allocation, you may want to check if you have this set up properly.
 
Old 04-28-2005, 12:26 PM   #4
Boow
Member
 
Registered: Feb 2004
Distribution: Slackware 10.2
Posts: 669

Rep: Reputation: 32
check your /etc/resovle.conf if your isps dns is not in there

cat /etc/ppp/resolve.conf >> /etc/resolve.conf

could be that simple
 
Old 04-28-2005, 01:42 PM   #5
WilliamS
Member
 
Registered: Nov 2003
Location: 46N 76W
Distribution: Slackware 14.1
Posts: 380

Rep: Reputation: 31
I don't think you have a hardware problem.

Here's how I do it: Call the ISP and get the nameserver number.
In a shell do: pppsetup as root, it will ask for the above number, and your ISP's telephone number and your login name and password.
In shell type ppp-go.

If that doesn't work, please tell us what error messages you get.

There is one thing about hardware - might be wise to be sure of what port your modem needs to be on.
 
Old 04-28-2005, 03:02 PM   #6
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 -current
Posts: 2,300

Rep: Reputation: 90
Yep, get the correct dns server ip and disable that proxy.
 
Old 04-29-2005, 12:04 AM   #7
IamI
Member
 
Registered: Mar 2004
Location: Dreary, Pennsylvania USA
Distribution: Slackware 10.2
Posts: 77

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by WilliamS
Here's how I do it: Call the ISP and get the nameserver number. In a shell do: pppsetup as root, it will ask for the above number, and your ISP's telephone number and your login name and password.
In shell type ppp-go.

If that doesn't work, please tell us what error messages you get.

No errors reported from the above just:


Serial connection established
Using interface ppp0
Connect: ppp0 <--> /dev/modem
PAP authentication succeded.
local ip xxx.xxx.xx.xx
remote ip xxx.xxx.xx.xx


The links are always useless, of course. Nothing gets through. PPP goes on and off as if nothing is wrong. Perhaps, from its perspective, there isn't.




Quote:
Originally posted by Boow
check your /etc/resovle.conf if your isps dns is not in there

cat /etc/ppp/resolve.conf >> /etc/resolve.conf

could be that simple

Tried it. No joy.



Quote:
Originally posted by masonm
disable that proxy.
What proxy?
 
Old 04-29-2005, 12:10 AM   #8
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
After connecting, can you get to some site using the IP number, like: http://216.239.37.99 (google) ?
 
Old 04-29-2005, 12:38 AM   #9
IamI
Member
 
Registered: Mar 2004
Location: Dreary, Pennsylvania USA
Distribution: Slackware 10.2
Posts: 77

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by gbonvehi
After connecting, can you get to some site using the IP number, like: http://216.239.37.99 (google) ?



No, but interestingly enough, Konqueror's status bar reports that "216.239.37.99 contacted. Waiting for reply..."

The reply never comes, however.
 
Old 04-29-2005, 10:21 AM   #10
IamI
Member
 
Registered: Mar 2004
Location: Dreary, Pennsylvania USA
Distribution: Slackware 10.2
Posts: 77

Original Poster
Rep: Reputation: 15
I just blanked my ext3 partitions, and installed my old copy of Mandrake 9.2 to see if I could pick out the network settings and apply them to Slack in some manner. I never had a problem dialing out with Mandrake.

A brand new fresh install of Mandrake is giving me exactly the same grief as Slackware is. Exactly.

What has changed about ISPs lately that none of my versions of Linux will deal with them? Am I going insane? What the fuck is wrong?

I am loathe to admit it, but this could be the end of Linux for me. I donít know how much more of my life I am going to waste trying to make Linux do what I can do in XP effortlessly.
 
Old 04-29-2005, 11:48 PM   #11
IamI
Member
 
Registered: Mar 2004
Location: Dreary, Pennsylvania USA
Distribution: Slackware 10.2
Posts: 77

Original Poster
Rep: Reputation: 15
Well, folks, I hope you have better luck in your Linux journey than I did. I'm throwing in the towel while I still have some shredded remnants of sanity. I'm going to burn all my linux cds and try very hard to forget about all the time I lost.

Fare thee well.
 
Old 04-30-2005, 07:13 AM   #12
WilliamS
Member
 
Registered: Nov 2003
Location: 46N 76W
Distribution: Slackware 14.1
Posts: 380

Rep: Reputation: 31
Ok, it's not software, and it's not hardware.

That leaves the ISP.
 
Old 04-30-2005, 11:28 AM   #13
CRCampbell
LQ Newbie
 
Registered: Apr 2005
Location: California
Distribution: Slackware 10.1, because Ubuntu got boring
Posts: 9

Rep: Reputation: 0
Quote:
Originally posted by IamI
Well, folks, I hope you have better luck in your Linux journey than I did. I'm throwing in the towel while I still have some shredded remnants of sanity. I'm going to burn all my linux cds and try very hard to forget about all the time I lost.

Fare thee well.
Bummer: I was going to ask you if you tried editing the last three lines of your /etc/ppp/pppoptions file, replacing them with this:


"" "ATZ"
OK "ATDT<phone number>"
CONNECT '\d\c'
 
Old 05-01-2005, 10:46 PM   #14
IamI
Member
 
Registered: Mar 2004
Location: Dreary, Pennsylvania USA
Distribution: Slackware 10.2
Posts: 77

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by CRCampbell
Bummer: I was going to ask you if you tried editing the last three lines of your /etc/ppp/pppoptions file, replacing them with this:


"" "ATZ"
OK "ATDT<phone number>"
CONNECT '\d\c'


*sigh* I almost stayed away. What is the "\d\c" intended to accomplish?
 
Old 05-01-2005, 11:48 PM   #15
gotissues68
LQ Newbie
 
Registered: Jan 2005
Posts: 15

Rep: Reputation: 0
Hey if its successfully establishing a login but you're unable to browse then do the following:

login: duh ;-)
from a terminal type: "route" no quotes... these are the routes that the kernel is managing. Whats happening is you're getting assigned an IP address but for some reason the gateway or route as it were is not working properly is what it sounds like. Normally the gateway will be in the same /24 as the IP you're dynamically assigned. See if you can ping it, or if its not in the kernel routing table, see if you can ping xxx.xxx.xxx.1 or xxx.xxx.xxx.254 where the xxx's are of course replaced with the first 3 octets of the IP you're assigned. If we can narrow this down to a routing issue then you're golden =) don't give up!!!! Its time consuming and you might feel like you're wasting time but don't give up yet!

[edit] Here's a look at what the route table should look like.

-(drew@aristotle:<tty1>)->$ route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
67.171.248.0 * 255.255.248.0 U 0 0 0 eth0
loopback * 255.0.0.0 U 0 0 0 lo
default c-67-171-248-1. 0.0.0.0 UG 0 0 0 eth0


you're looking for a default route that should show it using Iface ppp0 since you're on dialup.

Last edited by gotissues68; 05-01-2005 at 11:52 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
The 2.4 -> 2.6 Saga Continues ... sundialsvcs Linux From Scratch 2 08-11-2005 01:25 PM
Another Radeon saga... Berto Linux - Software 1 09-01-2004 09:05 PM
linux dialup faster and more stable than windows dialup -why? whitshade Linux - Networking 4 06-19-2004 03:52 PM
x- question....the saga continues Robert0380 Linux - General 3 05-23-2003 09:18 AM
Wvdial Saga! el_felipe Linux - General 1 01-28-2002 01:37 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration