LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-22-2010, 06:55 PM   #1
Josh000
Member
 
Registered: Aug 2009
Distribution: Slackware 13 64bit
Posts: 534

Rep: Reputation: 35
Terminals behaving oddly all except xterm


I was looking for a terminal program with support for transparency. I understand urxvt is the only non DE specific terminal program that supports real transparency, although I have been playing with mrxvt and aterm as well since I could not get urxvt working.

I have not had any luck with urxvt, mrxvt or aterm. Only xterm works properly.

The main problems I am having is that I cannot use vi in any of these programs. None seem to refresh or output properly. curses based programs also give me trouble.

Not to mention I have not been able to get transparency working with urxvt at all. I can force it transparent with fluxbox but that is not what I want.

I don't just want a solution, I want to udnerstand why it doesnt work by default.

Since urxvt, mrxvt and aterm all behave the same way I guess they may be emulating a different terminal type to xterm by default, but I have been unable to see what this is.

Thankyou in advance for any suggestions

Last edited by Josh000; 04-22-2010 at 07:00 PM.
 
Old 04-22-2010, 07:18 PM   #2
rmjohnso
Member
 
Registered: Mar 2006
Location: Wisconsin
Distribution: Slackware64-Current
Posts: 294

Rep: Reputation: 43
Do you have anything set in an .Xresources or .Xdefaults file?
 
Old 04-22-2010, 07:20 PM   #3
Josh000
Member
 
Registered: Aug 2009
Distribution: Slackware 13 64bit
Posts: 534

Original Poster
Rep: Reputation: 35
No, I don't even have those files in my home directory.
 
Old 04-22-2010, 09:23 PM   #4
rmjohnso
Member
 
Registered: Mar 2006
Location: Wisconsin
Distribution: Slackware64-Current
Posts: 294

Rep: Reputation: 43
Try creating a .Xresources file when using something like aterm. Here is a copy of mine. See if this helps.

Code:
Aterm*background:	black
Aterm*foreground:	#FF8F4C
!Aterm*foreground:	limegreen
Aterm*loginShell:	true
Aterm*saveLines:	100000
Aterm*scrollBar:	true
Aterm*cursorColor:	#FF8F4C
!Aterm*cursorColor:	green
Aterm*pointerColor:	magenta
Aterm*transparent:	true
Aterm*shading:		50
Aterm*tinting:		blue
Aterm*fading:		50
Aterm*scrollBar_right:	true
Aterm*transpscrollbar:	true
Aterm*termName:		xterm

Xft.antialias: 1
Xft.dpi: 96
Xft.hinting: 1
Xft.hintstyle: hintfull
Xft.lcdfilter: lcddefault
Xft.rgba: rgb
 
Old 04-23-2010, 01:36 PM   #5
Josh000
Member
 
Registered: Aug 2009
Distribution: Slackware 13 64bit
Posts: 534

Original Poster
Rep: Reputation: 35
OK, this works for being able to use vi in aterm.

After some experimenting, the only line I actually need is : Aterm*termName: xterm

Which I assume makes aterm emulate the same terminal type xterm does. Is there a way to find out what this is, and set it as the default instead of setting aterm to imitate xterm?

Setting a similar line for urxvt and mrxvt does not work, although setting TERM=xterm in either of them does work. I would rather figure out why this happens than just use the easy solution and have them imitate xterm.

Last edited by Josh000; 04-23-2010 at 01:51 PM.
 
Old 04-23-2010, 02:03 PM   #6
Josh000
Member
 
Registered: Aug 2009
Distribution: Slackware 13 64bit
Posts: 534

Original Poster
Rep: Reputation: 35
This thread here is related to my problem.

Basically none of the terminals are using terminfo likes they should, but for some reason the deprecated termcap. Interesting.
 
Old 04-24-2010, 12:14 PM   #7
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,897

Rep: Reputation: 577Reputation: 577Reputation: 577Reputation: 577Reputation: 577Reputation: 577
Rebuild the alternate terminals without termcap present on the system. Some amy require a tiny one-line patch to get them to link to terminfo instead of termcap. Most can also link to ncurses instead of terminfo.
 
Old 04-24-2010, 12:21 PM   #8
Josh000
Member
 
Registered: Aug 2009
Distribution: Slackware 13 64bit
Posts: 534

Original Poster
Rep: Reputation: 35
Probably the best solution...although I think it is odd the slackbuilds don't already take this into account.
 
Old 04-24-2010, 03:33 PM   #9
Josh000
Member
 
Registered: Aug 2009
Distribution: Slackware 13 64bit
Posts: 534

Original Poster
Rep: Reputation: 35
OK, I have it all working now.

infocmp -C rxvt-unicode >> /etc/termcap

mrxvt and aterm both have entiries in terminfo, but doing a similar command to above for aterm or mrxvt does not work as they have TERM set to rxvt. Just doing the command for rxvt will work for both of them.

Does anyone know why slackware still uses termcap?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Xterm or Konsole to 1:open, 2:position, 3:initialize multiple terminals in an order linux_newb_help_wanted Linux - Newbie 8 02-03-2010 12:24 AM
USB problem on linux terminals vie NComputing X300 terminals Aleks` Linux - General 1 12-04-2008 05:39 PM
Quantum DLT-V4 Tape Drive Behaving Oddly davidstvz *BSD 0 09-18-2008 04:54 PM
Amarok behaving oddly little_penguin Linux - Software 2 07-10-2005 11:58 AM
Bash Prompts with xterm-style terminals somnium Linux - General 1 09-11-2003 08:43 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration