LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-21-2009, 01:31 PM   #1
Bller
Member
 
Registered: Aug 2009
Location: Bucharest, Romania
Distribution: Slackware 14.1
Posts: 228

Rep: Reputation: 17
Terminal problem


Hello guys, this is my first post here so i should be farely clear and straight. When i try to acces the terminal, i click the terminal shortcut, and everything freezes and i have to restart the PC.
2. I can`t find 1280x1024 resolution in display settings, and i don`t know how to install the driver for my graphic card, it`s a .run file downloaded from the Ati Radeon download page. 3. My scrol on the mouse won`t work. It`s not a usb mouse.
 
Old 08-21-2009, 01:42 PM   #2
forrestt
Senior Member
 
Registered: Mar 2004
Location: Cary, NC, USA
Distribution: Fedora, Kubuntu, RedHat, CentOS, SuSe
Posts: 1,288

Rep: Reputation: 99
First of all, welcome to LQ!

What distro are you using? The answer to your questions will differ based on the answer to that.

Let us know,

Forrest
 
Old 08-21-2009, 01:47 PM   #3
Bller
Member
 
Registered: Aug 2009
Location: Bucharest, Romania
Distribution: Slackware 14.1
Posts: 228

Original Poster
Rep: Reputation: 17
Well as i posted in slackware thread, it is obvious that i have slackware . I just installed today.
 
Old 08-21-2009, 02:05 PM   #4
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),OpenSuse 13.2 (Laptop & Desktop),, OpenSuse 13.2 on the wifes lappy
Posts: 781

Rep: Reputation: 98
Is this an install of 12.2 or current?

Either way you will have real trouble with getting the ATI drivers to work correctly, and should instead consider using the Xorg radeon driver. Check your /etc/X11/xorg.conf file to see what driver you are currently using. It's generally well commented so is pretty easy to work out what each section does.

For your mouse, rerun pkgtool (as root) and make sure the correct mouse type is configured. Personally I find the imps protocol works for me, but you need to choose whatever suits your device.
 
Old 08-21-2009, 02:10 PM   #5
forrestt
Senior Member
 
Registered: Mar 2004
Location: Cary, NC, USA
Distribution: Fedora, Kubuntu, RedHat, CentOS, SuSe
Posts: 1,288

Rep: Reputation: 99
Two comments come to mind:

1) You'd be surprised.
2) What, now you expect me to read :-P.

As far as the terminal not working via the icon, are you able to open a terminal any other way? I'm not a Slacker, but installing the video driver should be as simple as making it executable (chmod +x filename.run) and then running it (./filename.run). Again, I'm not a Slacker, but the mouse wheel should work if you change the mouse "Option Protocol" line of your xorg.conf to look like:
Option "Protocol" "IMPS/2"

I'm sure you will soon get a real Slacker to verify/correct these statements.

HTH

Forrest

Last edited by forrestt; 08-21-2009 at 02:12 PM.
 
Old 08-21-2009, 02:10 PM   #6
Bller
Member
 
Registered: Aug 2009
Location: Bucharest, Romania
Distribution: Slackware 14.1
Posts: 228

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by vdemuth View Post
Is this an install of 12.2 or current?

Either way you will have real trouble with getting the ATI drivers to work correctly, and should instead consider using the Xorg radeon driver. Check your /etc/X11/xorg.conf file to see what driver you are currently using. It's generally well commented so is pretty easy to work out what each section does.

For your mouse, rerun pkgtool (as root) and make sure the correct mouse type is configured. Personally I find the imps protocol works for me, but you need to choose whatever suits your device.
The first part i will do right now, but the problem will be with the pkgtool, i would need to reset my PC so i can have a terminal working, `cose from the KDE desktop, as i sed, when i try to access the terminal shortcut everything just freezes and i need to restart.
Oh and yes i installed 12.2 version from a dvd boot i burned and checked myself !

//Edit: How do i gain acces to edit the xorg.conf file? i do believe i did give my account root acces :-s when i installed.

Last edited by Bller; 08-21-2009 at 02:25 PM.
 
Old 08-21-2009, 02:26 PM   #7
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,276

Rep: Reputation: 229Reputation: 229Reputation: 229
I use successfully on my ThinkPad T60 ATI proprietary driver (fglrx).

The newest version is: ati-driver-installer-9-3-x86.x86_64.run. I tried it yesterday but it displayed some error at the end of installation so I came back to older version: ati-driver-installer-8-12-x86.x86_64.run.

To install driver you have to download it, and as root run the command:

Code:
chmod 755 ati-driver-installer-9-3-x86.x86_64.run
and then the command:

Code:
./ati-driver-installer-9-3-x86.x86_64.run
Next still as root open your /etc/X11/xorg.conf using some text editor, find the section similar to:

Code:
Section "Device"
    Identifier  "VESA Framebuffer"
    Driver      "vesa"
    #VideoRam    4096
    # Insert Clocks lines here if appropriate
EndSection
or:

Code:
Section "Device"
    #VideoRam    65536
    # Insert Clocks lines here if appropriate
        Identifier  "** ATI Radeon (generic)               [radeon]"
        Driver      "radeon"
EndSection
And replace "vesa" or "radeon" with "fglrx".

Finally restart X Window.

***

By the way: I just discovered that during unsuccessful attempt to install new driver it modified my xorg.conf. Now I see in it some sections as:

Code:
Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-0"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
EndSection
and:

Code:
Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID       "PCI:1:0:0"
EndSection
I will inspect it further.
 
Old 08-21-2009, 02:29 PM   #8
forrestt
Senior Member
 
Registered: Mar 2004
Location: Cary, NC, USA
Distribution: Fedora, Kubuntu, RedHat, CentOS, SuSe
Posts: 1,288

Rep: Reputation: 99
You should be able to get a VT by CTL-ALT-F1 through CTL-ALT-F7. You can get back to X via CTL-ALT-F8 (although lately, F8 has been replaced with F1. not sure if this is true in Slack 12).

Forrest
 
Old 08-21-2009, 02:39 PM   #9
Bller
Member
 
Registered: Aug 2009
Location: Bucharest, Romania
Distribution: Slackware 14.1
Posts: 228

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by w1k0 View Post
I use successfully on my ThinkPad T60 ATI proprietary driver (fglrx).

The newest version is: ati-driver-installer-9-3-x86.x86_64.run. I tried it yesterday but it displayed some error at the end of installation so I came back to older version: ati-driver-installer-8-12-x86.x86_64.run.

To install driver you have to download it, and as root run the command:

Code:
chmod 755 ati-driver-installer-9-3-x86.x86_64.run
and then the command:

Code:
./ati-driver-installer-9-3-x86.x86_64.run
Next still as root open your /etc/X11/xorg.conf using some text editor, find the section similar to:

Code:
Section "Device"
    Identifier  "VESA Framebuffer"
    Driver      "vesa"
    #VideoRam    4096
    # Insert Clocks lines here if appropriate
EndSection
or:

Code:
Section "Device"
    #VideoRam    65536
    # Insert Clocks lines here if appropriate
        Identifier  "** ATI Radeon (generic)               [radeon]"
        Driver      "radeon"
EndSection
And replace "vesa" or "radeon" with "fglrx".

Finally restart X Window.

***

By the way: I just discovered that during unsuccessful attempt to install new driver it modified my xorg.conf. Now I see in it some sections as:

Code:
Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-0"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
EndSection
and:

Code:
Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID       "PCI:1:0:0"
EndSection
I will inspect it further.
Thanks for the tip m8, i would like to stick to the simple xorg.conf editting and trying to add 1280x1024 resollution to it and se if it would work, as for the terminal i still don`t know that to do. Oh and another thing. when i first stepped in slack, my system ran at 1024x768, i tryied changing that into like 800x600 and the screen just goes berzerk, lines everywhere colors and things, and again it freezez my PC and have to restart.
 
Old 08-21-2009, 02:40 PM   #10
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,276

Rep: Reputation: 229Reputation: 229Reputation: 229
Quote:
Originally Posted by forrestt View Post
You should be able to get a VT by CTL-ALT-F1 through CTL-ALT-F7. You can get back to X via CTL-ALT-F8 (although lately, F8 has been replaced with F1. not sure if this is true in Slack 12).
Ctrl-Alt-F1 to Ctrl-Alt-F6 for six text consoles. Ctrl-Alt-F7 back to X Window started with startx command (primary). Ctrl-Alt-F8 back to X Window started with startx -- :1 command (secondary).
 
Old 08-21-2009, 02:55 PM   #11
Bller
Member
 
Registered: Aug 2009
Location: Bucharest, Romania
Distribution: Slackware 14.1
Posts: 228

Original Poster
Rep: Reputation: 17
I entered the console with ctrl alt f1 and did a restart from there, now every file/app/ every title in the sistem is like just a few points. there like so tiny you can`t read them

//Edit: a restart resolved the problem

Last edited by Bller; 08-21-2009 at 02:59 PM.
 
Old 08-21-2009, 03:02 PM   #12
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,276

Rep: Reputation: 229Reputation: 229Reputation: 229
To run root's commands and to edit root's files go to the second console (Ctrl-Alt-F2) and login as root. Next run Midnight Commander with mc command. Using Midnight Commander you can explore the system, run the commands, edit the files and much more.

***

If you run X Window with startx command from -- say -- first console you can't use it to login as root. It's used by X Window. So use the consoles from second to sixth.

Last edited by w1k0; 08-21-2009 at 03:06 PM.
 
Old 08-21-2009, 03:14 PM   #13
Bller
Member
 
Registered: Aug 2009
Location: Bucharest, Romania
Distribution: Slackware 14.1
Posts: 228

Original Poster
Rep: Reputation: 17
I logged in with the root account, and started X, now i`m on my root account, eddited the xorg.conf file like this for my graphic card:
Code:
# **********************************************************************
# Graphics device section
# **********************************************************************

# Any number of graphics device sections may be present

Section "Device"
    Identifier  "VESA Framebuffer"
    Driver      "vesa"
    #VideoRam    4096
    # Insert Clocks lines here if appropriate
EndSection

# **********************************************************************
# Screen sections
# **********************************************************************

# Any number of screen sections may be present.  Each describes
# the configuration of a single screen.  A single specific screen section
# may be specified from the X server command line with the "-screen"
# option.
Section "Screen"
    Identifier  "Screen 1"
    Device      "VESA Framebuffer"
    Monitor     "My Monitor"

# If your card can handle it, a higher default color depth (like 24 or 32)
# is highly recommended.

#   DefaultDepth 8
#   DefaultDepth 16
   DefaultDepth 24
#   DefaultDepth 32

# "1024x768" is also a conservative usable default resolution.  If you
# have a better monitor, feel free to try resolutions such as
# "1152x864", "1280x1024", "1600x1200", and "1800x1400" (or whatever your
# card/monitor can produce)

    Subsection "Display"
        Depth       8
        Modes "1280x1024" "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes "1280x1024" "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes "1280x1024"  "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth       32
        Modes "1280x1024" "1024x768" "800x600" "640x480"
    EndSubsection

EndSection
And still my new resolution won`t apear on display settings
 
Old 08-21-2009, 03:29 PM   #14
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,276

Rep: Reputation: 229Reputation: 229Reputation: 229
Assuming you use Radeon replace:

Code:
    Driver      "vesa"
with:

Code:
    Driver      "radeon"
Then restart X Window to assure everything went well.

If X Window will run with the new resolution the problem is solved. If not it means it's unable to use that resolution with 24 bits color depth. In such case you have to remove these high resolutions or decrease color depth to 16 bits (very poor).

Last edited by w1k0; 08-21-2009 at 03:33 PM.
 
Old 08-21-2009, 03:32 PM   #15
Bller
Member
 
Registered: Aug 2009
Location: Bucharest, Romania
Distribution: Slackware 14.1
Posts: 228

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by w1k0 View Post
Assuming you use Radeon replace:

Code:
    Driver      "vesa"
with:

Code:
    Driver      "radeon"
Then restart X Window to assure everything went well.

Next add "1280x1024" at the beginning of each Modes ... line.

Then restart X Window.

If X Window will run with the new resolution the problem is solved. If not it means it's unable to use that resolution with 24 bits color depth. In such case you have to use mc in console mode and remove these high resolutions or decrease color depth to 16 bits (very poor).
will try it right now, and i finally found a working console terminal working in X
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
terminal problem ambavaram Linux - Software 3 07-09-2008 03:45 AM
terminal problem jaspreet85 Linux - General 3 07-20-2005 10:15 AM
Terminal problem rupesh_pulikool Linux - Security 2 10-19-2004 05:25 AM
Terminal problem David@330 Linux - Newbie 3 10-12-2004 02:40 AM
qt: terminal problem powadha Slackware 1 12-23-2003 05:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 09:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration