-   Slackware (
-   -   Tellico in Xfce4: KDEInit could not lauch '/usr/lib64/firefox-18.0/firefox' (

tronayne 03-11-2013 11:23 AM

Tellico in Xfce4: KDEInit could not lauch '/usr/lib64/firefox-18.0/firefox'
Tellico is a KDE collections manager application that has been running happily in Xfce for, oh, a couple years now (KDE is installed, I just don't use it).

One feature is that a book record contains a hyperlink to which is currently failing with the subject message.

I have searched every KDE and Xfce configuration file I can find trying to locate what is causing this (Firefox 18.0 is long gone, updated to Firefox 19.0.2) and have come up blank. I did rebuild Tellico (it's a SlackBuild) and "upgradepkg --reinstall") just to be on the safe side, have changed the default browser in Xfce System settings, blown away cache directories, blown away all the KDE files in /tmp, done everything I can think of.

No joy here in Mudville.

Any ideas?

foodown 03-11-2013 11:46 AM

Have you checked in '~/.kde/share/config/tellicorc'?

tronayne 03-11-2013 12:30 PM

Sure did -- not a blessed thing in there about browser, link, firefox, Amazon, IMBD or anything that look remotely like them. Looked through every tellico directory and file in ~/.kde while I was at it.

foodown 03-11-2013 04:08 PM

Well that's lame ... That was all I had. :(

Have you tried creating a new user and seeing how it works for them?

tronayne 03-13-2013 08:00 AM


Originally Posted by foodown (Post 4909412)
Well that's lame ... That was all I had. :(

Naw, it wasn't, it was good thinking and I do appreciate it.

The developer (Robby Stehpenson) suggested a couple of things that I certainly didn't know (I pay virtually no attention to KDE any more):

This comes up occasionally from a non-KDE workspace. Tellico uses the
KDE settings, and you check if somehow the default browser configuration
for KDE got changed somehow. Use this command:
kreadconfig --group General --key BrowserApplication

If you want to clear it:
kwriteconfig --group General --key BrowserApplication ''

Or set it:
kwriteconfig --group General --key BrowserApplication '/usr/bin/firefox'

See if that helps...
Interesting to know, but, alas, nope, did not help.

So, I figured, let's go back to infancy, backed up ~/.kde (where the application stores data sources keys) and removed every dot-file in my home directory (except .VirtualBox/ .cvspass .exrc.kshrc .mozilla/ .mplayer/ .profile .screenrc and .thunderbird -- didn't want to go back to conception, just infancy). Blew away all the files and directories owned by "me" in /tmp, blew away the files in /var/tmp/kdecache*, dumped everything I could find.

Then, logged back in as me, startx, tried it, viola, connects to Amazon (with Konqueror, which I really don't like using but the thing connected). Re-do my desktop the way I like it and get on with life.

How did the problem occur? I dunno. Through the magic of electronics or something like that. I screwed around the "right way" for too long and said to hell with it, nuke the blasted thing.

All is well that ends.

All times are GMT -5. The time now is 04:55 AM.