LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-02-2018, 03:20 PM   #16
upnort
Member
 
Registered: Oct 2014
Distribution: Slackware, Proxmox, Debian, CentOS, Ubuntu MATE
Posts: 766

Original Poster
Rep: Reputation: Disabled

I have been unable to discover a root cause. No long-term data but the system self-awakens about 80% of the time.

The system never self-awakens a second time. After the first self-awaken the system always powers down the second time.

I removed all USB devices. No change in behavior. I changed to run level 1 before powering down. The system self-awakened less often but nonetheless occasionally did. I powered off all LAN devices including the router. No change in behavior. I disconnected the Ethernet cable before powering down. The system self-awakened much less than previously but nonetheless occasionally did.

Removing the cable indicates the problem is not an actual WOL magic packet being generated somewhere.

I tried rmmod r8169 before powering down. No change in behavior.

The only solution is disable WOL in the BIOS.

I think there is a bug in the r8169 NIC module, the BIOS, or both. I found many bug reports about the r8169 but not related to self-awakening.

I have not yet tried any Live ISOs with different kernels and have not tried booting with the huge kernel.

Are there any ethtool tricks I might try at power down?
 
Old 09-02-2018, 06:47 PM   #17
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 727

Rep: Reputation: 407Reputation: 407Reputation: 407Reputation: 407Reputation: 407
Quote:
Originally Posted by upnort View Post
The only solution is disable WOL in the BIOS.
Are there any ethtool tricks I might try at power down?
If you don't need WoL and you don't have a BIOS option to disable it, then you might want to try disabling it with ethtool at shutdown:
Code:
/usr/sbin/ethtool -s eth0 wol d
Even if a BIOS option to disable the WoL exists and you can use it, I'd still double-check with ethtool if it's still active and if positive maybe keep the ethtool command from above in the shutdown script.
 
Old 09-02-2018, 09:19 PM   #18
upnort
Member
 
Registered: Oct 2014
Distribution: Slackware, Proxmox, Debian, CentOS, Ubuntu MATE
Posts: 766

Original Poster
Rep: Reputation: Disabled
The BIOS supports WOL. I do not need WOL on this specific system but I would prefer to use the option.

I long have had a check in rc.local_shutdown that WOL is enabled. I did not test using ethtool to disable WOL on power down. I will try that with respect to observing whether the system continues to self-awaken.
 
Old 09-02-2018, 10:12 PM   #19
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 727

Rep: Reputation: 407Reputation: 407Reputation: 407Reputation: 407Reputation: 407
Actually you don't necessarily need to disable WoL with ethtool on power down, in /etc/rc.d/rc.6 for instance. It doesn't make any difference when you do it, you can put it in /etc/rc.d/rc.local, easier to manage.

I'm only using laptops for a while, years, personal preferences, but I do remember some PSUs were just powering on after a (very)short power drop. Not sure if you can manually simulate such an event - rapidly unplug/plug the power cord while the system is powered down, but an UPS providing backup to your computer can rule that out.

You wrote that you use: "I do use the RTC to awaken the system". Is your system self-awakening even if you don't use/disable that timer? It could be that BIOS function misbehaving.
 
Old 09-03-2018, 11:52 AM   #20
upnort
Member
 
Registered: Oct 2014
Distribution: Slackware, Proxmox, Debian, CentOS, Ubuntu MATE
Posts: 766

Original Poster
Rep: Reputation: Disabled
Disabling WOL on power down worked but proved nothing. The system did not self-awaken although I did not repeat the test as many times as previously. I need to power down about two dozen times to provide some degree of certainty.

The BIOS is configured not to do anything on a return of power. The PSU could be a suspect, but I am not yet pursuing that possibility.

Curious to me is the way the system has never self-awakened after the first event. The system always remains powered down after the first self-awaken. This is a clue. I just don't know what the clue means.
 
Old 09-03-2018, 01:39 PM   #21
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 727

Rep: Reputation: 407Reputation: 407Reputation: 407Reputation: 407Reputation: 407
Quote:
Originally Posted by upnort View Post
Curious to me is the way the system has never self-awakened after the first event. The system always remains powered down after the first self-awaken. This is a clue. I just don't know what the clue means.
Have you tried to get some help from Asus? Seriously, send them an e-mail/open a support request and let them break their heads

P.S.
That's a premium board:
https://www.asus.com/Motherboards/Z170-K/
And the latest BIOS is:
Version 11.8.55.3510 2018/08/27
https://www.asus.com/us/Motherboards...HelpDesk_BIOS/
- try flashing it and check how it performs before getting in touch with Asus

Last edited by abga; 09-03-2018 at 01:44 PM. Reason: P.S.
 
Old 09-03-2018, 02:19 PM   #22
upnort
Member
 
Registered: Oct 2014
Distribution: Slackware, Proxmox, Debian, CentOS, Ubuntu MATE
Posts: 766

Original Poster
Rep: Reputation: Disabled
Quote:
And the latest BIOS is:
Version 11.8.55.3510 2018/08/27
That is the MEUpdate tool. The latest BIOS is 3805, which I have installed.
 
Old 09-03-2018, 04:07 PM   #23
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 727

Rep: Reputation: 407Reputation: 407Reputation: 407Reputation: 407Reputation: 407
Quote:
Originally Posted by upnort View Post
That is the MEUpdate tool. The latest BIOS is 3805, which I have installed.
Indeed it's the ME update, for which you need to boot Redmond 10 I suppose
It's not Intel AMT, fully autonomous even when the system is powered down, but still, I would upgrade that Intel ME firmware too.
https://en.wikipedia.org/wiki/Intel_ME
"The subsystem primarily consists of proprietary firmware running on a separate microprocessor that performs tasks during boot-up, while the computer is running, and while it is asleep."
... it never sleeps
 
Old 09-03-2018, 04:28 PM   #24
upnort
Member
 
Registered: Oct 2014
Distribution: Slackware, Proxmox, Debian, CentOS, Ubuntu MATE
Posts: 766

Original Poster
Rep: Reputation: Disabled
Quote:
for which you need to boot Redmond 10 I suppose
Don't have Windows installed and I'm not wasting my time installing a spare drive and disconnecting my current drives just to update ME. Considering the whole Intel story the past year along with the infamous ME nonsense, I am unlikely to buy an Intel CPU again. Love their video drivers though. Nonetheless, f-ck 'em.
 
Old 09-10-2018, 02:45 PM   #25
lazardo
Member
 
Registered: Feb 2010
Location: SD Bay Area
Posts: 198

Rep: Reputation: Disabled
I used to fixate on these low-level problems back when hardware required minimal understanding of bus slots/interrupts and obscure jumpers as there was always a deep satisfaction reward.

Don't miss it at all.

Quote:
Power On by PCI-E/PCI is enabled.
What this actually means is that a wake signal by any device on the PCIe bus can wake the system, and almost all PCIe devices have the ability to manage power which includes wake/sleep.

If you've eliminated the clock/bios battery, spurious magic packets, RTC and BIOS settings, then it is down to three:
a) a PCIe device other than NIC
b) system is not actually shutting down, rather warm booting in an odd way
c) ME evil (I shut off all of the intel "professional management tools/spyware_vectors" with a "purge big server environment bits" pass through the kernel config).

As suggested earier, remove all PCIe devices (eg, anything capable of I/O) and set up a line at the top of /etc/rc.local that issues the very same shutdown sequence after a delay, eg:
Code:
echo "1m sleep starts now"; sleep 1m; /sbin/shutdown -h now
If you need the NIC in place, remove the cable after sleep starts. No cable, no magic packet.

I always downloaded the drivers from realtek as they were very good about keeping several fix cycles ahead of the kernel driver http://www.realtek.com.tw/downloads/...Downloads=true

Cheers && pls file a discovery report

Last edited by lazardo; 09-10-2018 at 02:46 PM.
 
Old 09-21-2018, 11:55 PM   #26
upnort
Member
 
Registered: Oct 2014
Distribution: Slackware, Proxmox, Debian, CentOS, Ubuntu MATE
Posts: 766

Original Poster
Rep: Reputation: Disabled
Quote:
What this actually means is that a wake signal by any device on the PCIe bus can wake the system, and almost all PCIe devices have the ability to manage power which includes wake/sleep.
For the curious, I pulled all PCI/PCIe cards and reenabled WOL. Consistent with other tests, the system again reawakened but not every time I powered down.

Quote:
ME evil
For many years I have blacklisted the mei* kernel modules. Nothing related in the BIOS is enabled.

Quote:
If you need the NIC in place, remove the cable after sleep starts. No cable, no magic packet.
In previous posts I shared that powering down the router or pulling the cable made no difference.

Same conclusion as originally: a bug in the r8169 NIC module, the BIOS, or both.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Feedback on TV antenna and on Star Wars: The Force Awakens Fixit7 General 1 12-23-2015 09:20 AM
How to disable automatic login 10.04 everytime computer awakens? gunrun705 Linux - Newbie 2 05-10-2010 12:22 PM
LXer: The Android Awakens LXer Syndicated Linux News 0 09-24-2008 01:30 AM
LXer: Asterisk awakens open source love in telecom entrepreneur LXer Syndicated Linux News 0 01-03-2008 01:50 AM
How to Actually powerdown?? chutsu Slackware 9 09-13-2004 05:53 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration