-   Slackware (
-   -   System lock when closing laptop lid on 12.2 (

brixtoncalling 03-30-2009 03:39 AM

System lock when closing laptop lid on 12.2
I recently installed 12.2 on my Lenovo n500 laptop, replacing 12.1.

There's one thing that's been causing me headaches though. Whenever I close the lid, the system freezes and I have to do a hard reboot.

I'd be happy if closing the lid did nothing. With 12.1 I changed nothing except the klaptop "button actions" to "off", but this has no effect in 12.2.

My /etc/acpi are the defaults (ie doing nothing) and I haven't changed any BIOS settings between the two installs.

Any suggestions as to what might be the problem?


Feinom 03-30-2009 04:26 AM

Have you checked that "" doesn't contain any 'LID' entry? I know it isn't there by default, but maybe it got added by something else.

Didier Spaier 03-30-2009 04:52 AM

You could just blacklist the button module.

Probably you will loose software-controlled power-off too then (it's the same driver).

Anyway first try "rmmod button", close the lid and see what happens.

brixtoncalling 03-30-2009 08:45 AM

I checked everything in /etc/acpi and there's nothing there.

I guess that would be temporary solution but I'd rather be able to control what happens with the lid and to retain software controlled power-off.

Thanks for the answers.

Feinom 03-30-2009 08:51 AM

Is the /etc/acpi directory emtpy? My default installation has the acpi_handler script and a directory called "events" which contains a file named "default".

Didier Spaier 03-30-2009 10:53 AM

I agree with Feinom, you should have that an "events" directory and a "acpi_handler" file in /etc/acpi.

If no, get acpid-1.0.8-i486-2 package and (re)install it. as root:

upgradepkg --install-new --reinstall acpid

allend 03-30-2009 11:45 AM

I have my laptop setup for suspend to ram when the lid is closed.

In /etc/ecpi/ I have a line

case "$2" in
power) /sbin/init 0
lid) /usr/sbin/pm-suspend
Using 'visudo' I have a line under User privilege specification
<username> ALL = NOPASSWD: /usr/sbin/pm-suspend

Also, the user has been made a member of the 'power' group.

In KDE, I have the power management set so that closing the lid does nothing.

Thanks to rworkman, Slackware now has pm-utils!

brixtoncalling 03-30-2009 02:17 PM

Sorry, I meant to say there is nothing there except the default files ( and events/default).

Through trial and error I found that choosing "Off" as the action for "Lid Switch Closed" in Klaptop is causing the crash. If I choose something like "logout" then I do not get a lock up. Is this possibly a klaptop problem?

brixtoncalling 03-31-2009 02:21 AM

To update a bit, I can't seem to predictably prevent this locking up no matter how much I play with klaptop. Sometimes I can get it to log out on close but usually it is a crash. The same thing happens when I am logged in at the terminal (no X running).

Besides the files in /etc/acpi what should I be looking at? I can find nothing in /var/log/syslog except that is correctly catching the lid close (I added a little logger message to test it).

Didier Spaier 03-31-2009 04:05 AM

I would avoid using KDE settings for ACPI. Personally I don't use it at all.

Go to Control Center/Power Control/Laptop Battery and disable everything in the ACPI tab.

Other than that I tried "rmmod button". In fact I still can shutdown through software (e.g. "shutdown -r now" or "halt"); the only difference is that when I hit the ON/OFF button nothing happens (usually it triggers the "halt" command).

brixtoncalling 03-31-2009 06:51 AM

Well I did not find the source of the problem per se, but an upgrade to kernel 2.6.29 has solved it. Things worked fine with the 12.1 default kernel but not with the one that shipped with 12.2.

At least I've learned to love pm-utils -- allend's setup works better than klaptop.

Thanks all.

All times are GMT -5. The time now is 04:39 AM.