-   Slackware (
-   -   system freezes after upgrading kernel (

samac 02-18-2005 06:33 AM

system freezes after upgrading kernel
I had to upgrade to 2.6.10 (from /testing) so that I could get my new (to me) graphics card working.

It is now working, and most of the things that the upgrade broke are fixed.

However this is the third time that I have started this thread, because each of the other two time the system has frozen. A complete lock up which required a reset.

These freezes are apparently random, and on looking in the logs and dmesg appear to have no cause.

Am I just looking in the wrong place or is there a problem with 2.6.10


egag 02-18-2005 07:40 AM

well....can you give your hardware-setup. ?
if i understand correct, this occured after installing a " new " graph. card. ?
if it's pci, you could try another slot.
otherwise reseat the card. ( might be just a bad contact. ).


keefaz 02-18-2005 09:06 AM

Post your video card specs, if it is agp, maybe the lock up is due to a bad setting in bios or something wrong with agp module/video card driver, it may be a RAM problem too...

What driver do you use for your card in /etc/X11/xorg.conf ?

samac 02-18-2005 10:55 AM

I am replying from my backup system Slackware 10.1 (2.4.29) because the 2.6.10 was freezing too often to even get this reply typed.

2.4.29 seems stable therefore I would suggest that the problem is not hardware related, but rather configuration related.

I created a script that gives tons of information and writes it all to a file called si.txt (1300+ lines), but then realised that you could not post attachments.

So I have posted it to

A thought that I had, was to run an upgrade using:

upgradepkg --reinstall --install-new /root/packages/*/*.tgz

just to see if that would help (but with my luck it wouldn't)

Or perhaps rebuilding the kernel modules (see previous line)


egag 02-18-2005 11:00 AM

ah, if you're sure it's not a hw-prob. then the graph-driver could be it.
still don't know what hw. you use....? ( and what driver.. )


samac 02-18-2005 11:06 AM

See edit, I have added a massive nvidia bug report file.

samac 02-19-2005 05:21 AM


Kernel version 2.6.10 freezes with both "nvidia" driver and "nv" driver, whereas 2.4.29 is stable with "nv" driver.

Which suggests to me that the graphics card/driver combination are relatively stable and it is perhaps an interaction between them and the kernel, or in fact some other drivers and the kernel that is causing the problem.

I had a ssh conection between the Zaurus and the main machine during a crash to see if it was just the keyboard and mouse that were dead, and also to poke around to see if there were any clues, but the ssh terminal was frozen too, so it seems to be a system wide failure, not just X or the input devices.


keefaz 02-19-2005 07:33 AM

For the nvidia driver :
Did you try to comment your "VideoRam 262144" line in xorg.conf ?

Maybe an agp problem, try put that line, just below ' Driver "nvidia" ' :
Option "NvAGP" "1"

Then try :
/sbin/rmmod sis_agp
/sbin/rmmod agpgart

samac 02-19-2005 08:05 AM

I have modified xorg.conf, but am having big troubles removing the modules.

rmmod will not remove them as they are in use, and modifying /etc/rc.modules had no effect.

Where are they being loaded from?


keefaz 02-19-2005 08:10 AM

First exit X session, then rmmod nvidia (if present), rmmod agpgart and sis_agp (maybe try rmmod sis_agp before), then modprobe nvidia and startx

samac 02-19-2005 08:36 AM


Did that but the modules still would not remove. Eventually tried "rmmod -f" this temporarily disabled the modules.

insmod nvidia didn't work, yet modprobe nvidia did, but that appears just to have put sis_agp and agpgart back in.

How can you remove modules that are being used?

Is there a file that loads these modules at start, then I can modify it and reboot.


keefaz 02-19-2005 08:40 AM

If you're using hotplug (more than likelly with 2.6.10 kernel), tou could add sis_agp and agpgart in /etc/hotplug/blacklist to prevent them to load at boot

samac 02-19-2005 08:50 AM

OK that worked, now we will have to wait and see if the system is stable, I will update you.

Many thanks


samac 02-19-2005 09:02 AM

Three minutes later ...........

So now I'm back in 2.4.29, could I be better going back to my old graphics card and forgetting about "The joy of Doom3".

No I will not give up.

Any other suggestions keefaz

keefaz 02-19-2005 11:17 AM

At least you know it is not an agp problem. You can revert to default, comment the Agp line in xorg.conf and delete sis_agp and agpgart in /etc/hotplug/blacklist

I see you enabled Linux Plug and Play Support from your log, maybe try a kernel compilation without this option.

Make sure you did not enabled APM in config as you use ACPI

I see some "pciehp" error in your log, try put pciehp in /etc/hotplug/blacklist

All times are GMT -5. The time now is 08:47 PM.