-   Slackware (
-   -   system freezes (

zord 05-07-2005 08:58 AM

system freezes

I recently bought a new harddisk (Western Digital Raptor WDC740 SATA).
Since my mainboard supports only IDE I got a SATA controller as well (some noname product using a SiI 3112 chip).
I installed Slack10.1 (full) using the sata.i kernel for installation, afterwards I compiled my own kernel supporting SiI Sata.
Everything works fine so far, no problems with the hdd or the controller, the disk runs at the supposed speed (fast as hell ;) ).

I set up X using the latest nvidia drivers (I have a Gf2MX) and fluxbox as wm.

I hardly changed any software, just installed a few packages: aterm, torsmo and firefox instead of mozilla.

Everything works, as long as I don't browse the web.
Firefox (the package from as well as the official installer) works for a few minutes, but sooner or later the system freezes.
Konqueror kills it right away.

When it hangs, I still can move the mouse, but nothing reacts if I click on it, menu doesn't pop up on rightclick etc.
The keyboard is totally dead, I can't even switch numlock on/off anymore, can't kill X with Ctrl+Alt+Bs and can't switch to another login terminal with ctrl+alt+f2
But the machine still responds to pings and I can still access via ssh. There everything seems to be fine, I can run programs, kill processes, etc.
But killing firefox/konqueror won't bring it back to life, I have to reboot via ssh.

First I tought, the system will just crash under high load, but this doesn't seem to be it. I can use way more heavy weight applications, like e.g. eclipse without any problems. Compiling stuff (new kernel etc.) also was never a problem.
So I also don't think it's a heat problem of the hdd, because I can do what I want, but the moment konqueror starts up, it hangs.

The rest of the hardware used works fine, I had suse, slack10.0 and gentoo running on the same system (except the new hdd) for month without any problems.

X is set up correctly for sure, the same configuration worked for the same Xorg version with the same graphicsboard and monitor before.

It's also not a network problem, that is configured correctly via dhcp. Also firefox works for some time, and I can dl anything using wget.

There are no errors in syslog or in the Xorg log.

I don't think it's an configuration-error in the kernel, since a) I have succesfully compiled a kernel for this machine for quite a few times and b) the same thing happens with the 2.4.29 generic sata.i kernel from the slackware cd.

My system:
athlon xp 2600+
Asrock K7S8X (SiS 746)
512 ddr 400

I'm getting out of ideas, what I can do, where I could find a hint of whats wrong
Any suggestions?
Thanks a lot.
Let me know, if you need to know anything, any specific logs, etc.

trickykid 05-07-2005 09:38 AM

My first guess and assumption would be that your new SATA controller for your hard drive is conflicting with your ethernet, possibly by IRQ conflict, etc.

zord 05-07-2005 10:23 AM

thx for the suggestion.
What could I do about that?
I just tried using different pci slots (lot's of combinations), but that didn't change a thing.
Somehow always eth0 and the nvidia module share an interrupt.
That's the output of cat /proc/interrupts:

root@eder:~# cat /proc/interrupts
  0:    130272          XT-PIC  timer
  1:        78          XT-PIC  i8042
  2:          0          XT-PIC  cascade
  3:      6680          XT-PIC  libata
  8:          1          XT-PIC  rtc
  9:          0          XT-PIC  acpi
 10:          0          XT-PIC  ehci_hcd
 11:      8335          XT-PIC  eth0, nvidia
 12:        213          XT-PIC  i8042
 14:        12          XT-PIC  ide0
 15:        11          XT-PIC  ide1
NMI:          0
ERR:          1

zord 05-07-2005 12:31 PM

I reinstalled the whole system and tried again, this time staying with mozilla, but same problem there. :/

xushi 05-07-2005 01:51 PM

did you have linux installed on this machine before you bought the new HD? If yes, did it work well?

Also, Might it be a graphics problem?

I had the exact same problem on my laptop, but with an ATI card and ATI's drivers. Certain things made it crash where only the mouse worked, and nothing else.

Eventually, i realised that i can still ssh into the machine from another computer, but i couldn't kill any proccesses.. They just stayed there, or changed into a .. <defunct> process.

When i disabled the ATI drivers, everything went back to normal.

Try using the computer without X... through CLI, copy data to and from the hard disks, and so on.. to see if the problem is infact from the hard disk(s).

zord 05-07-2005 02:53 PM

Thank you very much, you just made my day ;)
It was indeed a graphics problem.
When I installed the nvidia drivers, I got the latest from, because the one's I used before with Slack 10.0 refused to compile.

Now after reading your post I switched the driver back to nv, and it worked.
After trying around a bit, I found out that the line Option "RenderAccel" "true" of my xorg.conf seemed to cause the problem.
No idea why that is, I had no problem using this option so far, but anyways I'm happy now :D

xushi 05-07-2005 03:13 PM

hehe, glad to be of help =)

Its strange to see this happening. Did you see if you need any specific patches installed in order to have the latest nvidia and 2.6 kernel running well?

zord 05-07-2005 03:24 PM

No, no patches at all, I installed Slack10.1 full, compiled the kernel and installed the Nvidia drivers.
I use that in my xorg.conf

Section "Device"
    Identifier  "gf2mx"
    Driver      "nvidia"
    VideoRam    32768
    Option      "NoLogo"      "true"
#    Option      "RenderAccel" "true"
    Option      "NvAgp"      "1"

I didn't try much open gl stuff yet, but at least glxgears works. :)

davidsrsb 05-08-2005 12:53 AM

I have machines that cannot use recent versions of the Nvidia driver, but which work well with older versions.

All times are GMT -5. The time now is 06:51 AM.