LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-23-2007, 04:50 PM   #1
dracolich
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 1,182

Rep: Reputation: 47
system clock adjusts for time zone every startup


This one's been bugging me since daylight savings ended on Nov. 4. Every time I start the computer the hardware clock is correct but the system clock is -5 hours (GMT -5). I can manually adjust it with the date or hwclock commands but the next time I start it the same thing happens. This machine dual boots Slackware 12 and Win2K. Win2K doesn't have the problem, the BIOS clock is correct and my laptop, running Slackware 12 only, doesn't have the problem.

I compared /etc/adjtime to the laptop and tried deleting it. Both computers use localtime and don't have anything /etc/sysconfig. I tried booting into Windows and changing the time. When daylight savings ended the clock didn't adjust itself although I have the patched glibc-zoneinfo and /etc/localtime is linked to the correct file in /usr/share/zoneinfo. The laptop did change correctly. I could probably work around it by setting the hwclock +5 but that wouldn't really solve the problem.

Or am I wrong and the hwclock should be +5 and the laptop is the one that's wrong?
 
Old 11-23-2007, 05:25 PM   #2
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
Check this (last post): http://www.linuxquestions.org/questi...an-4.0-596526/
 
Old 11-24-2007, 05:50 AM   #3
evilDagmar
Member
 
Registered: Mar 2005
Location: Right behind you.
Distribution: NBG, then randomed.
Posts: 480

Rep: Reputation: 31
Or, less gnomically...

Win2k requires the hardware/BIOS clock be stored in your local time, i.e., if the clock on your wall says it's 5:23pm, that's what you need to set the BIOS to.

Then you need to run timeconfig, and select "NO Hardware clock is set to local time", or just edit /etc/hardwareclock and change "UTC" to "localtime".

Vista supposedly doesn't have the "DOS Backwards Compatibility" requirement that is the reason/excuse Microsoft made everything screw up horribly if you try to tell say, XP to use UTC for the clock, but I'll believe it when I see it.
 
Old 11-24-2007, 08:20 AM   #4
dracolich
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 1,182

Original Poster
Rep: Reputation: 47
Thanks for the link, Alien_Hominid. All I needed was the --localtime switch. I know I searched here at least twice but I didn't see that thread. I'm adding this to my notebook for future reference.

evilDagmar, that's why I dusted off my Win2k and booted into it forcing it to save some changes. I'll believe Vista's "improvements" when I see them, too, which I hope isn't anytime soon.

Thanks, guys.
 
Old 11-24-2007, 01:12 PM   #5
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
XP isn't really DOS compatible. NTVDM is crap. If anyone needs real DOS compatibility, he needs to use DosBox.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to get Time Zone information from the system chowdhary_g Programming 12 04-04-2014 09:56 PM
Where does RH8 daily set system time to hardware clock time smartnorman Red Hat 1 05-24-2006 03:42 PM
Various clock issues: Clock shows wrong time only in Knoppmyth, & CMOS time change ? davidbix General 1 04-05-2006 10:58 PM
Setting System Time: kernel in wrong time zone warrenweiss Linux - General 7 05-15-2004 04:25 PM
Time Zone, Clock, Nothing is Right pzorn Linux - General 1 10-31-2003 03:31 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration