LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-25-2015, 10:35 AM   #1
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,103

Rep: Reputation: 157Reputation: 157
Question syndaemon and disabling touchpad while typing


Greetings!

It appears that either the new kernel or xorg has broken the way syndaemon disabled the touchpad while typing. I've been googling around, but have been unsuccessful so far. I remember running the 3.17 kernel version a while back on 14.1 and running into the same issue. So, my guess is that the problem points to the kernel.

I had this bit of code in my autostart:
Code:
syndaemon -R -k -i 1 -d
Even using xinput doesn't work. So, I'm a bit out of ideas. Any help would be appreciated.
 
Old 04-26-2015, 08:56 AM   #2
Bertman123
Member
 
Registered: Jun 2010
Distribution: Slackware 14.1 64 bit MLED with XFCE 4.12
Posts: 331

Rep: Reputation: 69
If you use the KDE desktop you can install kcm_touchpad from slackbuilds. That will allow yuo to configure the touchpad from the system settings.
 
2 members found this post helpful.
Old 04-26-2015, 10:18 PM   #3
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,103

Original Poster
Rep: Reputation: 157Reputation: 157
Quote:
Originally Posted by Bertman123 View Post
If you use the KDE desktop you can install kcm_touchpad from slackbuilds. That will allow yuo to configure the touchpad from the system settings.
I tried both kcm_touchpad and flsynclient without any success.
 
Old 04-26-2015, 11:49 PM   #4
travis82
Member
 
Registered: Feb 2014
Distribution: Slackware
Posts: 425

Rep: Reputation: 202Reputation: 202Reputation: 202
Quote:
If you use the KDE desktop you can install kcm_touchpad from slackbuilds. That will allow yuo to configure the touchpad from the system settings.
also xfce has a built-in tool to configure touchpad which works fine for me.
 
3 members found this post helpful.
Old 04-27-2015, 07:39 AM   #5
stormtracknole
Senior Member
 
Registered: Aug 2005
Distribution: Slackware, RHEL
Posts: 1,103

Original Poster
Rep: Reputation: 157Reputation: 157
Man, I feel like an idiot. I completely got tunnel vision and did not notice the extra settings for the touchpad. Disable while typing now works as intended. Thank you both for your tips. Marking this as solved.
 
1 members found this post helpful.
Old 06-02-2018, 01:09 PM   #6
Lysander666
Senior Member
 
Registered: Apr 2017
Location: The Underearth
Distribution: Slackware, Devuan, Xubuntu
Posts: 1,297
Blog Entries: 3

Rep: Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249
Quote:
Originally Posted by travis82 View Post
also xfce has a built-in tool to configure touchpad which works fine for me.
Sorry for the necro, could someone please confirm that this refers to

Code:
syndaemon -i 2.0 -K -R
and no other setting in LXDE? The above works fine but I wonder if there's anything else I'm missing. I can't see separate settings for the touchpad, neither in Mouse/Keyboard settings.
 
  


Reply

Tags
disable, synaptics, syndaemon, touchpad


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Disabled touchpad while typing? salparadise Slackware 6 11-16-2012 01:32 PM
[SOLVED] touchpad interfering with typing in Squeeze (Debian) Gnome. edbarx Linux - Laptop and Netbook 6 02-26-2012 05:52 AM
lubuntu: syndaemon loading twice from autostart, won't release touchpad. Mountain Man Ubuntu 0 12-07-2011 12:23 PM
Touchpad disable/enable typing. zuriel45 Linux - Software 2 01-21-2011 08:42 AM
Disabling Touchpad while typing. nardz Linux - Desktop 4 01-24-2008 04:33 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration