LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   synaptics Touchpad & USB mouse in slack 10 (https://www.linuxquestions.org/questions/slackware-14/synaptics-touchpad-and-usb-mouse-in-slack-10-a-212633/)

mehargags 08-02-2004 04:59 PM

synaptics Touchpad & USB mouse in slack 10
 
sometime ago i posted a thread regarding this & got the solution for making both of them work simultaneously but recently installed the new Slack 10 & as all know it comes with the new X.org. the above configuration is again not Working with my laptop. the touchpad works Fine but when i Plug in my USB mouse ,the Light glows but it doesn't function..
can some one Suggest me how to make it Work with the New X

this worked for me earlier Fine:

Section "InputDevice"
Identifier "UsbMouse"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
EndSection

then make an entry to the serverlayout

InputDevice "UsbMouse" "AlwaysCore"

am i missing something

canllaith 08-10-2004 12:19 AM

This works for me under slackware 10 :)

In my xorg config, I have for both devices:

(Mouse1 is my touchpad)

Section "InputDevice"

Identifier "Mouse1"
Driver "mouse"
Option "Device" "/dev/psaux"
Option "Protocol" "PS/2"
Option "Emulate3Buttons"

EndSection

Section "InputDevice"
Identifier "usbmouse"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxis Mapping" "4 5"

EndSection

Then, under ServerLayout:

Section "ServerLayout"
Identifier "Simple Layout"
Screen "Screen 1"
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "usbmouse" "SendCoreEvents"

EndSection

mehargags 08-10-2004 02:10 AM

I've Resolved the issue as well. The same old Freind Helped & recommended me to use the utility " X -configure" at run level 3 in Console. it made me an xorg.conf file at /root.
The new File had the Specifications of my Detected hardware --- perfectly matching the Configuration. & i added the same Lines into it -- The mouse worked after that.

Just one Question. If i start X whithout the mouse Plugged in it is never Taken by my X again until i restart X with the mouse Plugged in. though once it is Working i can hotswap it any time & it works again .

I used the "alwayscore". Can u tell me the Difference with "sendcoreevents". Will it resolve the Mouse issue if it is not Plugged in b4 starting X

Thx anyways for anticipating

canllaith 08-10-2004 04:47 AM

Yes, using SendCoreEvents should allow you to startx without the mouse plugged in, and then have it function when you plug it in. SendCoreEvents basically means the device is a secondary pointer device, rather than *the* CorePointer.

mehargags 08-10-2004 07:50 AM

no The SCENE remains the Same even if i use the "SendCoreEvents"..
Any other resolution ??

canllaith 08-10-2004 06:19 PM

I can only suggest that you have something configured incorrectly, as it works fine here.


All times are GMT -5. The time now is 01:08 PM.