-   Slackware (
-   -   Switching keyboard layouts - need some help (

dreamwalking 02-18-2013 06:46 PM

Switching keyboard layouts - need some help

I run Slack 14 with windowmaker as a window manager.

I had it configured to switch between English and Greek keyboard with alt_shift, which worked smoothly in all applications except terminal and gvim. Since I've occasionally needed to type in Greek in text editor or terminal, I decided to follow the instructions given in and edited the /etc/X11/xorg.conf.d/90-keyboard-layout.conf:

Option "XkbLayout" "us,el"
#Option "XkbVariant" ""
Option "XkbOptions" "terminate:ctrl_alt_bksp"
Option "XKbOptions" "grp:alt_shift_toggle"
After restarting X, I could input Greek characters just fine, but I couldn't use alt_shift anymore to switch between layouts in any application (I had to manually click on the keyboard status button that wmaker adds to windows when its configured with --enable-modelock option).

That's about when I started to panic a bit and renamed the
/etc/X11/xorg.conf.d/90-keyboard-layout.conf file so that it doesn't get read and rebooted. After that, I haven't been able to switch keyboard layouts again, despite the fact that I define two different layouts in both my xorg.conf and x11-input.fdi. Putting back the 90-keyboard-layout.conf after all this, didn't make any difference either.

I'm not very computer-savvy and I don't have a clue where to start when it comes to troubleshooting - I'm certain that I messed up in something very basic here. I'd appreciate any pointers where to look or what I've been doing wrong.

Thanks in advance

my xorg.conf:

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "us,el" #xkeymap0
Option "XkbOptions" "grp:alt_shift_toggle,caps:capslock,eurosign:e,numpad:pc,terminate:ctrl_alt_bksp"
my /etc/hal/fdi/policy/x11-input.fdi

<merge key="input.x11_options.XkbModel" type="string">pc102</merge>
<merge key="input.x11_options.XkbLayout" type="string">us,el</merge>
<merge key="input.x11_options.XkbOptions" type="string">grp:alt_shift_toggle</merge>

dreamwalking 02-19-2013 05:27 AM

Nevermind, I solved it.

Should not make changes late at night and then get all panicky when they don't work out...

All times are GMT -5. The time now is 07:40 AM.