-   Slackware (
-   -   swaret "Missing Libraries" question (

plan9 06-02-2004 09:43 PM

swaret "Missing Libraries" question

I thought that i'd ask this here as the swaret forum seems kinda slow. I am trying to get all my libraries up to date using swaret (it's a great program, huh?) and I get the following error when I run #swaret --dep
Listing missing Packages...
Search for (, needed by 'kdegraphics-3.2.2-i686-1'!
Search for (, needed by 'kdemultimedia-3.2.2-i686-1'!
Search for (, needed by 'kdevelop-3.0.3-i686-1'!
Search for (, needed by 'kdegraphics-3.2.2-i686-1'!
Search for (, needed by 'kdemultimedia-3.2.2-i686-1'!

Obviously I need to sniff these libraries out on the net, google will do that most likely. My question is this: How do you install a library in Slackware, and will swaret know that it's been done (i'm sure i'll have to run #updatedb to get slocate to up to date).



plan9 06-02-2004 10:01 PM

never mind the "how to install a library in slackware" question... they should come in tgz's, right? Does anyone know what packages the above libraries come in? Finding them with google wasn't as easy as I thought.



nazim 09-03-2005 07:32 PM

I know this is a bit late for the original poster, but if anyone's searching for, you need to install the fribidi package from the Slackware repository/CDs.

nukey 09-03-2005 07:39 PM

If someone wants to search for libraries, just go to the slackware website and use the package browser, direct link:

Just search for (a part of) the filename

Needed it half an hour or so, was missing libsasl or something like that (when i ran "newaliases").

shilo 09-04-2005 12:20 AM

I am running a -current system (using SWareT) and I have the following:


You currently have installed:


Note the differences:

1) Your versions are older

2) Your packages are compiled for i686, whereas mine are compiled for i486

3) Mine are from official Slackware mirrors. Due to the previous differences, I would guess that your's are not.

What would I do to resolve your current state? Remove all repositories (including for /etc/swaret.conf. Try updating again. Possibly set /etc/swaret.conf to -current.

You have third party packages. Never can tell exactly how they were compiled (unless they provided a SlackBuild script, and you like reading bash). Don't use third party packages unless you need to.

All times are GMT -5. The time now is 04:47 AM.