-   Slackware (
-   -   SW12.1 IEC958 audio skip (

Yogstr 09-07-2008 07:03 AM

SW12.1 IEC958 audio skip
Have Slackware 12.1 installed on an ABIT IC7 MAX mobo. (snd_intel8x0 / ac97) ICH5 chipset.

Configured to send audio through SPDIF, either via KDE control centre (override device location > spdif), or at an application level (eg Amarok plug:spdif). The result is that audio skips every 2-3 seconds. Audio configured via kmix or KDE control center, or Amarok to the plugged in PC speakers is ok. Sample frequency via KDE control center is set to 48Khz.
There are no messages i can see in dmesg or logs relating to alsa errors, that i can see.

I tried removing the sw packages and re-compiling Alsa, Xine, and Amarok from the latest source. Still the same skip.
I am at a loss as to what to try next, and thought i might have a hardware problem, except that i also have Ubuntu hardy herron installed, and SPDIF via Rhythm Box works fine. Something amiss in my configuration, but not sure what.

Any help appreciated. Cheers

keefaz 09-07-2008 07:59 AM

Maybe look for modprobe options in /etc/modprobe.d/ or /etc/modprobe.conf in Ubuntu
look also at /etc/asoundrc file (if it exists)

Some interesting links:

All times are GMT -5. The time now is 01:55 PM.